locked
Coupure réseau entre serveur TSE et base oracle RRS feed

  • Question

  • Bonjour,

    Je viens vers vous aujourd'hui car nous subissons un problème très important.

    Nous disposons d'un serveur TSE en 2008 R2 virtualisé, un serveur de licence en 2008 R2 virtualisé également et un serveur Oracle physique. (Les serveurs virtuels sont sur des ESX)

    Une application est installé sur le serveur TSE fait référence à la base de donnée Oracle.

    Le problème est que de temps à autre, complètement aléatoirement, la connexion entre l'application du serveur TSE et la base Oracle se perd. On le sait car la session TSE, elle, est toujours présente. C'est dans cette application que des messages d'erreurs Oracle apparaissent.

    Nous avons donc émis plusieurs hypothèses.

    -Le serveur TSE bascule d'un ESX à un autre, et par conséquent, il se peut qu'il y ait une micro coupure. Il s'avère que ce n'est pas ça, nous avons vérifié et le serveur n'a jamais changé d'ESX. Dans le doute, nous allons attaché le serveur TSE à un ESX unique.

    -Le serveur TSE demande au serveur de Licence au bout d'un certain temps un nouveau jeton pour les utilisateurs déjà connectés. Il y a très peu de chance que ça soit cela, je pense que Microsoft ont déjà pensé à ça, ils ne se permettraient pas de créer une micro coupure de la sorte, sous peine de faire des serveurs TSE, des outils totalement inutilisables. Et puis, c'est toutes les connexions à Oracle qui se perdent en même temps et non pas une connexion par une connexion.

    J'espère que vous saurez me guider dans ce cas très délicat.

    Je vous remercie par avance pour les réponses que vous pourrez m'apporter.

    Cordialement,

    Ludovic

    mardi 25 juin 2013 13:16

Réponses

  • Je reviens pour prévenir que nous avons trouvé d'où vient de le problème.

    C'était la résolution de nom. Notre serveur DNS était surchargé et quand il l'était TROP, la carte réseau créait une micro coupure. Et par conséquent, la résolution de nom du serveur Oracle ne se faisait plus.

    Nous avons donc changé les noms par les adresses IP.

    Le problème est maintenant résolu !

    Merci à vous !

    • Marqué comme réponse Ludovic3 mercredi 26 juin 2013 13:54
    mercredi 26 juin 2013 13:54

Toutes les réponses

  • Ete vous capable d'avoir des traces réseaux ? et le serveur Oracle va toujours bien ? (pas de %CPU a 100% en exemple)

    Un %CPU a 100% risque d'interrompte des connections au hasards, et si cela arrive durant de courte période cela peut semblé etre des micro coupure réseaux.


    MCP | MCTS 70-236: Exchange Server 2007, Configuring
    Microsoft Translator Widget - French moderator (Technet Wiki)

    Twitter - @yagmoth555 ()
    Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/

    mercredi 26 juin 2013 03:19
  • Bonjour, merci pour votre réponse.

    Je ne sais pas si le serveur oracle a des surcharge à 100%. Je vais regarder dans la journée.

    Pour ce qui est des traces réseaux, nous avons un nagios, mais il n'indique aucune alerte. Il ne voit aucune coupure malheureusement, ce qui rend la chose encore plus incompréhensible...

    Merci à vous pour vos pistes de réfléxion. Je viens tiens au courant le plus rapidement possible.

    En attendant, si vous voyez la moindre chose à vérifier, je suis tout à fait preneur


    EDIT : En ce qui concerne la surcharge du CPU à 100% sur le serveur Oracle, ça me parait étrange que nos applications installées directement sur les machines ne subissent pas ce problème. Seul l'application distribuées en TSE le subit. Je vais néanmoins vérifier. Toutes les pistes sont bonnes à vérifier.
    • Modifié Ludovic3 mercredi 26 juin 2013 07:09 EDIT
    mercredi 26 juin 2013 07:07
  • Je reviens pour prévenir que nous avons trouvé d'où vient de le problème.

    C'était la résolution de nom. Notre serveur DNS était surchargé et quand il l'était TROP, la carte réseau créait une micro coupure. Et par conséquent, la résolution de nom du serveur Oracle ne se faisait plus.

    Nous avons donc changé les noms par les adresses IP.

    Le problème est maintenant résolu !

    Merci à vous !

    • Marqué comme réponse Ludovic3 mercredi 26 juin 2013 13:54
    mercredi 26 juin 2013 13:54