none
WSUS 2012r2 et Windows 10

    Discussion générale

  • Bonjour,

    Je connais bien les prérequis nécessaire pour gérer un windows 10 via le serveur WSUS et ai lu cette doc

    https://docs.microsoft.com/en-us/windows/deployment/update/waas-manage-updates-wsus

    Toutefois, je voudrais savoir est ce que c'est obligatoire ?

    Lorsqu'on déploie un nouveau serveur 2012R2 et qu'on le met à jour avec la cumulative d'aout par exemple, on ne peut plus installer ces 2 prérequis qui semblent être intégrés dans la cumulative. J'ai fais le test en maquette et cela fonctionnait bien.

    Toutefois chez un client j'ai un comportement bizarre :

    Sur 2 postes Windows 10 bien configurés pour aller sur le serveur WSUS, il vont chercher leur mises à jour sur internet (passage 1607 -> 1703 alors qu'elle n'est pas approuvée sur WSUS).

    De plus la commande get-windowsupdatelog renvoie uniquement des GUID et donc il semblerait que le poste ne parvienne pas à télécharger les symboles. Cela a été testé sur tous ces postes Windows 10 et aucun ne parvient à générer un fichier lisible de windowsupdate.log

    On va donc tenter en téléchargant les symboles et utiliser la procédure adéquate, mais cela n'est pas un comportement normal et ne semble pas venir de son proxy qui laisse bien l'accés à cette URL à priori.

    Il y a donc 3 problèmes :

    1) Pourquoi les symboles ne peuvent pas être téléchargés

    2) Est ce qu'il est nécessaire de désinstaller la cumulative puis passer les 2 KB prérequis puis réinstaller la cumulative pour gérer les windows 10 ?

    3) Pourquoi ces postes windows 10 vont sur internet alors qu'ils ont un serveur WSUS de paramétrer (et qu'il n'y a pas de paramétrage renseigné pour différer les mises à niveau qui pourrait provoquer un dual scan)


    Merci de marquer comme réponse les sujets qui vous ont permis d'avancer afin que cela puisse être bénéfique aux personnes qui rencontrent le même problème.

    vendredi 29 septembre 2017 06:25

Toutes les réponses

  • bonjour,

    1) Probablement parce que votre client à réalisé un master et que celui-ci ne contient pas la librairie. La doc est ici : https://developer.microsoft.com/fr-fr/windows/hardware/download-symbols

    2) Normalement non. Mais c'est une bonne approche pour confirmer ou infirmer que le problème vient de là.

    3) Je commencerai par vérifier que la GPO est bien appliquée (base de registre et RSOP) puis que le client arrive à joindre le serveur tel qu'indiqué dans la base de registre.

    Je vous joint un troubleshoot guide (en anglais) : https://technet.microsoft.com/en-us/library/gg153542.aspx?f=255&MSPPError=-2147217396


    mardi 3 octobre 2017 19:30
  • Bonjour,

    Tout d'abord, merci d'avoir pris le temps pour lire et répondre.

    Pour le 1) Il a le problème avec des postes qu'il a masterisé lui mais également des postes qu'il n'a pas masterisé lui (sortie d'usine). Il doit faire un test en prenant un pc portable chez lui et lancer la commande, mais je pense qu'il a un élément réseau qui vient bloquer tout ca... C'est tellement fréquent ! Puisque les symboles sont sensé être téléchargés sur internet lors de la génération de la commande.

    2)Au final, sur 5 postes en windows 10 il en a 2 qui ont un fonctionnement normal et 3 qui vont sur internet faire le scan. On a réussi à déchiffrer une partie du windwosupdate.log en téléchargant les symboles a la mains et lancant un utilitaire en ligne de commande et voir qu'il y a bien la présence du serveur WSUS dans les logs.

    3) Tout ca est ok puisque c'est via le rsop que j'ai vu la présence de la gpo et je suis aller également vérifier le registre qui est ok (et le windowsupdate.log également pour le serveur wsus) et le client joint bien le serveur puisque la date de dernier contact et de report d'inventaire sont bonne...

    Je ne comprends vraiment pas ou chercher. Il doit essayer avec un poste windows 10 from scrach nouveau et voir le comportement de ce poste, mais je n'arrive pas a comprendre pourquoi ces 3 postes n'ont pas un comportement "normal"


    Merci de marquer comme réponse les sujets qui vous ont permis d'avancer afin que cela puisse être bénéfique aux personnes qui rencontrent le même problème.

    mardi 3 octobre 2017 20:24
  • Hmm, je viens de me rappeler de la petite option qui tue : n'aurait-il pas configurer le serveur WSUS pour minimiser l'espace de stockage en ne conservant pas les sources sur le serveur ? 

    mardi 3 octobre 2017 20:59