none
Problème de réplication Hyper-V RRS feed

  • Question

  • Bonjour à tous, 

    je rencontre un problème pour une bascule hyper-v sur un serveur réplica

    Je précise que je n'ai jamais effectué cette opération, mon poste (suite au rachat d'une société par mon employeur) m'impose de réaliser un test sur l'infrastructure d'un client, infra que je n'ai pas mise en place, je pars de 0 car je n'ai eu aucun transfert de compétence, je suis donc dans le flou absolu.

    Architecture existante : 

    2 serveurs physiques Hyper-V, 1 de production et 1 utilisé pour la réplication

    Sur ce serveur sont présent 2 VM : 

    1 serveur, contrôleur de domaine

    1 serveur TSE

    La réplication a été activée pour les 2 VM et pointe sur le 2è serveur Hyper-V (celui donc prévu pour le réplica), j'ai donc, en théorie, 2 VM identiques sur les 2 serveurs (par contre les machines physiques ne sont, elles, pas identiques)

    J'ai réalisé un 1er test de bascule début décembre pour tester le bon fonctionnement de la réplication, comme c'était une 1ere fois je n'ai peut être pas fait les choses correctement (certainement même vu que je poste ici car j'ai rencontré un problème)

    Ce test a été réalisé un weekend sans aucun utilisateurs de connectés sur les serveur

    Dans un 1er temps le serveur de production a été éteint électriquement, une fois cette opération effectuée je me suis connecté sur le serveur de réplica et j'ai activé la bascule (je n'ai pas fait le test de bascule mais simulé un sinistre nécessitant la remise en prod du serveur de réplica)

    C'est la que ca commence à se corser, tout d'abord j'ai eu quelques problèmes de connexion réseau (résolu en modifiant les paramètres réseaux des VM pour que celui ci remonte correctement), une fois ce problème résolu un 2è est apparu qui, manque de temps, a invalidé le test : le domaine, même si le DC était bien démarré et présent sur le réseau, "n'existait pas"

    Impossible donc de me connecter au serveur TSE depuis un poste de travail autrement qu'avec le compte administrateur local (et même chose pour le contrôleur de domaine)

    J'ai fait quelques recherches à ce sujet mais je n'ai pas réussi a trouver d'infos intelligible pour résoudre mon problème, je me tourne donc vers vous pour espérer une réponse

    Bien évidemment autour de moi personne ne connaît Hyper-V, car ma boite bosse avec VMWare

    Je peux, bien sur vous fournir le maximum d'informations qui seraient nécessaire à la compréhension de l'archi cliente

    mardi 12 janvier 2021 11:16

Toutes les réponses

  • Au niveau des contrôleurs de domaine si tu as deux hyperviseurs il est préférable de mettre un contrôleur de domaine actif sur chaque serveur, ce n'est pas le meilleur choix que de faire un réplicat de DC.

    Quel version d'OS pour les VMs ? Tu as d'autres rôles sur les DCs ?

    Les deux hyperviseurs ont un hardware identique ou assez proche ?

    Il n'est pas recommandé d'utilisé des snapshots sur les DCs, même si cela est supporté à partir de 2012.

    C'est plus dur a diagnostiquer maintenant, vu que l'on ne peut pas tester. Au moment du test tu as pu faire un dcdiag sur le DC? Tu as vérifier les paramètres IPs, DNS et la résolution ?

    mardi 12 janvier 2021 11:30
    Modérateur
  • Bonjour, 

    merci pour ta réponse,

    alors dans l'ordre : 

    - Tous les OS sont en windows 2012R2 (hyperviseur et VM)

    - les 2 machines sont des serveurs Lenovo, mais de génération différentes (X3650 M5 pour le réplica et SR630 pour le serveur de prod : 

    https://www.lenovo.com/fr/fr/data-center/servers/racks/System-x3650-M5/p/77XS7HV7V64 acheté en 2015

    https://www.lenovo.com/fr/fr/data-center/servers/racks/ThinkSystem-SR630/p/77XX7SRSR63 acheté en 2018

    - Le DC a les rôles de serveur DHCP et DNS

    - j'ai plusieurs erreurs dans dcdiag : concernant la réplication echouée avec un ancien controleur de domaine (AD2) qui est éteint depuis maintenant plusieurs mois  (un aurte serveur encore plus ancien) vers le contrôleur de domaine actuel (AD)

    - idem un nslookup (en CMD) renvoie une erreur concernant ce même serveur :

    DNS request timed out

    timeout was 2 seonds.

    Serveur par défaut :  Unknown

    Address : @IP du serveur éteint

    Le même nslookup lancé directement depuis la console mmc du DNS pointe bien sur le DC actif

    Il y a donc effectivement un problème du côté du DNS mais qui, en prod, n'est pas visible (les utilisateurs se connectent au serveur TSE en rentrant le nom du serveur et non son adresse IP)

    Dans le gestionnaire DNS j'ai bien le DC qui apparait comme serveur de nom mais en creusant un peu je tombe sur plusieurs entrée dans la zone de recherche directe

    _tcp qui correspondent à des serveurs qui n'existent plus (des clés _gc, _kerberos, _kpasswd et _ldap pour cet ancien serveur qui font doublon avec celles du DC

    dans la zone de recherche inversée je retrouve aussi ce fameux serveur

    J'ai lancé un nettoyage des ressources obsolètes mais cela ne les supprime pas

    Une épuration (manuelle clé par clé ?) pour virer cet ancien serveur serait déjà une 1ere étape. reste les erreurs mises en avant par le dcdiag concernant cette réplication


    • Modifié G.BIZE mardi 12 janvier 2021 13:11
    mardi 12 janvier 2021 13:01
  • j'ai plusieurs erreurs dans dcdiag : concernant la réplication echouée avec un ancien controleur de domaine (AD2) qui est éteint depuis maintenant plusieurs mois  (un aurte serveur encore plus ancien) vers le contrôleur de domaine actuel (AD)

    Dans site et service AD, tu dois avoir encore un serveur qui n'existe plus en tant que partenaire.

    Il faut que tu fasses un metadata cleanup pour nettoyer ton AD, tu peux le faire avec ntdsutil ou avec les GUI http://pbarth.fr/node/94

    Il faut aussi que tu fasses le ménage dans tes zones DNS.

    Une fois que tu as rétabli et que tu as un DC propre, envisage d'ajouter un deuxième DC actif sur l'autre HyperV ou tu peux suivre son intégrité, plutôt qu'un basculement hasardeux sur un réplicat de VM. Conserve les scénarios de VM replicat pour les serveurs applicatifs.

    Mais cela dépend si tu as mis d'autres rôles sur les DCs que AD,DNS,NPS éventuellement DHCP.

    Quand tu reprends un site comme cela, fait systématiquement une pré analyse de l'état de santé (DCdiag, repadmin ...). En cas de problème, cela évite d'être induit en erreur par un problème qui traine de longue date.

    mardi 12 janvier 2021 17:57
    Modérateur
  • Merci pour tous tes conseils, 

    je vais tâcher de les mettre en oeuvre courant semaine prochaine :)

    Si j'ai besoin d'aide je sais ou faire toc toc ;)

    Bon week end

    vendredi 15 janvier 2021 17:03
  • Bonjour,

    Pouvons-nous considérer que vous avez résolu votre problème avec les scénarios proposés? Si les conseils vous ont aidé, veuillez marquer comme réponses les contributions pertinentes qui ont conduit à la solution.
    Si vous avez trouvé une autre solution, partagez-la avec la communauté afin que d'autres utilisateurs avec le même problème puissent profiter de cette solution.

    Merci d'avance!

    Cordialement,

    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.

    jeudi 4 février 2021 11:44