none
creation fichier .wsp pour une feature RRS feed

  • Question

  • bonjour,

    je veux creer un fichier .WSP pour une feature pour faciliter son deployment sur le serveur de sharepoint de production,pour cela j'ai procédé comme suivant:

    • j'ai vus que je ne pourrai pas le crérer avec VS 2010
    • j'ai ajouté WSPBuilder comme template a Visual Studio 2010
    •  j'ai creé un projet de WSPBuilder
    • j'ai ajouté un item de type Blank Feature
    • et j'ai cliké sur Build WSP pour créer le fichier .wsp
    • ensuite j'ai déployé la solution .wsp avec PowerShell
    • dans la console d'administration il quand je fais installer la solution mantenant il m'affiche l'erreur suivante:

    AVT : le journal de liaison d'assembly est désactivé.
    Pour activer le journal des échecs de liaison d'assembly, attribuez la valeur 1 à la valeur de Registre [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD).
    Remarque : une certaine perte de performance est associée à l'enregistrement dans le journal des échecs de liaison d'assembly.
    Pour désactiver cette fonctionnalité, supprimez la valeur de Registre [HKLM\Software\Microsoft\Fusion!EnableLog].

    comment je pourrai régler ce probleme?

    pour déboguer la feature j'ai ajouté à la solution .sln un projet sharepoint vide et j'a ajouté au réference de ce projet la DLL de ma feature.

    dans le dossier Debug il existe un fichier .WSP mais celui du projet sharepoint et pas ma feature .quand j'ai essyé de déployé cette solution .wsp avec

    power shell ,une erreur s'affichie le fichier manifest.xml,.. sont introuvables??

    merci d'avance pour tt explication

    lundi 23 avril 2012 14:42

Réponses

Toutes les réponses