none
Tache Planifiée pour batch RRS feed

  • Question

  • Bonjour, 


    J'avais posté cette demande sur le forum classique et un utilisateur m'a conseillé de plutôt la poster sur le forum TechNet.

    J'ai créé un batch pour sauvegarder différents dossiers et je lance celui-ci via le "planificateur de tâche" à 3h du matin.

    Cependant j'ai un souci avec la ligne : 

    Copy D:\*.* E:\BackUp\"Documents"\*.* /E /H /Y /Q /Exclude:Except.txt > nul

    "Except.txt" contient :

    \Fichiers Perso Temporaire\
    \System Volume Information\
    \$RECYCLE.BIN\

    Si je lance le batch en tant qu'administrateur (J'utilise comme compte administrateur celui qui est normalement caché sous Windows) la sauvegarde se fait bien entièrement. Sinon, les dossiers dans E:\BackUp\"Documents" ne sont pas copiés.

    En fonctionnement normal c'est l'utilisateur "P.C.S." qui est toujours connecté.

    Dans les propriétés de mon batch, j'ai coché sous "compatibilité" "Exécuter en tant qu'administrateur".

    Dans le "Planificateur de taches", j'ai coché "Exécuter avec les autorisations maximales".

    Quelqu'un peut-il m'aider pour que mon batch se lance via le "planificateur de tâches" en tant qu'administrateur alors que c'est l'utilisateur "P.C.S." qui est connecté ? Ou trouver une solution pour que le dossier E:\BackUp\"Documents" soit copié ?

    mercredi 5 octobre 2016 09:08

Réponses

  • Aïe, aïe, aïe, je viens de me rendre compte que la tâche planifiée ne se lance pas...

    Si je crée, la tâche sous le compte Admin (celui normalement caché de Windows 10) et que je reste connecté, la tâche planifiée se lance bien

    Mais si je me déconnecte, elle ne se lance pas... alors que j'ai bien coché " Exécuter même si l'utilisateur n'est pas connecté"

    Si j'importe la tâche ou que je la crée sous le compte utilisateur, quand je coche " Exécuter avec les autorisations maximales puis que je clique sur "OK", quand j'entre le mot de passe Admin on me dit que "Le Planificateur de tâches ne peut pas créer la tâche. Le compte d'utilisateur est inconnu, le mot de passe est incorrect ou le compte d'utilisateur n'a pas l'autorisation de créer cette tâche."

    Pour info, cela fonctionne quand je décoche "Exécuter avec les autorisations maximales"

    Une idée ?

    -----  EDIT  -----

    Laissez tomber, cela fonctionne bien sans cocher "Exécuter avec les autorisations maximales"

     

     

    • Modifié _p0p0_ dimanche 16 octobre 2016 08:00
    • Marqué comme réponse Teodora Sharkova lundi 17 octobre 2016 16:47
    dimanche 16 octobre 2016 07:15

Toutes les réponses

  • Tu dois faire exécuter la tâche par l'administrateur, pas par l'utilisateur.

    Comme ceci:

    tu choisis en cliquant sur Utilisateur ou groupe.

    Seconde chose, Copy, c'était bien à l'époque des disquettes.

    Utilise Robocopy, avec cette commande:

    robocopy D:\ E:\BackUp\Documents /e /copyall /ndl /r:0 /w:0 /XJ /XD "Fichiers Perso Temporaire" "System Volume Information" $RECYCLE.BIN

    dans laquelle, par exemple, tu peux ajouter les paramètres suivants:

    • /XO exclure les fichiers plus anciens
    • /MIR <ATTENTION> la destination sera la copie miroir de la source
      Cette commande peut effacer les fichiers de la destination si ceux-ci n'existe pas dans la source, ne te trompe pas de destination.

    Robocopy ne copie pas les fichiers identiques, et copie, avec l'option /COPYALL, tous les attributs du fichier, droit NTFS compris.

    Donc, ne joue plus avec Copy, ni Xcopy

    B.


    • Modifié Bawilanemo jeudi 6 octobre 2016 07:57 retrait guillemet de la commande robocopy
    mercredi 5 octobre 2016 12:55
  • Merci pour ton aide

    Désolé mais je ne suis pas du tout familiarisé avec le commande "robocopy", j'ai lancé dans une invite de commande la ligne que tu m'avais noté, mais cela me renvoie l'erreur :

    "2016/10/06 08:36:03 ERREUR 123 (0x0000007B) Accès au répertoire de destination E:\BackUp\Documents \e \copyall \ndl \r:0 \w:0 \XJ \XD Fichiers\ 

    La syntaxe du nom de fichier, de répertoire ou de volume est incorrecte."

    jeudi 6 octobre 2016 06:40
  • Erreur normal, si tu mets des backslash pour les paramètres....

    Tu t'y familiariseras en l'utilisant, et un jour, tu regretteras de ne pas t'y être mit plus tôt!

    B.

    jeudi 6 octobre 2016 06:53
  • C'est à dire ? Car j'ai fait un copier/coller de ta ligne 
    jeudi 6 octobre 2016 07:46
  • Oui, je vois, c'est de ma faute, il y avait un guillemet en trop dans la commande.

    C'est corrigé.

    jeudi 6 octobre 2016 07:58
  • Cette fois la sauvegarde se fait bien mais le répertoire destination (E:\BackUp\Documents\) est caché (fichiers protégés du système d'exploit.)

    Dans l'aide de robocopy, je n'ai pas vu de paramètre correspondant

    ---- EDIT ----

    J'ai trouvé dans une aide qu'il fallait utiliser les commandes /A-:SH

    Je teste...

    ---- EDIT ----

    Du coup, où je les vais placé dans la ligne, ça ne marchait pas et j'ai cru comprendre que cela modifiait les attributs de tous les fichiers alors j'ai préféré utiliser la commande attrib




    • Modifié _p0p0_ jeudi 6 octobre 2016 13:55
    jeudi 6 octobre 2016 10:39
  • Aïe, aïe, aïe, je viens de me rendre compte que la tâche planifiée ne se lance pas...

    Si je crée, la tâche sous le compte Admin (celui normalement caché de Windows 10) et que je reste connecté, la tâche planifiée se lance bien

    Mais si je me déconnecte, elle ne se lance pas... alors que j'ai bien coché " Exécuter même si l'utilisateur n'est pas connecté"

    Si j'importe la tâche ou que je la crée sous le compte utilisateur, quand je coche " Exécuter avec les autorisations maximales puis que je clique sur "OK", quand j'entre le mot de passe Admin on me dit que "Le Planificateur de tâches ne peut pas créer la tâche. Le compte d'utilisateur est inconnu, le mot de passe est incorrect ou le compte d'utilisateur n'a pas l'autorisation de créer cette tâche."

    Pour info, cela fonctionne quand je décoche "Exécuter avec les autorisations maximales"

    Une idée ?

    -----  EDIT  -----

    Laissez tomber, cela fonctionne bien sans cocher "Exécuter avec les autorisations maximales"

     

     

    • Modifié _p0p0_ dimanche 16 octobre 2016 08:00
    • Marqué comme réponse Teodora Sharkova lundi 17 octobre 2016 16:47
    dimanche 16 octobre 2016 07:15