locked
Conférence Web Lync2013 RRS feed

  • Question

  • Bonjour,

    Avant tout je précise que je suis newbie en Lync. J'ai un petit problème lorsque je fais une conférence avec Lync2013. Si je n'ai pas un participant se connectant avant l'organisateur, ça raccroche.

    Je m'explique. Je crée une conférence, dans Outlook, j'appelle le numéro, j'entre l'ID de la conf puis mon Pin. L'assistant vocal me répond : Vous participez à la conférence en tant qu'organisateur. Puis 10 sec après ça raccroche. 

    Est ce que l'un de vous pourrez éclairer ma lanterne ???

    Cordialement,


    jeudi 2 mai 2013 14:01

Réponses

  • Oui c'est exactement les mêmes. J'ai également fait les traces dans les deux cas de figures  et c'est exactement les deux mêmes.

    Bon en fait, je viens de voir d'où cela venait... mon DHCP délivre trop d'options et du coup, ça fait planté tout le système des conf call. Par contre, gros mystère pourquoi ça marche quand il y a un convive avant que l'organisateur se connecte ???

    Enfin bref merci beaucoup à tout ceux qui m'ont aidé à comprendre un peu plus le fonctionnement de Lync  

    lundi 13 mai 2013 13:28

Toutes les réponses

  • Bonjour,

    Est ce que vous avez des messages d'erreur dans les journaux d’événements ?

    Merci

    Cordialement,


    Alexis CONIA - Eliade - http://www.techandprog.fr

    jeudi 2 mai 2013 15:26
  • Bonjour,

    Aucun qui me semble lié (sauf peut être une erreur 31059: probléme de mise à jour de la version de base de données)

    Cordialeemnt

    jeudi 2 mai 2013 15:43
  • bonjour,

    Votre environnement Lync Server 2013 est-il à jour?

    Microsoft a sorti en février des CU qui permettent de corriger certains bug de cette version.

    voici le lien : http://support.microsoft.com/kb/2809243/en-us

    cordialement,

    sébastien ANTIER

    vendredi 3 mai 2013 06:50
  • Bonjour,

    Est ce que vous avez la possibilité d'obtenir les traces SIP avec l'outil snooper sur le serveur ? Lors de l'installatiion vous avez un outil d'analyse "Logging Tool" et vous pouvez ensuite ouvrir l'analyse avec le snooper présent dans le resource kit (http://www.microsoft.com/en-us/download/details.aspx?id=36821)

    Je pense que vous obtiendrez quelques messages supplémentaires.

    Merci

    PS : n’hésitez pas a revenir vers nous si vous souhaitez avoir des informations suoplémentaires 



    Alexis CONIA - Eliade - http://www.techandprog.fr


    vendredi 3 mai 2013 07:28
  • Bonjour,

    Ce serveur Lync est à jour, je vais commencer par résoudre l'erreur 31059 et ensuite je regarderais les logs.

    merci pour les pistes, je regarde et reviens vers vous

    Donc, Mise à jour effectuée et correction de bug fini mais toujours le même probléme

    Cdt


    vendredi 3 mai 2013 08:37
  • Bonjour, 

    Avant d'investiguer plus loin, avez-vous correctement configurés les options de conférence Lync dans Outlook (via le Lync Plug-in)?

    Deuxième point, avez-vous apporté des paramétrages spécifiques au niveau de vos conferencing policy ?

    Ensuite effectivement, vous avez la possibilité d'obtenir les traces SIP (http://msdn.microsoft.com/en-us/library/lync/hh347311.aspx) avec au minimum S4 et SIPSTACK comme provider ainsi qu'avec tous les Flags activés.

    Avez-vous configuré le Dial-Out (l'option Call me at: lorsque vous souhaitez rejoindre une conférence via la WebApp)? Si oui, cela fonctionne t'il ?

    Merci

    Cdt,


    David ANDRE - Consultant UC - unifiedit.wordpress.com

    vendredi 3 mai 2013 14:15
  • Bonjour,

    Oui j'ai ce bouton. Concernant le paramétrage des politiques, le paramétrage reste de base. Sur Lync 2013, je ne trouve pas les outils pour le logging et concernant le dial-out, je ne sais pas du tout ce que c'est... :s

    cdt,

    vendredi 3 mai 2013 15:03
  • Qu'avez vous comme options par défaut quand vous cliquez sur ce bouton ?

    En ce qui concerne les outils de logging, faites une recherche de fichier : OCSLogger.exe. N'hesitez pas à installer aussi le RessourceKit Lync 2013 sur votre serveur Lync : http://www.microsoft.com/en-us/download/details.aspx?id=36821

    Cependant, pouvez-vous nous dire quelle passerelle téléphonique avez-vous? Des infos sur votre trunk SIP?

    Pour le Dial-Out, c'est une fonctionnalité qui permet à un participant d'une conférence de se faire appeler par Lync sur un numéro qu'il renseigne. 
    Le Dial-In quant à lui est justement l'inverse, le participant appel le pont de conférence pour rejoindre la dite conférence.

    Cdt,


    David ANDRE - Consultant UC - unifiedit.wordpress.com

    vendredi 3 mai 2013 15:15
  • Bonjour,

    De passage sur le Forum, je vous propose ce lien qui vous aidera grandement pour faire le debug :

    cf : http://blog.schertz.name/2011/06/using-the-lync-logging-tool

    Concernant votre erreur 31059, il y à de multiples articles sur internet qui en parle avec bien sur de multiples résolutions (MAJ / bidouille / etc..)

    Cordialement,


    DUC Pierre-Emmanuel - AZEO -  http://ducpmanu.blog.com


    samedi 4 mai 2013 16:18
  • Bonjour à tous,

    Donc j'avance, les logs sont presque clean, (reste juste 2 ou 3 erreurs de connexion à Lync Web App et de synchro). 

    Mais concernant mon problème, les logs sont assez clair, le serveur Edge refuse catégoriquement la connexion.

    lundi 6 mai 2013 08:11
  • Bonjour,

    Est ce que vous pouvez donner les détails du message d'erreur ?

    Merci

    Cordialement,


    Alexis CONIA - Eliade - http://www.techandprog.fr

    lundi 6 mai 2013 13:20
  • Bonjour,

    Oui bien sur : 

    TL_ERROR(TF_CONNECTION) [2]0E98.0E88::05/06/2013-08:03:46.878.0000000f (SIPStack,SIPAdminLog::WriteConnectionEvent:1207.idx(452))[74596305] 
    $$begin_record
    Severity: error
    Text: Failed to complete outbound connection
    Peer-IP: X.X.X.X:5061
    Connection-ID: 0x79A900
    Transport: TLS
    Result-Code: 0x8007274d
    Data: fqdn="srv.domaine.lan";peer-type="InternalServer";winsock-code="10061";winsock-info="The peer actively refused the connection attempt"
    $$end_record

    j'ai vérifié les pare feu, aucun des deux cotés. Par contre dés que je fais du telnet sur le edge, j'ai accès à tous les ports sauf le 5061 et un autre. Ma génération de topologie met bien le port 5061 en SIP. 

    côté DNS j'ai bien un enregistrement SRV pour le SIP sur le bon port et le bon serveur.

    lundi 6 mai 2013 15:15
  • Bonjour,

    Voici quelques vérifications à réaliser :

    • Est ce que les services Lync sont biens démarrés sur le serveur Edge ? 
    • Si le serveur n'est pas dans le domaine, est ce que le certificat de l'autorité est dans le magasin de l'ordinateur local ?

    Cordialement,


    Alexis CONIA - Eliade - http://www.techandprog.fr

    lundi 6 mai 2013 15:56
  • Bonjour,

    Pour compléter les information d'Alexis (+1 pour les certificats) ; avez-vous essayer :
    - https://www.testocsconnectivity.com/ : (je n'y crois pas trop mais on ne sait jamais)
    - Le lync BPA ne donne rien ?

    Pour info :
    - pour lister les services utilisant les ports, entrer dans un terminale netstat -a

    En espérant que ça vous aide.

    Cordialement,


    DUC Pierre-Emmanuel - AZEO -  http://ducpmanu.blog.com

    lundi 6 mai 2013 17:44
  • Bonjour,

    - Maintenant, tous les services sont bien démarrés sur l'ensemble des deux serveurs (Edge comme Lync dans le lan), j'ai également refait un netstat -a pour voir les ports et j'ai maintenant le port 5061 d'ouvert. (le service qui n'était pas démarré était le service RTCSRV ) mais pas de changement sur la conférence.

    - Le certificat est sur le Edge ainsi que sur le Lync du Lan sont en place.

    - Le lync BPA ne donne rien à part me dire qu'il faut 16Go de ram et 4VCPU.


    Je regarde maintenant les traces du edge et du lync en Lan pour voir si elles ont évoluées maintenant qu'ils ont le même port. C'est rageant, je sens que je suis pas loin de la solution mais elle s'échappe ... 

    Mise à jour : 

    Donc les traces montrent que certains ports ne sont pas accessible sur les deux serveurs Exchanges (Il y a 5 ports sur le premier et 2 ports sur le second), je n'ai aucune idée de comment les ouvrir (recherche en cours)

    Cordialement,




    mardi 7 mai 2013 07:46
  • Bonjour,

    Vous n'avez pas de problèmes avec les autres services (Connexion depuis Internet par exemple) ? 

    Cordialement,


    Alexis CONIA - Eliade - http://www.techandprog.fr

    mardi 7 mai 2013 13:12
  • Aucun. tout marche nikel.

    Par contre le truc que je trouve bizarre c'est que si un invité rejoins la conf avant l'organisateur, la conférence se passe sans accro. Mais si l'organisateur se connecte avant un invité, ça raccroche systématiquement au bout de 8secondes.... :s 

    La détection de la présence avec Lync marche nikel, dés que dans le calendrier j'ai quelque chose de prévu, lync passe en Occupé tout seul. Donc à priori, il s'agirait de port non ouvert sur l'exchange (dont le pare feu n'est plus) aprés, l'exchange est en SP3. Est ce possible que le bug provienne des mises à jours ?

    Cordialement,


    • Modifié Valentin M vendredi 10 mai 2013 07:34 Mise à jour
    mardi 7 mai 2013 13:18
  • Bonjour,

    Est ce que vous avez pu tester avec plusieurs utilisateurs qui ont le rôle organisateur ?

    Cordialement,


    Alexis CONIA - Eliade - http://www.techandprog.fr

    vendredi 10 mai 2013 08:42
  • Bonjour,

    effectivement, et à chaque fois, le même comportement. Je suis en train de tester une théorie sur des problèmes de certificats et de connexion avec Exchange. Mais les récents tests m'orientent plutot vers la piste exchange. Les SIP Track donnent les messages suivants : 

    TL_ERROR(TF_CONNECTION) [1]0E98.2FD0::05/10/2013-08:55:08.175.0025ff5e (SIPStack,SIPAdminLog::WriteConnectionEvent:1207.idx(374))[4235351428] 
    $$begin_record
    Severity: error
    Text: The peer is not a configured server on this network interface
    Peer-IP: X.X.X.X:12664
    Transport: TLS
    Result-Code: 0xc3e93d6a SIPPROXY_E_CONNECTION_UNKNOWN_SERVER
    Data: fqdn="FQDNLYNC"
    $$end_record

    et ce message apparaît avec plusieurs ports.

    Je creuse cette piste là en regardant les erreurs potentielles sur l'exchange.

    Question subsidiaire, Lync peut communiquer avec plusieurs OWA à la fois ? (l'architecture est composé de 4 exchanges 2 en 2010 et 2 en 2013)

     

    il me reste quelques erreurs dans le journal d'évènement Windows,

    41029 : LS Data MCU 


    32049 32053 et 32054 : LS Storage Service qui sont liées je pense


    vendredi 10 mai 2013 09:02
  • Bonsoir,

    Il n'y a normalement pas de lien entre le service de conférence et le serveur Exchange. Concernant OWA, il est considéré comme une application "trusté", les contacts peuvent être affichés aussi bien en 2010 qu'en 2013 (en 2013 il utiliser le protocole OAuth alors qu'en 2010 il s'agit d'une trusted application avec un lien TLS).

    Les deux serveurs Lync (front end et edge) sont up to date ?

    Cordialement,


    Alexis CONIA - Eliade - http://www.techandprog.fr

    dimanche 12 mai 2013 21:05
  • Bonjour,

    Donc à part une mise à jour SP1 pour SQL 2012, les lync sont up to date. 

    Quand vous dites, en 2013 il utiliser le protocole OAuth alors qu'en 2010 il s'agit d'une trusted application avec un lien TLS, où peut on le paramétrer ? A moins qu'il ne fasse le paramétrage en découvrant l’hôte.  

    Sinon, j'ai un peu avancé, il apparaît lorsque j'essaie de modifier la topologie qu'il cherche un serveur qui n'existe pas -_-'

    Cordialement, 

    Valentin

    lundi 13 mai 2013 08:40
  • Bonjour,

    Concernant les "Trusted application", voici un lien qui pourra t'aider :
    http://technet.microsoft.com/en-us/library/gg617964%28v=ocs.14%29.aspx

    Ou encore un exemple :

    http://blog.schertz.name/2010/11/lync-and-exchange-im-integration/

    Par contre je serais curieux de savoir le problème dans ta topologie (vu que c'est un peu beaucoup la base de ton infra Lync).

    Est-ce un serveur qu'il ne peut pas joindre ou un résidu de modification ?
    En attendant ton retour.

    Cordialement,


    DUC Pierre-Emmanuel  -  http://ducpmanu.blog.com

    lundi 13 mai 2013 11:23
  • En fait, le probléme est le suivant :

    je crée une conférence Lync depuis Outlook. J'appelle le centre de conférence, j'entre le numéro de conférence et dés que je dis, je suis l'organisateur, je rentre mon PIN, j'ai 10 secondes puis ça raccroche. Le même test en étant juste un membre lambda de la conf, je suis en attente. SI à ce moment là l'organisateur rejoins la conf, elle se déroule sans aucun accro. 

    et coté log, je n'ai rien de correspondant mais coté Trace SIP, j'ai quelques trucs comme quoi il ne trouve pas un serveur dans l'AD sauf qu'il n'existe pas ... il s'agit d'un alias DNS sur des exchanges 2010/2013.

    Aprés je dois dire que depuis l'ouverture de ce flux, j'ai appris pas mal de chose sur Lync et je continue à me documenter aussi si jamais vous avez d'autres liens je suis largement preneur ^^ (@ducpmanu merci pour les liens que tu viens de me donner)

    Cordialement,

    Valentin

    lundi 13 mai 2013 11:30
  • Bonjour,

    Concernant les traces SIP, tu as les mêmes messages sur le edge et sur le front ?

    Cordialement,


    Alexis CONIA - Eliade - http://www.techandprog.fr

    lundi 13 mai 2013 13:24
  • Oui c'est exactement les mêmes. J'ai également fait les traces dans les deux cas de figures  et c'est exactement les deux mêmes.

    Bon en fait, je viens de voir d'où cela venait... mon DHCP délivre trop d'options et du coup, ça fait planté tout le système des conf call. Par contre, gros mystère pourquoi ça marche quand il y a un convive avant que l'organisateur se connecte ???

    Enfin bref merci beaucoup à tout ceux qui m'ont aidé à comprendre un peu plus le fonctionnement de Lync  

    lundi 13 mai 2013 13:28
  • Bonjour,

    Très bizarre comme comportement, est ce que tu peux donner un peu plus de détails concernant ces options ?

    Merci

    Cordialement,


    Alexis CONIA - Eliade - http://www.techandprog.fr

    mardi 14 mai 2013 08:41
  • Bonjour,

    En fait, les options sont définis pour permettre l'auto conf de pas mal de chose pas forcément que en rapport avec Lync (WDS,NTP  entre autre) du coup je ne sais pas si je peux ou non divulgué les options utilisées.

    Cordialement

    mardi 14 mai 2013 08:47
  • Bonjour,

    Content que tu es trouvé la solution.

    Je serais curieux de savoir la ou lesquels des options dégradaient le service.
    En te remerciant.

    PS: ou par Message privé si vraiment tu veux pas les divulguer (ce que je peut comprendre)

    Cordialement,


    DUC Pierre-Emmanuel  -  http://ducpmanu.blog.com

    mercredi 15 mai 2013 17:49
  • Bonjour,

    En fait ce n'est pas une option en particulier, c'est juste que le DHCP délivre trop d'options (pas loin d'une vingtaine). Je ne pense pas que ça soit une option en particulier qui pose problème mais l'accumulation de celles-ci.

    Dites, au passage, (bien que ça soit hors sujet) est-ce que vous auriez des tips/ressources/ebooks/livre à me conseiller pour passer la certification pour Lync ? Le fait de me pencher dessus m'a donné envie d'en faire plus sur Lync et d'approfondir ce que je sais ^^

    Cordialement,

    Valentin

    jeudi 16 mai 2013 08:03