locked
IIS ne s'installe pas RRS feed

  • Question

  • Bonjour tout le monde

     

    Je n'arrive pas à installer IIS sous Vista SP1

    Est ce que c'est déja arrivé à quelqu'un si oui quelle est la solution ?

    Merci

    mercredi 20 août 2008 09:29

Réponses

  • bonsoir fafatech,

     

    /mode guess ON

    essaye un petit coup de ccleaner ça peut aider à nettoyer des applis récalcitrantes et à isoler des applis mal (des)installer..tu le trouveras ici: http://www.ccleaner.com/

    il ne fait pas de miracle mais peut mettre un peu d'ordre dans ton registre...et qui sait? peut etre resoudre ton probleme Smile

    /mode guess OFF

     

    essaye l'installation par script:

     

    Code Snippet
    start /w pkgmgr /iu:IIS-WebServerRole;IIS-WebServer;IIS-CommonHttpFeatures;IIS-StaticContent;IIS-DefaultDocument;IIS-DirectoryBrowsing;IIS-HttpErrors;IIS-HttpRedirect;IIS-ApplicationDevelopment;IIS-ASPNET;IIS-NetFxExtensibility;IIS-ASP;IIS-CGI;IIS-ISAPIExtensions;IIS-ISAPIFilter;IIS-ServerSideIncludes;IIS-HealthAndDiagnostics;IIS-HttpLogging;IIS-LoggingLibraries;IIS-RequestMonitor;IIS-HttpTracing;IIS-CustomLogging;IIS-ODBCLogging;IIS-Security;IIS-BasicAuthentication;IIS-WindowsAuthentication;IIS-DigestAuthentication;IIS-ClientCertificateMappingAuthentication;IIS-IISCertificateMappingAuthentication;IIS-URLAuthorization;IIS-RequestFiltering;IIS-IPSecurity;IIS-Performance;IIS-HttpCompressionStatic;IIS-HttpCompressionDynamic;IIS-WebServerManagementTools;IIS-ManagementConsole;IIS-ManagementScriptingTools;IIS-ManagementService;IIS-IIS6ManagementCompatibility;IIS-Metabase;IIS-WMICompatibility;IIS-LegacyScripts;IIS-LegacySnapIn;IIS-FTPPublishingService;IIS-FTPServer;IIS-FTPManagement;WAS-WindowsActivationService;WAS-ProcessModel;WAS-NetFxEnvironment;WAS-ConfigurationAPI

     

     

    cette commande t'installe IIS complet, avec toutes ses options...tu trouveras plus d'info ici: http://technet2.microsoft.com/windowsserver2008/fr/library/10aac45e-e993-42a2-bf93-275375d662631036.mspx?mfr=true

     

    peux tu éventuellement poster les erreurs systeme et aplications présentes dans ton eventvwr apres cette commande?

     

    merci,

     

    Pierre.

     

    lundi 13 octobre 2008 18:51

Toutes les réponses

  • Bonjour,

     

    il n'y a aucun problème particulier.

     

    Il suffit d'activer la fonctionnalité dans "Programmes et fonctionnalités", "activer une fonctionnalité windows"

    => cocher les cases correspondantes souhaitées.

    A+

    mercredi 20 août 2008 11:36
  • Bonjour

     

    C'est exactement ce que j'ai fait mais ca fonctionne pas une erreur se produit juste avant la fin de l'installation,je suis allé dans l' observateur d'evenement,une série d'erreur s'est produit la première est:

     

    Nom du journal Tongue Tiedystem
    Source :       Microsoft-Windows-Servicing
    Date :         20/08/2008 12:20:21
    ID de l'événement :4375
    Catégorie de la tâche :Aucun
    Niveau :       Erreur
    Mots clés :    Classique
    Utilisateur :  ***\***
    Ordinateur :   ***
    Description :
    Windows Servicing a échoué lors de la définition du package Windows Foundation (Foundation) à l’état Installé(Installed)

     

    merci

     

    mercredi 20 août 2008 12:36
  • ps: j'ai oublié de mentionné que j'ai pu l'installer sur vista sans le sp1 une fois le sp1 installé IIS ne veut plus s'installer .

    Le probleme vient peut etre de sp1 ?

     

    mercredi 20 août 2008 12:55
  • y'a vraiment personne qui pourrait m'aider pour installer iis sous vista sp1 ?

     

    vendredi 22 août 2008 13:24
  • la seule solution que j'ai trouvé est de désinstaller le sp1, installé IIS puis reinstallé le sp1.
    jeudi 2 octobre 2008 13:41
  • Bonjour,

    tu pourrais essayer de modifier le fichier applicationHost.config en ajoutant le code suivant 

    Code Snippet

    <section name="configHistory" allowDefinition="AppHostOnly" overrideModeDefault="Deny" />

     

     

     

    dans la section "system.applicationHost"

    Si ca ne fonctionne pas, merci de nous donner davantage de renseignements sur les messages d'erreurs rencontrés.

     

     

    jeudi 2 octobre 2008 14:06
  • merci pour ta réponse mais lorsque tu me dit d'aller modifié le fichier applicationHost.config ce fichier apparait aprés l'installation de IIS ou il est avant l'installation sachant que je n'est pas encore installé IIS je vais  C:\windows\system32\inetsrv ce dossier est vide

    J'ai encore reesayer d'installer IIS sans enlever le SP1 et j'ai la meme erreur juste avant la fin de l'installation j'ai une fenetre d'erreur qui dit "Une erreur s'est produit.Certaines fonctionnalités n'ont pas été modifiées correctement.

    Dans le journal des évenement je vois une série d'erreurs voici la première de ces erreurs:


    Nom du journal Tongue Tiedystem
    Source :       Microsoft-Windows-Servicing
    Date :         03/10/2008 09:54:42
    ID de l'événement :4375
    Catégorie de la tâche :Aucun
    Niveau :       Erreur
    Mots clés :    Classique
    Utilisateur :  WYDEPARIS\administrateur
    Ordinateur :   trainee
    Description :
    Windows Servicing a échoué lors de la définition du package Windows Foundation (Foundation) à l’état Installé(Installed)
    XML de l’événement :
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-Servicing" Guid="{bd12f3b8-fc40-4a61-a307-b7a013a069c1}" EventSourceName="Microsoft-Windows-Servicing" />
        <EventID Qualifiers="49152">4375</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2008-10-03T07:54:42.000Z" />
        <EventRecordID>71685</EventRecordID>
        <Correlation />
        <Execution ProcessID="0" ThreadID="0" />
        <Channel>System</Channel>
        <Computer>trainee</Computer>
        <Security UserID="S-1-5-21-257754602-2376541186-1432394172-1467" />
      </System>
      <UserData>
        <CbsPackageChangeState xmlns="http://manifests.microsoft.com/win/2004/08/windows/setup_provider">
          <PackageIdentifier>Windows Foundation</PackageIdentifier>
          <ReleaseType>Foundation</ReleaseType>
          <PackageState>Installed</PackageState>
          <PackageAssembly>Microsoft-Windows-Foundation-Package~31bf3856ad364e35~x86~~6.0.6000.16386</PackageAssembly>
          <Operation>Installed</Operation>
          <OperationCompleted>True</OperationCompleted>
          <ErrorCode>0x80070643</ErrorCode>
          <RebootOption>False</RebootOption>
          <MissingElements>
          </MissingElements>
        </CbsPackageChangeState>
      </UserData>
    </Event>


    merci
    vendredi 3 octobre 2008 08:02
  • bonsoir fafatech,

     

    as-tu par le plus grand des hasard essayé de désinstaller les frameworks beta 3.5 si tu les as installés?

    dans ton log on vois apparaitre une ref:

    Windows Servicing a échoué lors de la définition du package Windows Foundation (Foundation) à l’état Installé(Installed)

    autrement dit l'installateur IIS n'arrive pas à confirmer l'installation du composants WF..framework .NET 3.5 si je ne me trompe pas... et il y a eu des betas...

     

    essaye de selectioner les composants .NET que tu as dans le "appwiz.cpl", de les désinstaller tous, désinstller IIS s'il apparait installé malgres les erreurs...et redémarre ton poste, puis re tente l'installation.

     

    tiens nous au courant,

     

    cordialement,

     

    PierrE.

    mercredi 8 octobre 2008 22:20
  • bonjour Pierre ,


    Merci de m'aider, j'ai suivit vos indications j'ai désinstaller frameworks 3.0 car c'est cette version qui est installé sur mon vista SP1 après l'avoir désinstallé et redémarrer,j'ai retenté l'installation de IIS mais malheuresement le probleme persiste et il y'a toujours les meme message d'erreurs dans le journal des évenements.

    Cordialement,

    Fafatech
    lundi 13 octobre 2008 14:37
  • bonsoir fafatech,

     

    /mode guess ON

    essaye un petit coup de ccleaner ça peut aider à nettoyer des applis récalcitrantes et à isoler des applis mal (des)installer..tu le trouveras ici: http://www.ccleaner.com/

    il ne fait pas de miracle mais peut mettre un peu d'ordre dans ton registre...et qui sait? peut etre resoudre ton probleme Smile

    /mode guess OFF

     

    essaye l'installation par script:

     

    Code Snippet
    start /w pkgmgr /iu:IIS-WebServerRole;IIS-WebServer;IIS-CommonHttpFeatures;IIS-StaticContent;IIS-DefaultDocument;IIS-DirectoryBrowsing;IIS-HttpErrors;IIS-HttpRedirect;IIS-ApplicationDevelopment;IIS-ASPNET;IIS-NetFxExtensibility;IIS-ASP;IIS-CGI;IIS-ISAPIExtensions;IIS-ISAPIFilter;IIS-ServerSideIncludes;IIS-HealthAndDiagnostics;IIS-HttpLogging;IIS-LoggingLibraries;IIS-RequestMonitor;IIS-HttpTracing;IIS-CustomLogging;IIS-ODBCLogging;IIS-Security;IIS-BasicAuthentication;IIS-WindowsAuthentication;IIS-DigestAuthentication;IIS-ClientCertificateMappingAuthentication;IIS-IISCertificateMappingAuthentication;IIS-URLAuthorization;IIS-RequestFiltering;IIS-IPSecurity;IIS-Performance;IIS-HttpCompressionStatic;IIS-HttpCompressionDynamic;IIS-WebServerManagementTools;IIS-ManagementConsole;IIS-ManagementScriptingTools;IIS-ManagementService;IIS-IIS6ManagementCompatibility;IIS-Metabase;IIS-WMICompatibility;IIS-LegacyScripts;IIS-LegacySnapIn;IIS-FTPPublishingService;IIS-FTPServer;IIS-FTPManagement;WAS-WindowsActivationService;WAS-ProcessModel;WAS-NetFxEnvironment;WAS-ConfigurationAPI

     

     

    cette commande t'installe IIS complet, avec toutes ses options...tu trouveras plus d'info ici: http://technet2.microsoft.com/windowsserver2008/fr/library/10aac45e-e993-42a2-bf93-275375d662631036.mspx?mfr=true

     

    peux tu éventuellement poster les erreurs systeme et aplications présentes dans ton eventvwr apres cette commande?

     

    merci,

     

    Pierre.

     

    lundi 13 octobre 2008 18:51