none
Windows Server 2012 R2 Datacenter problème ajout fonctionnalité RRS feed

  • Question

  • Bonjour,

    Comment indiquer dans le titre je possède un serveur windows 2012R2 Datacenter fraichement mis en place, auquel je rencontre des difficultés pour ajouter 2 fonctionnalités au rôle de Serveur d'Application.

    Mon rôle serveur d'application est bien installé, je souhaite ajouter à ce rôle les fonctionnalités :

    -activation TCP

    -activation des canaux nommés

    J'ai essayé de les installer en GUI mais sans succès, j'obtiens :

     Échec de la demande d'ajout ou de suppression de fonctionnalités sur le serveur spécifié.
    Échec de l'installation d'un ou plusieurs rôles ou services de rôle, ou d'une ou plusieurs fonctionnalités. Erreur:
    0x800f0922

    j'ai donc essayé de les installer via powershell (administrateur) et j'obtiens :

    PS C:\Windows\system32> Add-WindowsFeature AS-TCP-Activation,AS-Named-Pipes -source D:\sources\sxs
    Add-WindowsFeature : Échec de la demande d'ajout ou de suppression de fonctionnalités sur le serveur spécifié.
    Échec de l'installation d'un ou plusieurs rôles ou services de rôle, ou d'une ou plusieurs fonctionnalités. Erreur:
    0x800f0922
    Au caractère Ligne:1 : 1
    + Add-WindowsFeature AS-TCP-Activation,AS-Named-Pipes -source D:\sources\sxs
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation : (@{Vhd=; Credent...Name=localhost}:PSObject) [Install-WindowsFeature]
       , Exception
        + FullyQualifiedErrorId : DISMAPI_Error__Failed_To_Enable_Updates,Microsoft.Windows.ServerManager.Commands.AddWind
       owsFeatureCommand

    Je précise que je suis administrateur du serveur, que j'ai essayé avec et sans pare-feu Windows, avec et sans antivirus.

    J'ai essayé aussi de les ajouter 1 à 1 ou les 2 simultanément, rien à faire toujours cette même erreur.

    J'ai trouvé dans une discussion qu'il fallait appliquer ce correctif : Windows8.1-KB2966828-x64, rien à faire même après application du correctif l'erreur est toujours là.

    je sèche complètement, j'ai cherché un peu partout sans succès, c'est pourquoi me voilà à vous demander de l'aide.

    Je vous remercie d'avance pour vos réponse !

    jeudi 21 juillet 2016 12:04

Réponses

  • Bonjour,

    ESt-ce que vous avez déjà redémarré votre serveur ?

    Pourquoi vous spécifiez une source dans la ligne de commande ?

    Qu'est ce que ça donne quand vous enlevez le paramètre source ?

    Add-WindowsFeature AS-TCP-Activation,AS-Named-Pipes

    Si vous parvenez pas à installer le composant, est-ce que vous pouvez svp ajouter une capture écran du résultat de

    Get-WindowsFeature | ? Name -match '^AS'

    • Marqué comme réponse BoPtz vendredi 29 juillet 2016 10:01
    jeudi 21 juillet 2016 16:30

Toutes les réponses

  • Bonjour 

    Avez vous vérifier l'installation après un mise à  jours de votre OS ?!


    vote if you think useful

    jeudi 21 juillet 2016 12:30
  • Bonjour,

    ESt-ce que vous avez déjà redémarré votre serveur ?

    Pourquoi vous spécifiez une source dans la ligne de commande ?

    Qu'est ce que ça donne quand vous enlevez le paramètre source ?

    Add-WindowsFeature AS-TCP-Activation,AS-Named-Pipes

    Si vous parvenez pas à installer le composant, est-ce que vous pouvez svp ajouter une capture écran du résultat de

    Get-WindowsFeature | ? Name -match '^AS'

    • Marqué comme réponse BoPtz vendredi 29 juillet 2016 10:01
    jeudi 21 juillet 2016 16:30