none
Problème Remote-App ne monte que le disque client C RRS feed

  • Question

  • Bonjour à tous,

    J'ai mis en place un serveur Remote-App pour autoriser des clients (externe à l'entreprise) à se connecter sur notre application interne.

    Dans Services Bureau à distance > Collections > Macollection1 > Paramètres du client  j'ai coché l'option [x] Lecteurs, afin qu'ils puissent sauvegarder les documents sur leur Pcs.

    Mon problème est que seul le disque C: est monté (C on Pc-Users), les autres partitions ne le sont pas.
    J'ai du mal à trouver les options avancés cette configuration.

    Dans le fichier rdp que j'ai édité, il est indiqué:
    drivestoredirect:s:C:
    Je suppose que c'est cette option qui m'intéresse mais si je tente de modifier le fichier rdp téléchargé, je ne peux plus l'utiliser.

    Quelqu'un aurait une idée ?
    D'avance merci

    Cdt

    jeudi 24 juillet 2014 07:51

Réponses

  • Cette fois ci j'ai trouvé pour de bon *ouf*

    Il semblerait qu'à mon insu j'ai modifié le CustomRDPSettings..

    Et que j'y ai mis un drivestoredirect:s:C

    Du coup je n'avais que C on Ordi-Distant.
    J'ai tenté de mettre à jour avec la commande avec powershell
    Set-RDSessionCollectionConfiguration -CollectionName App -CustomRdpProperty "drivestoredirect:s:*" et pareil avec drivestoredirect:s:*
    Sans succès. (Même si au niveau base de registre et fichiers rdp mes modif étaient bien visible)
    J'avais un 2ème serveur RDS en cours d'installtion et j'ai remarqué que pour autoriser le montage de tous les disques dans la base de registre il n y avait aucune entrée.
    Du coup en supprimant l'entrée de ma base j'ai pu retrouver tous mes lecteurs...*Ouf*

    La configuration de RDP se trouve dans

    HL_Machine\Software\Microsoft\Windows NT\CurrentVersion\Terminal Server\CentralPublishedRessources\PublishedFarmes\"Nom de votre CollectionName"\DeployementSettings\CustomRDPSettings..

    Voilà c'est fini :)

    • Marqué comme réponse Jerome.A-74 vendredi 25 juillet 2014 07:55
    vendredi 25 juillet 2014 07:55

Toutes les réponses

  • Bonsoir,

    Quelle est la version du client RDP? De ce que je sais, jusqu'a partir de RDP 8.0 la redirection d'un lectuer specifique est disponible.

    Vous pouvez partager le lecteur C ou tous les lecteurs en modifiant le fichier comme ceci: drivestoredirect:s:*

    Voici la syntaxe:

    RDP 5 redirect all drives (0 or 1).
    redirectdrives:i:1

    RDP 6 settings:
    drivestoredirect:s:
    redirect none

    drivestoredirect:s:*
    redirect all drives, as well as drives connected later

    --does not work on RDP 7:
    drivestoredirect:s:C:;G:;DynamicDrives
    redirect just the C, G, and subsequently connected drives.

    Bien cordialement,

    Florin


    Florin CIUCA, MSFT  Votez! Appel à la contribution
    Nous vous prions de considérer que dans le cadre de ce forum on n’offre pas de support technique et aucune garantie de la part de Microsoft ne peut être offerte.

    jeudi 24 juillet 2014 22:08
  • Bonjour et merci pour votre réponse.

    Mon problème est de modifier cette option dans Windows 2012 R2.
    Sous 2008 R2, ça semble facile à trouver sous 2012 je ne trouve pas d'info... 

    Je ne trouve pas où je pourrais configurer ce paramètre au niveau du serveur afin que mes clients ai directement un: drivestoredirect:s:*  dans leur fichier rdp.

    Edit

    Je pense avoir trouvé et ça fait peur...

    http://microsoftplatform.blogspot.fr/2013/01/adding-custom-rdp-properties-in-windows.html

    vendredi 25 juillet 2014 06:48
  • Cette fois ci j'ai trouvé pour de bon *ouf*

    Il semblerait qu'à mon insu j'ai modifié le CustomRDPSettings..

    Et que j'y ai mis un drivestoredirect:s:C

    Du coup je n'avais que C on Ordi-Distant.
    J'ai tenté de mettre à jour avec la commande avec powershell
    Set-RDSessionCollectionConfiguration -CollectionName App -CustomRdpProperty "drivestoredirect:s:*" et pareil avec drivestoredirect:s:*
    Sans succès. (Même si au niveau base de registre et fichiers rdp mes modif étaient bien visible)
    J'avais un 2ème serveur RDS en cours d'installtion et j'ai remarqué que pour autoriser le montage de tous les disques dans la base de registre il n y avait aucune entrée.
    Du coup en supprimant l'entrée de ma base j'ai pu retrouver tous mes lecteurs...*Ouf*

    La configuration de RDP se trouve dans

    HL_Machine\Software\Microsoft\Windows NT\CurrentVersion\Terminal Server\CentralPublishedRessources\PublishedFarmes\"Nom de votre CollectionName"\DeployementSettings\CustomRDPSettings..

    Voilà c'est fini :)

    • Marqué comme réponse Jerome.A-74 vendredi 25 juillet 2014 07:55
    vendredi 25 juillet 2014 07:55