Windows Server Essentials 2016: WseMgmtSvc and associated WSE services don't start on reboot of server

    Discussion générale

  •    I thought that I had successfully negotiated the replacement of a 2012 R2 OS with the new 2016 OS, but then I found out that after a reboot, I could not remotely log into the server.  On closer inspection, I found that that the WSE dashboard was not populated with any of the device or user or storage data that had been so carefully supplied during the initialization of the server.  A little research suggested that the Windows Server Essentials Management Service was not running, which was in fact true, and I used the Server Manager to find and start the service.  But I also noticed that there were other WSE services that had not been started.  The absence of these services has a disastrous effect on the server, since it will not perform backups or share files or allow remote access until these services are activated.  In essence, the server is useless until these services are started, and after they are started, the server resumes all it's tasks very nicely.  

         So the only solution I have discovered is to sit in front of the server console, login, and use the Server Manager to start the services.  But I fear that this problem will require this on-site intervention frequently, since I presume the server will update itself and reboot overnight.  This is not a good solution for me, because I do as much remote administration as I can.  I would like, of course, to discover what is keeping the services from starting and correct that problem.  But failing that, at least I should be able to provide a script of some sort to run automatically at reboot to start these services without requiring personal intervention. 

         I have read that this phenomenon may be associated with the corruption of the file named DevicesInfo.xml, found in this folder: Program Data\Microsoft\Windows Server\Data.  During the process of configuring the server, I had several hard drives attached in several different combinations, and perhaps this xml file became confused in the process and is indeed corrupt.  But I have not found a way to re-create it. There is some discussion about this here:

    but according to the referenced post, the issue has not been resolved. 

      I have found that this forum can help supply good answers, but sometimes it takes quite a while for them to emerge.  As always, I will appreciate any and all suggestions and information relevant to this issue.  Thanks!


    samedi 19 novembre 2016 03:16

Toutes les réponses

  • Well, as usual, I wind up talking to myself on this forum.  But maybe someone benefits....

       I am not making any progress on finding the reason why the WseMgmtSvc service is not starting, but I have found a couple of things to try to make it start.   First of all, I have found that by editing the services entry for this service, I can change the procedure for what happens if the service fails to start.  There are instructions for what to do for the first and second failure to start, and then an instruction for "subsequent failures".  You can find this on the "recovery" tab of the properties pop-up window.  The first and second failure instructions are to "restart the service", but the subsequent failure instruction is to "Take no action".  I changed this one to "restart the service".

       Then I also found out about the sc.exe program, which is the Services Control utility.  This can be used to start a service.  I used the Task Scheduler to schedule a start of WseMgmtSvc when the system starts. 

       I have not yet brought the system down and restarted it because I want to be present at the console when this happens.  But I will be doing that within the next week, and I will report back with the results.  In the meantime, if any reader knows why I shouldn't be doing this, please make an entry here to explain.  Thanks.


    lundi 21 novembre 2016 03:44
  • The above actions worked.  Or at least something did.  I have confirmation that my scheduled task ran and succeeded, so I presume that it deserves the credit for fixing the problem.  Anyway, Windows Server Essentials 2016 now is behaving as I expect it to, and I hope it will continue to do so.


    mercredi 23 novembre 2016 16:14
  • I realize this is an older thread but though I would add my experience with this type of issue and the solution that worked in case someone else is searching.

    I am running WSE 2016 and after an update several months ago (if not longer) anytime the server would be rebooted my clients would not connect to the server and I could not log on remotely. If I logged on directly and opened up Server Manager I would see 5 services that had stopped: WseMgmtSvc, WseHealthSvc, WseNtfSvc, TscPubRDC and Tssdis. I could Start each service and the server would be fine until the next update that required a restart and then I was back to the services being stopped. After finally getting frustrated I started searching for a solution and cam across this:

    After setting the 5 services to Automatic (delayed start) I rebooted the server. My clients connected to the server and I was able to log in remotely.

    vendredi 18 mai 2018 16:34