none
Problème service DHCP Windows 2012 R2 Essential RRS feed

  • Question

  • Bonjour,

    J'ai un soucis avec le service DHCP de mon 2012 R2 Essential.

    En effet j'ai chez moi un 2012 R2 Essential avec un DHCP, DNS et WDS pour faire des installations de Windows en PXE.

    Je suis informaticien auto-entrepreneur et je travaille depuis chez moi.

    J'ai aussi un DHCP sur mon routeur TP-Link Archer C3150 (acheté récemment, 1 semaine).

    Avant j'avais un Netgear R6300v2, je n'avais aucuns soucis avec les 2 DHCP d'activé.

    Mais maintenant depuis que j'ai installé le TP-Link, le serveur coupe le service DHCP comme quoi il à détecté un autre serveur DHCP (mon routeur). 

    Je n'ai changer aucuns paramètres, le TP-Link à exactement les mêmes paramètres que le Netgear que j'ai mis au placard (problème WiFi et bug du firmware). 

    Le routeur distribue les adresses de .2 à .100, mon serveur, de .101 à .254.

    Le serveur ne sert qu'à du PXE (pour l'instant).

    Je ne peux pas désactiver le DHCP de mon routeur, le serveur n'est pas destiné à tourner 24h/24.

    J'ai besoin d'un DHCP pour attribuer des IP aux PC/tablettes/consoles de jeux ou smartphones de mes clients qui se connectent en RJ45 ou WiFi.

    Il n'y a pas d'IPv6, j'ai bien une IP fixe sur le serveur.

    J'avais lu que ça pouvais venir du fait que Essential ne prenais en charge qu'un serveur DHCP sur le réseau, si c'était le cas, avec mon Netgear j'aurais eu le même problème que j'ai maintenant.

    Et aussi autre petit soucis qui n'a rien à voir : sur le TP-Link le service SSH est activé par défaut (sans doute pour gérer le routeur à distance, mais j'ai désactivé cette option), et je n'ai aucunes options pour le désactiver ou changer le port, heureusement la connexion en SSH est impossible (vu que j'ai désactiver l'accès à distance). Et aussi, y'a t'il possibilité d'avoir du français sur ce routeur ?

    Merci d'avance.

    jeudi 1 février 2018 19:49

Réponses

  • bonjour,

    en général un DHCP "hardware" prend toujours la main sur un DHCP "Software".

    en règle général, il n'y a jamais 2 serveurs DHCP sur le même LAN, c'est très bizarre que cela fonctionnait avec ton ancien routeur ...

    toutefois il y a une possible solution (à essayer)

    not recommended but you can disable the Rogue DHCP Detection as you suspected via registry setting:

    HKEY_LOCAL_MACHINE\System\
    CurrentControlSet\Services\Dhcpserver\Parameters\
    create a DWORD called "DisableRogueDetection" and assign a value of 1.

    I would however recommend you troubleshoot the "other DHCP server" you have on the network and disable.  You can attempt to use this tool to assist:
    http://blogs.technet.com/b/teamdhcp/archive/2009/07/03/rogue-dhcp-server-detection.aspx

    source :

    https://www.experts-exchange.com/questions/27968986/SBS-2011-DHCP-server-stops-if-another-DHCP-server-is-found.html

    il y a aussi une autre option : faire 2 réseaux (192.168.0.0 avec le serveur et 192.168.1.0 avec ton routeur)

    dimanche 4 février 2018 09:00

Toutes les réponses

  • Bonjour DARLAIVE,

    Veuillez consulter le thread suivant (l'information est en anglais, je suis à votre disposition pour toute question complémentaire) :
    DHCP running on router. Besides port forward what else do i need to do?

    Cordialement,
    Teodora


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    vendredi 2 février 2018 15:29
    Modérateur
  • Bonsoir,

    J'ai mis l'IP du serveur en DNS principal mais toujours le même problème malheureusement.

    Cordialement.

    EDIT : Je suis obligé de désactiver la carte réseau du serveur, activé DHCP et activer la carte réseau pour que DHCP fonctionne.
    • Modifié DARLAIVE samedi 3 février 2018 00:32 rajout d'informations
    samedi 3 février 2018 00:29
  • bonjour,

    en général un DHCP "hardware" prend toujours la main sur un DHCP "Software".

    en règle général, il n'y a jamais 2 serveurs DHCP sur le même LAN, c'est très bizarre que cela fonctionnait avec ton ancien routeur ...

    toutefois il y a une possible solution (à essayer)

    not recommended but you can disable the Rogue DHCP Detection as you suspected via registry setting:

    HKEY_LOCAL_MACHINE\System\
    CurrentControlSet\Services\Dhcpserver\Parameters\
    create a DWORD called "DisableRogueDetection" and assign a value of 1.

    I would however recommend you troubleshoot the "other DHCP server" you have on the network and disable.  You can attempt to use this tool to assist:
    http://blogs.technet.com/b/teamdhcp/archive/2009/07/03/rogue-dhcp-server-detection.aspx

    source :

    https://www.experts-exchange.com/questions/27968986/SBS-2011-DHCP-server-stops-if-another-DHCP-server-is-found.html

    il y a aussi une autre option : faire 2 réseaux (192.168.0.0 avec le serveur et 192.168.1.0 avec ton routeur)

    dimanche 4 février 2018 09:00
  • Bonsoir,

    Merci, ça fonctionne.

    Normalement on peut avoir 2 serveurs DHCP, ou plus, sur le même réseau, tant qu'ils ne distribue pas sur les mêmes étendues.

    dimanche 4 février 2018 17:57
  • Bonjour,

    Je suis d'accord avec R-S, il est assez inhabituel de trouver deux serveurs DHCP sur le même réseau (même si techniquement possible en cas de ranges différents).

    De plus, d'un point de vue purement logique et technique, ne serait-il pas préférable de travailler avec 2 VLANs? Ainsi, le premier reste accessible au public et le second est dédié aux installations via PXE.

    À mon humble avis, j'aurais sans doute procédé de la sorte en pareille situation.

    Bien à vous,
    // Sébastien
    dimanche 4 février 2018 21:18