none
Hyperviseur qui ne repond plus RRS feed

  • Question

  • Bonjour à tous,

    Cela fait quelques année que nous avons un cluster de deux serveurs hyper-v 2012. Depuis quelques semaines, le deuxième hyperviseur n'arrive plus à fonctionner. Il affiche une erreur 5120 : "Le volume partagé de cluster « Volume1 » (« Nom du volume») est à l’état suspendu en raison de « (c00000c9) ». Toutes les opérations d’E/S seront temporairement mises en file d’attente jusqu’à ce qu’un chemin d’accès au volume soit rétabli".

    Lorsque j'essaye d'accéder au dossier ClusterStorage depuis cette hyperviseur, le système se fige et je dois redémarrer le serveur. L'accès au données se fait via le protocole iscsi.

    J'ai sorti et entré le serveur dans le cluster le problème reste le même.

    Merci pour votre aide.

    mardi 3 novembre 2020 15:24

Réponses

  • Bonjour

    Regarde le lien ci dessous (il couvre 2008 mais peut être il convient pour 2012) :

    https://docs.microsoft.com/fr-fr/troubleshoot/windows-server/backup-and-storage/event-5120-5142-access-clusterstorage-folder

    Cause

    Lors de l’accès à un volume CSV à partir d’un nœud passif (non coordinateur), les e/s disque vers le nœud propriétaire (coordinateur) sont acheminées via une carte réseau « préférée » et nécessite l’activation de SMB sur cette carte réseau. Pour que les connexions SMB fonctionnent sur ces cartes réseau, les protocoles suivants doivent être activés :

        Client pour les réseaux Microsoft
        Partage de fichiers et d'imprimantes pour les réseaux Microsoft

    Résolution

    Examinez chaque nœud de cluster et assurez-vous que les protocoles suivants sont activés : les cartes réseau disponibles pour l’utilisation de cluster :

        Client pour les réseaux Microsoft
        Partage de fichiers et d'imprimantes pour les réseaux Microsoft

        Cliquez sur Démarrer, sur Exécuter, tapez ncpa.cpl, puis cliquez sur OK.
        Cliquez avec le bouton droit sur la connexion au réseau local associée à la carte réseau, puis cliquez sur Propriétés.
        Vérifiez que les protocoles ci-dessus s’affichent dans la zone cette connexion utilise les éléments suivants . Si ce n’est pas le cas, procédez comme suit :
            Cliquez sur installer, sur client, puis sur Ajouter.
            Sélectionnez le protocole manquant, cliquez sur OK, puis sur Oui.
        Vérifiez que la case à cocher qui apparaît en regard de client pour les réseaux Microsoft est sélectionnée.


    "Marquer comme réponse" les réponses qui ont résolu votre problème



    mercredi 4 novembre 2020 11:49

Toutes les réponses

  • Salut, 

     vous avez deux serveur en cluster avec hyperviseur installé, et des machines dedans ? quel est le problème réel car c'est un peu confus, ce sont les VMS ou la machine hote qui ne démarre plus ? et qu'est-il de l'autre noeud ?

    car la tu indiques pas l'infra, les noeuds, etc....



    Dakhama Mehdi : Windows developper https://github.com/dakhama-mehdi

    mardi 3 novembre 2020 16:12
  • Bonjour

    Regarde le lien ci dessous (il couvre 2008 mais peut être il convient pour 2012) :

    https://docs.microsoft.com/fr-fr/troubleshoot/windows-server/backup-and-storage/event-5120-5142-access-clusterstorage-folder

    Cause

    Lors de l’accès à un volume CSV à partir d’un nœud passif (non coordinateur), les e/s disque vers le nœud propriétaire (coordinateur) sont acheminées via une carte réseau « préférée » et nécessite l’activation de SMB sur cette carte réseau. Pour que les connexions SMB fonctionnent sur ces cartes réseau, les protocoles suivants doivent être activés :

        Client pour les réseaux Microsoft
        Partage de fichiers et d'imprimantes pour les réseaux Microsoft

    Résolution

    Examinez chaque nœud de cluster et assurez-vous que les protocoles suivants sont activés : les cartes réseau disponibles pour l’utilisation de cluster :

        Client pour les réseaux Microsoft
        Partage de fichiers et d'imprimantes pour les réseaux Microsoft

        Cliquez sur Démarrer, sur Exécuter, tapez ncpa.cpl, puis cliquez sur OK.
        Cliquez avec le bouton droit sur la connexion au réseau local associée à la carte réseau, puis cliquez sur Propriétés.
        Vérifiez que les protocoles ci-dessus s’affichent dans la zone cette connexion utilise les éléments suivants . Si ce n’est pas le cas, procédez comme suit :
            Cliquez sur installer, sur client, puis sur Ajouter.
            Sélectionnez le protocole manquant, cliquez sur OK, puis sur Oui.
        Vérifiez que la case à cocher qui apparaît en regard de client pour les réseaux Microsoft est sélectionnée.


    "Marquer comme réponse" les réponses qui ont résolu votre problème



    mercredi 4 novembre 2020 11:49
  • Bonjour Doug936,

    Si vous avez trouvé une solution à votre problème, merci de la partager avec la communauté TechNet ou "Marquer comme réponse" les réponses qui ont résolu votre problème.

    Je vous remercie par avance pour votre retour.

    Cordialement, 
    Nedeltcho

    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    mercredi 25 novembre 2020 08:26