locked
Windows SBS 2008 Serveur de Fax RRS feed

  • Discussion générale

  • Bonjour à tous,

     

    Je développe actuellement une application pour un client qui servirait de spooler de fax : en connexion avec une liste de destinataires, envoi "séquentiel" des fax à Windows, et suivi "bloquant" de l'état d'envoi (en attente de l'information fax envoyé / en erreur) pour en informer le client.

    J'arrive relativement facilement à envoyer un fax au serveur et à en récupérer l'état. Mon problème survient lorsque j'essaye d'envoyer plusieurs fax simultanément (le serveur dispose de 4 fax USB USRobotics V92) :

    - je prend ma liste de destinataire

    - je la sépare en 4 file d'envoi

    - pour chaque file dans un traitement séparé, envoi séquentiel des fax de la liste, avec attente jusqu'à ce que le fax soit envoyé ou en erreur

     

    Il semblerait que Windows n'utilise pas les 4 fax à sa disposition (pas de règle d'envoi particulière), et j'ai même certains cas où certaines files "bloquent" (je ne sais pas où, mais j'en déduis que Windows ne retourne aucune information à l'application lui indiquant "le fax est envoyé / en erreur").

     

    Quelqu'un aurait une piste pour m'orienter ?

     

    Cordialement,

    Lionel

    lundi 21 février 2011 15:32

Toutes les réponses

  • Bonjour,

    Pourquoi ne te sert-tu pas des groupes de périphériques dans le serveur de fax avec un groupe d'envoi qui contient tes 4 modems.

    Comme ça tu fais pointer ton programme sur ce groupe d'envoi.

    En espérant t'avoir aidé.


    Sylvain D. MCTS
    lundi 28 février 2011 22:06
  • Bonjour Sylvain,

     

    Peux-tu m'expliquer comment faire "pointer" mon programme sur le groupe d'envoi (les 4 fax sont dans le <groupe> "tous les périphériques") ? Je n'ai pas souvenir d'avoir vu ce genre de fonctions disponibles.

     

    Merci d'avance,

    Lionel

    mardi 1 mars 2011 07:50
  • Bonjour Lionel,

    Je ne suis pas un expert en dev donc je ne peux pas t'aider sur le pointage.

    Pour ce qui est du groupe, tu vas dans "routage de trafic sortant" et tu fais clic droit et nouveau groupe, tu appels par exemple ton groupe "envoi".

    Ensuite tu fais clique droit sur ton groupe et nouveau périphérique et tu mets tes 4 modems dans ce groupe.

    Ensuite tu vas dans les règles, et tu fais clic droit sur ta règle, propriété et au lieu d'avoir un périphérique en cible, tu mets ton groupe de routage.

    N'hésites pas si ce n'est pas clair ou si je ne t'aide pas...

    Bonne journée. 


    Sylvain D. MCTS
    mardi 1 mars 2011 08:13
  • Merci Sylvain pour cette réponse rapide.

     

    Je viens de vérifier, et mes périphériques sont déjà dans le groupe "Tous les périphériques", et la règle par défaut pointe bien sur ce groupe. Windows fait-il une différence entre le groupe par défaut et les autres groupes ?

     

    Par contre je soupçonne le client de ne pas avoir connecté 4 lignes "viables" sur les fax : quand des fax sont dans le spool, deux des périphériques restent à "inactif" (il me semble), et 1 fax sur 2 sort en erreur (en moyenne). Il n'y aurait donc qu'une seule ligne valable... Je creuse de ce côté là.

     

    Je garde le sujet ouvert, et j'y reviendrai dès que j'en sais plus..

     

    Lionel

    mardi 1 mars 2011 09:19
  • Tu as raison pour les règles, c'est tout bon dans la config.

    Par contre pour les lignes, ça semble être le point à creuser.....

    Bon courage.


    Sylvain D. MCTS
    mardi 1 mars 2011 09:47
  • Bonjour Sylvain,

     

    Vérifications faites, il y avait bien un soucis sur les lignes de téléphone (les cables fournis avec les fax étaient incompatibles avec les lignes disponibles).

     

    Cependant il nous reste le problème de l'envoi simultané des fax... Sais-tu s'il est possible de le faire sans passer par l'imprimante fax ?

     

    Cordialement,

    Lionel

    lundi 21 mars 2011 07:49
  • Bonjour Lionel,

    cool pour les lignes j'aurais dû y penser, les câbles sont différents selont le RNIS ou Analogique.

    A part l'imprimante fax et le goupe de routage sortant, je ne vois pas...

     

    Désolé. Bon courage.


    Sylvain D. MCTS
    mercredi 23 mars 2011 20:37