none
Can't edit Sharepoint 2013 site page.

    Question

  • I'm running into an issue in Sharepoint 2013 where I can't edit a page on a sub-site, that it appears I should have permissions to, and I'm the sole administrator. I click on 'Edit Page', and most of the options are greyed out. What's interesting is that I can still edit all of the Lists, Libraries and Wikis within the page, just not the main page layout. 

    This isn't the case on any of the other Sharepoint sub sites, or the top level site. The permissions are inherited, which means that it should work.

    Is there a way to reset the permissions, like a propagation downwards in Windows?

    lundi 1 avril 2013 22:32

Toutes les réponses

  • Hi Tim,

    You need to first checkout the page then try "Edit Page"

    Navigate to

    Site Settings -> Site Content -> Site Pages -> Click on "..." next to page name -> Click on "..." -> Check out

    Help image link: Image Here

    Now when you "Edit page" it will work. Once done with editing make sure to check in the page.

    Thanks,

    Mayank

    mardi 2 avril 2013 06:21
  • Hi Mayank,

    That wasn't the answer, but it led me to the solution :) What happened was that I had edited the site properties, and messed something up. While looking through every menu option, I clicked 'Add a Page', it fixed whatever had broken, and now is back to normal. Strange!
    mercredi 3 avril 2013 16:05
  • Hey Tim,

    i experienced the same problems.

    I tried a lot of different approaches and found a solution which worked for me:

    I am using an Alternate Access (for example: sp.blabla.com directs to serversp-bla)

    When I tried to edit it on the sp.blabla.com-adress it always threw me out of editting mode. 

    But when I tried doing it on the "real" adress (serversp-bla) I had no problem editing the page and adding or deleting web parts, add parts, etc.

    I hope you can follow my line of thought and hope this will help you.

    Greets, PoetmitKnall aka. Francesco.

    jeudi 23 janvier 2014 15:30
  • This did not work
    lundi 24 février 2014 19:03
  • Hi Tim,

    You need to first checkout the page then try "Edit Page"

    Navigate to

    Site Settings -> Site Content -> Site Pages -> Click on "..." next to page name -> Click on "..." -> Check out

    Help image link: Image Here

    Now when you "Edit page" it will work. Once done with editing make sure to check in the page.

    Thanks,

    Mayank

    Checking the page out, then clicking edit worked for me :-)  Thanks!
    jeudi 20 mars 2014 08:17
  • I am in edit mode with the page checked-out and am I Site Collection Admin. The page layout refuses to be allowed to be changed. 
    mercredi 20 mai 2015 05:10
  • Did you ever solve the issue? I am in the same trouble right now.
    mercredi 15 juillet 2015 17:10
  • I have found some limited success by using the full domain name of the server in the URL. For some reason, the aliased name doesn't give me the same abilities. Something to do with the server admin / installation not being quite right. Maybe this helps you perhaps. Good luck.
    lundi 27 juillet 2015 13:54
  • I'm still having trouble with this as well.  Anyone?

    I am now the site designer so I can get in, but others on my team are unable to edit page.  It's not checked out to anyone either. 

    We also discovered that sometimes they can get in and other times they cannot.

    vendredi 9 octobre 2015 21:04
  • I have the same problem and the "workarounds" couldn't fix it here.

    Has anyone an idea?

    mercredi 6 juillet 2016 13:01
  • I am also having the same issue, but it seems to be only the Project Template that is the problem.  When I create a project template (and I have done this with on-prem and O365) the site contents do not include a site pages doc library app.  So no site page app means no checkout (nothing to check out) and no edit properties.

    So my question is, where is this page coming from if not from the site page doc lib? and how do I edit it?

    jeudi 7 juillet 2016 14:31
  • I resolved the same problem by opening the page in "maintenance mode" (edit properties/Link to Open in maintenance mode). There was a script inside that wasn't supposed to be there. I deleted it and then everything was OK again.
    mercredi 14 septembre 2016 10:04
  • I was hoping this would fix it (Maintenance Mode) ... no go. :(
    jeudi 22 septembre 2016 16:36
  • This incident occurred to me, when I made some edits to the custom master page we had applied. Restoring to a previous version solved the issue.  I made my edits again but the problem did not appear. So, I am clueless as to what exactly caused the issue but atleast I now know what could be a probably cause.

    shreyas ganta

    jeudi 20 octobre 2016 16:32
  • I have the same issue.  I am not able to use the edit page option from the Site cog wheel, however when I use the Edit button next to the Share / Follow options (page checked out), then I am able to edit page content.   Otherwise I can only edit apps. 

    MS support wouldn't support me as I have a customer master page.  I'm checking through the page now for any errors, but would love an answer for this. 


    jeudi 24 novembre 2016 15:52
  • If you are unable to open a SP page in Edit Mode(Edit option do not work) in SharePoint 2013. Mostly it happened due to JavaScript error. Reason could be many. This time we thought that we should delete the page and recreate this but do not do this immediately without doing research.  

    One example/scenario of above problem is below:

    i) Suppose you did any JavaScript change recently in Script Editor and in Content Editor WebPart.  

    Solution: 

    1) Open the page in SharePoint Designer to Edit. SP Designer will open it in Browser and you could edit there to fix the problem. you could revert you recent changes to change 

    2) Open the page in SharePoint Designer to Edit. SP Designer will open it in Browser and you could revert your latest changes to get the previous correct state of page.

    3) Go to Site contents on same SharePoint page. You will get this page by clicking on Settings wheel available on top right menu. On "Site Contents" Page click on "Pages" then you will get the listing of pages. Select your page and click on 3 dots(...), it opens a new small dialogue, here also you will get 3 dots(...), as you will click on these dots you will get a sub menu. In this Sub menu many options are there. So please choose Version History, It will opens Version History page to show all the versions of this page. Please select the last successful version and you will get Restore option by clicking the down arrow link(You will get once you hover mouse on that version title) next to title of Version.

    If it will not solve then also please comment/query.

    Thanks.

    Shekhar

    vendredi 30 juin 2017 07:23
  • Although old, thought I'd comment that I am facing same issue.  It has nothing to do with not checking out, etc.  Fact is, I can create and edit a new page, there is just this one page that ... one that I created a year ago ... that will not allow edit even though I can check it out, and can place the page in edit mode.  I am using an account that has permission to about everything in the enterprise from the page up through the domain, so I am guessing the issue is neither permissions nor my ability to know how to click the checkout button on this page that sits in a library that does not require checkout. 

    One solution is to simply re-create the page with web parts.  Trouble is that this happens periodically and would be nice to know the root cause.

    mardi 8 août 2017 14:24
  • I had a similar option in SharePoint Online trying to edit a Blog site homepage. Enable the site feature "Site Pages", then you can edit the blog homepage. To verify its not permissions, use a site collection admin account to test.

    I blogged the solution here: https://eschrader.com/2018/02/28/sharepoint-online-blog-site-how-to-edit-the-homepage/

    • Proposé comme réponse ESchrader jeudi 1 mars 2018 02:18
    jeudi 1 mars 2018 02:18
  • There will be some javascript embedded in the page, that's the reason you won't be able to edit the page.


    If its a wiki page, try it, should work fine. add the below text in front of the page url:

    ?WikiPageMode=Edit&WikiMergeTarget=true



    ex: ........./sites/ABC/SitePages/myPage.aspx?WikiPageMode=Edit&WikiMergeTarget=true


    lundi 19 mars 2018 10:08
  • i have the same issue , can't edit home page

    2 days 'm looking for it , even caald with microsoft , couldn't helpme

    i'm desperate

    samedi 24 mars 2018 13:06
  • tekoko

    Did you find an answer to this mine has just stopped allowing me to edit

    lundi 16 avril 2018 11:04
  • perhaps this can help :

    https://www.qdoscc.com/blog/sharepoint-o365-permissions-deny-add-and-customise-pages-issue

    In SharePoint online management shell (download if you don’t have it)

    Enter:

    Connect-SPOService 

    then

    Enter URL of admin site https://<yourdomain>-admin.sharepoint.com

    Then username and password

    Set-SPOSite -Identity https://<yourdomain>.sharepoint.com -DenyAddAndCustomizePages $false


    • Modifié tekoko10 lundi 16 avril 2018 12:10
    • Proposé comme réponse DenBro vendredi 13 juillet 2018 08:55
    lundi 16 avril 2018 12:09
  • That worked for me!  Thanks!
    jeudi 5 juillet 2018 18:45
  • perhaps this can help :

    https://www.qdoscc.com/blog/sharepoint-o365-permissions-deny-add-and-customise-pages-issue

    In SharePoint online management shell (download if you don’t have it)

    Enter:

    Connect-SPOService 

    then

    Enter URL of admin site https://<yourdomain>-admin.sharepoint.com

    Then username and password

    Set-SPOSite -Identity https://<yourdomain>.sharepoint.com -DenyAddAndCustomizePages $false



    This fixed my problem thanks
    vendredi 13 juillet 2018 08:55