none
activation Windows 10 impossible suite sysprep RRS feed

  • Question

  • Bonjour à tous,

    j'ai crée une image windows 10 version 1703 avec sysprep que je capture et deploie sur d'autres postes.

    Une fois le déploiement fait sur un autre poste, windows ne s'active pas.

    Le type de licence est SLP, licence lié au materiel (hp) qui s'active grace au bios.

    Les précédent images faites avec les anciennes version de windows 10 n'avaient pas de problèmes, les fichiers xml de réponses automatiques n'ont pas changés.

    Dans le panneau de configuration j'ai une erreur d'activation 0x803F7001 et dans l'observateur d'évenement une erreur "Échec de l’activation des licences (slui.exe) avec le code d’erreur suivant :hr=0x80004005"

    j'ai cherché sur le net mais rien de concret pour ces erreurs.

    Autre chose d'étrange, si le PC sur lequel je deploie mon image été déjà activé, il s'active très bien avec la nouvelle image.

    quelqu'un aurait une idée de ce qui peut poser problème ?

    merci d'avance

    jeudi 11 mai 2017 16:19

Réponses

  • Bonjour,

    Encore une fois, ce n'est pas supporté par microsoft

    https://support.microsoft.com/en-us/help/828287/unsupported-sysprep-scenarios

    C'est sur supporté que HP le fasse, pas vous...

    En cas d'escalade auprès de microsoft, il ne vous aideront pas car ils peuvent savoir que c'est un sysprep qui ne vient pas du constructeur.

    Une licence OEM ne permet pas grand chose malheureusement si ce n'est l'installation sur une machine à la main... ou une copie du CD oem pour le déployer de manière //

    Voici un article microsoft qui précise également les cadre d'activation automatiques de windows 10

    https://support.microsoft.com/en-us/help/12440/windows-10-activation

    A partir du moment ou windows 10 pro par exemple a été activé sur la machine, si on réinstalle un windows 10 pro en formatant la machine, on voit bien qu'elle sera réactivée automatiquement si le matériel n'a pas été modifié.


    Merci de marquer comme réponse les sujets qui vous ont permis d'avancer afin que cela puisse être bénéfique aux personnes qui rencontrent le même problème.


    vendredi 12 mai 2017 07:47
  • Pour apporter d'autres précisions. Comme Matteu31400 l'a écrit, vous devez avoir un contract avec Microsoft pour des licences en volume si vous modifier des images OEM. Il faut disposer d'une licence en volume pour l'édition Windows que vous utilisé et pour le nombre de poste dans votre parc. C'est l'aspect légal et vous obtiendrez des informations aupres de Microsoft.

    Les méthodes d'activations ont évoluées au fil des versions Windows 10. Si le poste était déja activé comme vous constatez, il n'y aura plus aucun souci d'activation dessus. Par contre, l'activation lié au BIOS n'est plus générique avec un certificat. Ce n'est pas parce que vous utillisé une image personnalisé sur un poste HP que cela va fonctionner. Donc soit vous activez tout vos postes avant de les réimager ou sinon passer par l'achat d'une clé en volume.

    Votre image sans sysprep s'active car les données d'activations, certificats restent présent dans l'image.


    signatureforums

    lundi 29 mai 2017 13:59
    Modérateur

Toutes les réponses

  • Bonjour,

    C'est tout à fait normal.

    1) Il est interdit par le contrat microsoft de déployer Windows 10 en volume via une cle OEM. Il est possible de réaliser cette opération uniquement via une clé KMS ou MAK. Vous n'êtes pas en règle.

    2) L'activation d'une clé OEM lorsqu'elle est réalisé envoit un hardware ID aux serveur de microsoft afin d'enregistrer l'activation en cas de réinstallation du système si le matériel est identique. C'est bien votre cas lorsque vous activez windows 10 une premiere fois puis déployez votre image windows 10 s'active bien.


    Merci de marquer comme réponse les sujets qui vous ont permis d'avancer afin que cela puisse être bénéfique aux personnes qui rencontrent le même problème.

    jeudi 11 mai 2017 18:54
  • Bonjour matteu31400,

    Merci pour votre réponse et de l'intérêt que vous portez à notre sujet. Je travaille avec davzell13 dans le cadre de ce projet de Delivery Windows 10.

    Bien que nous soyons partenaires HP/HPE et Microsoft, nous ne faisons pas de déploiement en volume (ex : Open). Le matériel acheté auprès des grossistes est à destination de nos clients finaux. Windows 10 Pro 64 bits est inclus avec le matériel dans le cadre d'un contrat OEM.

    La personnalisation via SysPrep est autorisée. HP laisse l'opportunité d'utiliser l'image préparée d'usine par le constructeur ou de réaliser sa propre golden image, ce que nous avons choisi de faire. Les précédentes builds de Windows 10 (v1511, v1607) ne posent aucun pb d'activation. Une installation from scratch avec la v1703 sans méthode sysprep fonctionne. Les binaires et nos doutes quant à l'empreinte constructeur dans le BIOS ne sont donc pas en cause.

    Nous allons reprendre le process du début en évitant toute personnalisation pour vérifier que le souci ne vient pas de nos tâches de personnalisation.

    A suivre...

    vendredi 12 mai 2017 07:34
  • Bonjour,

    Encore une fois, ce n'est pas supporté par microsoft

    https://support.microsoft.com/en-us/help/828287/unsupported-sysprep-scenarios

    C'est sur supporté que HP le fasse, pas vous...

    En cas d'escalade auprès de microsoft, il ne vous aideront pas car ils peuvent savoir que c'est un sysprep qui ne vient pas du constructeur.

    Une licence OEM ne permet pas grand chose malheureusement si ce n'est l'installation sur une machine à la main... ou une copie du CD oem pour le déployer de manière //

    Voici un article microsoft qui précise également les cadre d'activation automatiques de windows 10

    https://support.microsoft.com/en-us/help/12440/windows-10-activation

    A partir du moment ou windows 10 pro par exemple a été activé sur la machine, si on réinstalle un windows 10 pro en formatant la machine, on voit bien qu'elle sera réactivée automatiquement si le matériel n'a pas été modifié.


    Merci de marquer comme réponse les sujets qui vous ont permis d'avancer afin que cela puisse être bénéfique aux personnes qui rencontrent le même problème.


    vendredi 12 mai 2017 07:47
  • comment se fait il que sur les anciennes release de win10 il n'y avait aucun problème ? 
    vendredi 12 mai 2017 09:25
  • Pour apporter d'autres précisions. Comme Matteu31400 l'a écrit, vous devez avoir un contract avec Microsoft pour des licences en volume si vous modifier des images OEM. Il faut disposer d'une licence en volume pour l'édition Windows que vous utilisé et pour le nombre de poste dans votre parc. C'est l'aspect légal et vous obtiendrez des informations aupres de Microsoft.

    Les méthodes d'activations ont évoluées au fil des versions Windows 10. Si le poste était déja activé comme vous constatez, il n'y aura plus aucun souci d'activation dessus. Par contre, l'activation lié au BIOS n'est plus générique avec un certificat. Ce n'est pas parce que vous utillisé une image personnalisé sur un poste HP que cela va fonctionner. Donc soit vous activez tout vos postes avant de les réimager ou sinon passer par l'achat d'une clé en volume.

    Votre image sans sysprep s'active car les données d'activations, certificats restent présent dans l'image.


    signatureforums

    lundi 29 mai 2017 13:59
    Modérateur
  • Bonjour,

    Votre conversation m'interesse.

    Actuellement en poste de Technicien dans une boite de Vidéo Surveillance, j'ai été missionné dans le cadre d'une migration Windows 10.

    Après coup, il ne s'agissait plus d'une migration car achat de nouveau PC préinstallé Widows 10 OEM.

    Seulement, voilà, Deux types de poste, un configuré pour poste opérateurs et un poste contenant les logiciels et base de données des différents sites dont nous avons la charge de vérifier caméras.

    Ils sont aux nombre de 13. Pour PC Opérateus, 9 PC identique (même marque, même config) + 5 PC i5 (même marque, même config).

    Pour les PC Opérateurs, aucun soucis car deux logiciels à installer (+mise à jour widows). Je suis obligé de les faire un par un (9 aux total) donc du temps de perdu.

    Mais là où ça se corse c'est les autres postes (aux nombres de 5).

    Il doivent être équipés d'une multitude de programmes (a peu près une 10) plus les dossiers clients.

    Mon problème, c'est que j'ai beau tenté de lui expliquer que déploiement par Image Système Acronis est impossible avec licence OEM, ma supérieur hiérarchique (soit disant admin réseau...) maintient morticus qu'elle a déjà fait ceci sans soucis.

    Si jamais vous avez un lien qui puisse expliquer que c'est impossible je suis preneur. Car je sens gros comme une maison que je vais devoir faire ce déploiement avec méthode qu'elle me préconise (sans en avoir discuté en réunion bien sur, sans la présence des chefs...) et après me coller le problème sur le dos.

    Heureusement que celà n'est qu'une mission qui se termine bientôt mais je n'aime pas le travail mal fait surtout dans l'informatique.

    Soit on fait les choses bien, soit on ne les fait pas pour ne pas déstabiliser un système....

    D'avance merci (j'en peux plus de cette mission où l'on ne fait que de me répéter que je ne suis QUE Technicien de Maintenance Informatique et donc ne suis pas compétent à mettre mon nez dans ceci...

    vendredi 28 février 2020 05:21
  • Bonjour.

    Un petit script PowerShell que j'avais écrit pour l'activation des Windows 10 avec la clé intégrée machine :

    Set-ExecutionPolicy Unrestricted -Scope Process -Force
    $ActivationOUI = Get-wmiobject -Class SoftwareLicensingProduct -filter "ApplicationID = '55c92734-d682-4d71-983e-d6ec3f16059f'" | where licensestatus -eq 1 | FT name,licensestatus
    $service = get-wmiObject -query 'select * from SoftwareLicensingService'
    $key = $service.OA3xOriginalProductKey
    if($ActivationOUI){
    Write-Host 'Deja active'
    }else{
    Write-Host 'Activation avec la cle de produit:' $key
    $service.InstallProductKey($key)
    }

    vendredi 28 février 2020 08:30