none
Mettre à jour des donnés RRS feed

  • Discussion générale

  • Bonjour,

    Quand je souhaite ajouter un utilisateur XX via la fenêtre ci-dessous, l'attribut Service n'est pas bon alors que dans l'AD est correct.

    Comment je peux faire via powershell pour corriger l'info?

    Merci par avance.



    jeudi 13 novembre 2014 09:41

Toutes les réponses

  • Bonjour,

    J'ai pas trop saisi la nuance . Tu dis que l'attribut n'est pas bon ... L'attribut est mal orthographié c'est cela  ou il s'agit d'un autre ? Ou tout autre contraire tu parle de la donnée de cet attribut ?

    De ce que je sais ,tu fais référence à l'attribut "Deparmtent" (in english) et donc "Service" en français. Je suppose donc que tu parle donc de la valeur de cet attribut qui n'est pas bon (?)

    Si c'est le cas , est ce que l'erreur se produit pour un utilisateur uniquement ? 

    As tu vérifié dans les user Profiles l'état de cet attribut ?

    Avant de faire du power shell, je te suggère de déterminer l'origine de ton problème sous peine de devoir réitérer à chaque fois ta solution de contournement (script ps). 

    Dans le pire de cas, purge des user Profil et refait un import depuis l'AD

    Bon courage


    Mutandis mutatis

    dimanche 16 novembre 2014 13:34
  • Bonjour,

    Sans un exemple précis, c'est difficile de comprendre la problématique.

    Il faut connaître la version et édition de SharePoint utilisée dans votre cas, puis savoir quel champs n'est pas correct.

    Pour information, dans la version gratuite, le visualisateur en question utilise les données provenant de la table userinfo, qui n'est chargée qu'une fois (et partiellement) lors de la recherche de l'utilisateur dans l'AD. Il n'y a aucun refresh hormis en supprimant l'utilisateur et le recréant, ou ia un script PowerShell schedulé.

    Fabrice


    Romelard Fabrice [MVP]

    mercredi 26 novembre 2014 12:04