none
Envoie mail depuis AS400 (ajout problème WSUS 3.0) RRS feed

  • Question

  • Bonjour,

     

    Après avoir fait la transition d'Exchange 2000 vers Exchange 2007, nous sommes confronté à un problème d'envoie de mail depuis un AS400 vers l'extérieur.

    Je précise que je ne connais pas du tout l'AS400 et que la configuration a été faite par une société externe.

     

    Pour préciser la situation, l'envoie se faisait sans aucune difficulté lorsque l'organisation était sous Exchange 2000.

    Dans la configuration de l'AS400, nous rentrons l'adresse IP du serveur de Transport HUB, nous utilisons l'authentification d'un compte qui a les droits sur l'organisation pour l'envoie d'un mail en smtp.

    Sous Exchange 2007 - serveur de Transport Hub, il a fallu rajouter l'option anonyme dans le connecteur de réception default pour l'envoie en interne, et ce n'est pas la meilleure solution, mais je n'ai pas trouvé d'autre moyen.

    Par contre, pour l'envoie externe, nous n'y parvenons pas et nous obtenons une erreur 535 authentification failed.

    Si nous créons un connecteur faisant du serveur Transport un relais ouvert, cela fonctionne, mais ce n'est pas viable et nous avons de suite supprimé ce connecteur.

     

    Avez-vous déjà rencontré un problème tel que celui-ci et avez-vous trouvé une solution ?

     

    Merci.



    Ajout du 7/11/2008

    Je viens de m'appercevoir que j'ai le même problème avec l'envoie de mail depuis WSUS 3.0 sans ou avec SP1, si cela peut faire avancer dans la solution.

    Je suis en train de monter une plate-forme de test chez un autre client, et j'ai le même soucis.

    Dans la console "Update Services", "Options", je clique sur "Notifications par courrier électronique", je rajoute une adresse interne ou externe au domaine dans l'onglet "Général", puis dans l'onglet "Serveur de messagerie", je rajoute les informations concernant le serveur, le port est celui par défaut, les "Informations de l'expéditeur" (celui-ci possède un compte AD), et les  "Informations d'ouverture de session" correspondant au compte de l'expéditeur.

    Même situation que pour l'AS 400, je ne peux envoyer en interne que si je mets l'authentification anonyme dans le connecteur de réception. Par contre, je ne peux pas envoyer de mail vers l'extérieur. Le message est "authentification failed".

    Pouvez-vous m'aider à résoudre ce soucis au niveau de la configuration de mon Exchange ?

    Merci.



    Philippe

    dimanche 2 novembre 2008 09:52

Réponses

  • Pour WSUS, j'ai trouvé la solution suivante, il suffit de faire un nouveau connecteur de réception avec l'option "Personnalisé".

    Dans la console EMC, étendre "Configuration du serveur", puis cliquez sur "Transport Hub".
    Dans le menu de droite, cliquez sur "Nouveau connecteur de réception...".
    Dans la fenêtre "Nouveau connecteur de réception SMTP", donnez un nom explicite (par exemple WSUS, nous utiliserons ce nom pour la suite des explications), dans le champ "Sélectionner l'utilisation prévue ppour ce connecteur de réception :", choisir "Personnalisé", puis cliquez sur "Suivant".
    Dans la section "Paramètre du réseau local", laissez la valeur par défaut, puis cliquez sur "Suivant>".
    Dans la section "Paramètre du réseau local", supprimer la plage d'adresse "0.0.0.0-255.255.255.255" en cliquant sur la croix rouge, puis cliquez sur "Ajouter..." et dans la fenêtre "Ajouter une ou des adresses de serveurs distants" inscrire l'adresse du serveur WSUS devant envoyer des mails interne ou externe (il faudra recommencer ces opérations pour chaque serveur WSUS). Cliquez ensuite sur "Suivant>", puis cliquez sur "Nouveau" et enfin sur "Terminer".
    Dans la partie centrale, sous "Connecteur de réception", vous devriez avoir le connecteur WSUS.
    Dans le menu de droite, sous WSUS, cliquez sur "Propriétés".
    Dans la fenêtre "Propriétés de WSUS", cliquez sur l'onglet "Groupes d'authentification" et cochez "Serveurs Exchange".
    Cliquez sur l'onglet "Authentification", laissez coché la case "TLS", et cochez celle qui correspond à "Sécurité de l'extérieur", cliquez enfin sur "OK".
    Vous pouvez effectuer un test d'envoie depuis le serveur WSUS, il ne devrait pas être nécessaire de fournir un compte d'authentification.

    Par contre, il faut absolument suivre l'ordre de cette procédure surtout sur les propriétés, il faut commencer par l'onglet "Groupes d'authentification", puis passer à l'onglet "Authentification".

    En espérant que cela pourra aider d'autres personnes qui auront eu le même problème.

     

    Pour l'AS400, j'attends la réponse de notre autre client pour valider cette réponse.

    lundi 10 novembre 2008 15:01

Toutes les réponses

  • Pour WSUS, j'ai trouvé la solution suivante, il suffit de faire un nouveau connecteur de réception avec l'option "Personnalisé".

    Dans la console EMC, étendre "Configuration du serveur", puis cliquez sur "Transport Hub".
    Dans le menu de droite, cliquez sur "Nouveau connecteur de réception...".
    Dans la fenêtre "Nouveau connecteur de réception SMTP", donnez un nom explicite (par exemple WSUS, nous utiliserons ce nom pour la suite des explications), dans le champ "Sélectionner l'utilisation prévue ppour ce connecteur de réception :", choisir "Personnalisé", puis cliquez sur "Suivant".
    Dans la section "Paramètre du réseau local", laissez la valeur par défaut, puis cliquez sur "Suivant>".
    Dans la section "Paramètre du réseau local", supprimer la plage d'adresse "0.0.0.0-255.255.255.255" en cliquant sur la croix rouge, puis cliquez sur "Ajouter..." et dans la fenêtre "Ajouter une ou des adresses de serveurs distants" inscrire l'adresse du serveur WSUS devant envoyer des mails interne ou externe (il faudra recommencer ces opérations pour chaque serveur WSUS). Cliquez ensuite sur "Suivant>", puis cliquez sur "Nouveau" et enfin sur "Terminer".
    Dans la partie centrale, sous "Connecteur de réception", vous devriez avoir le connecteur WSUS.
    Dans le menu de droite, sous WSUS, cliquez sur "Propriétés".
    Dans la fenêtre "Propriétés de WSUS", cliquez sur l'onglet "Groupes d'authentification" et cochez "Serveurs Exchange".
    Cliquez sur l'onglet "Authentification", laissez coché la case "TLS", et cochez celle qui correspond à "Sécurité de l'extérieur", cliquez enfin sur "OK".
    Vous pouvez effectuer un test d'envoie depuis le serveur WSUS, il ne devrait pas être nécessaire de fournir un compte d'authentification.

    Par contre, il faut absolument suivre l'ordre de cette procédure surtout sur les propriétés, il faut commencer par l'onglet "Groupes d'authentification", puis passer à l'onglet "Authentification".

    En espérant que cela pourra aider d'autres personnes qui auront eu le même problème.

     

    Pour l'AS400, j'attends la réponse de notre autre client pour valider cette réponse.

    lundi 10 novembre 2008 15:01
  • Bonsoir,

     

    la solution "connecteur" de réception ouvert et autorisant le relais, peut être une solution, à condition de n'autoriser que l'adresse IP du serveur AS400 à se connecter.

    A+

     

    lundi 10 novembre 2008 22:25
    Modérateur
  • Bonjour,

     

    Merci pour cette confirmation.

    En effet, faute de pouvoir faire autrement, le client devra utiliser cette solution et ne fournira que l'adresse IP du serveur.

    Les personnes qui ont déployé l'AS400 ne lui proposant pas d'autre alternative à ce jour.

     

    @+

    mardi 11 novembre 2008 09:21