none
Publishing workflow no longer overwrites existing version

    Question

  • I modified the existing workflow and published it. However the new workflow comes into effect on the next day. I got SharePoint 2013 and Designer 2013. I followed the below steps but didn't help.

      • I removed the previous workflow from the list. (Workflow Settings)
    1. Closed SharePoint Designer
    2. Deleted everything from  \AppData\Roaming\Microsoft\Web Server Extensions\Cache
    3. Deleted everything \AppData\Local\Microsoft\WebSiteCache
    4.  Unchecked "Cache site data across SharePoint Designer sessions” in SPD file -> Options -> General -> Application Options.
    lundi 7 mai 2018 21:05

Toutes les réponses

  • Hi Susan,

    What changes did you make? Are you using a Reusable Workflow? Please provide your workflow for helping us solving your issue.

    It is strange for your issue. In my environment, after I edit the workflow and re-publish it, it will come into effect immediately.

    For narrowing down your issue, try below things:

    1. Create a new list item, run the workflow, check if this workflow come into effect immediately. 

    2. Clear the browser cache.

    3. Logging out and log in again, check the results.

    Best regards,

    Allen Bai



    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    mardi 8 mai 2018 06:57
  • I got a custom list with a list workflow. I changed the "to" field of the email and also conditions in the Workflow. 

    

    A new workflow will come into effect immediately. If there is any modification to an existing workflow, then the changes will show up on next day.

    mardi 8 mai 2018 11:19
  • Hi Susan,

    Have you tried the suggested things mentioned in my first reply? 

    How about create a new list item and run the workflow manually?

    Best regards,

    Allen Bai


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    jeudi 10 mai 2018 01:57
  • The steps you suggested didn't fix the issue. Also I started the workflow manually and didnt see the changes.

    jeudi 10 mai 2018 18:00
  • Hi Susan,

    For your situation, I suggest you delete this workflow and create a new same workflow then have a test.

    Best regards,

    Allen Bai


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    vendredi 18 mai 2018 02:42
  • Hi Susan,

    How are things going? I'm willing to hear from you.

    Best regards,

    Allen


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    jeudi 31 mai 2018 03:20