none
ajouter un second serveur Exchange 2010 RRS feed

  • Discussion générale

  • Bonjour,

    voici ma problèmatique :

    Actuellement, j'ai un serveur exchange 2010 (mailbox,hub,cas)  dans mon domaine.

    Je souhaiterais installer, sur un autre serveur, un second exchange 2010 afin de libérer le premier serveur (trop vétuste!)

    Le problème est que mon nouveau serveur récupère automatiquement les paramètres exchange et IIS du premier serveur alors que je souhaite faire une installation sans récupérer certains bugs (entre autre problème owa sous IIS) du vieux serveur.

    Comment dois-je m'y prendre svp ?

    Merci d'avance pour vos conseils avisés!

    Julien

    mercredi 16 mai 2012 09:51

Toutes les réponses

  • Bonjour,

    La configuration générale d'Exchange est liée et stockée au sein d'Active Directory, chaque serveur ne conserve au final que des paramètres locaux spécifiques.

    Si vous souhaitez repartir "à neuf", il faudra probablement remonter une infra AD + une infra Exchange, ce qui n'est pas toujours possible ; sinon détruire entièrement et proprement votre infra Exchange et la remonter completement.

    mercredi 16 mai 2012 09:58
    Modérateur
  • Bonjour,

    Actuellement, j'ai un serveur exchange 2010 (mailbox,hub,cas)  dans mon domaine.

    Je souhaiterais installer, sur un autre serveur, un second exchange 2010 afin de libérer le premier serveur (trop vétuste!)

    Il sera mieux d'utiliser deux serveus CAS / HUB / MBX et de configurer le DAG entre les deux. Aussi, vous pouvez utiliser le tourniquet DNS pour l'équilibrage de charge.

    Le problème est que mon nouveau serveur récupère automatiquement les paramètres exchange et IIS du premier serveur alors que je souhaite faire une installation sans récupérer certains bugs (entre autre problème owa sous IIS) du vieux serveur.

    Votre serveur récupère les paramètres stockés dans Active Directory. Pour cette raison, il est normal que plusieurs configurations seront partagées. Prière de nous indiquer ce que vous voulez désactiver pour vous aider.


    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.   

    Microsoft Student Partner 2010 / 2011
    Microsoft Certified Professional
    Microsoft Certified Systems Administrator: Security
    Microsoft Certified Systems Engineer: Security
    Microsoft Certified Technology Specialist: Windows Server 2008 Active Directory, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Network Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Applications Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows 7, Configuring
    Microsoft Certified Technology Specialist: Designing and Providing Volume Licensing Solutions to Large Organizations
    Microsoft Certified IT Professional: Enterprise Administrator
    Microsoft Certified IT Professional: Server Administrator
    Microsoft Certified Trainer

    Lien vers mon site Web: http://www.ahmedmalek.com/web/fr/home.asp

    Pour suivre mon activité: http://www.facebook.com/TunisianIt


    • Modifié Mr XMVP mercredi 16 mai 2012 10:10
    mercredi 16 mai 2012 10:09
  • Bonjour,

    chaque serveur Exchange, et en particulier OWA, a sa propre configuration qui lui est spécifique !

    Il n'y aucune raison que le nouveau serveur récupère les bugs, sauf si vous installez les mêmes versions de patchs, hotfixs,... et que la même configuration lui est appliquée.

    Le problème est probablement dans les paramètres et choix généraux.

    Dans le cadre d'une migration entre 2 serveurs, les mêmes rôles doivent être installés.

    Ensuite, il s'agira de répliquer les dossiers publics (s'ils existent) et de déplacer quelques boîtes de tests. Vérifier la bonne intégration, c'est à dire communications internes entre les 2 serveurs, et externes vers Internet.

    Si cela se passe bien, on peut commencer à basculer (configurer) la sortie des messages depuis le nouveau serveur, puis l'arrivée directe des messages sur le nouveau serveur.

    Ensuite, on peut alors migrer/déplacer la totalité des boîtes (la nuit) en une ou plusieurs fois selon la taille.

    En fonction des services utilisés (OWA, Outlook Anywhere, ActiveSync,...), la configuration sera adaptée pour permettre la bascule vers le nouveau serveur. (Si toutes les boîtes peuvent être migrées en une seule fois, la configuration sera simplifiée et se limitera à configurer correctement le nouveau serveur).

    Dans le cadre d'un transfert de boîte, le client Outlook se met à jour automatiquement. Si un CasArray (d'une seule machine) avait été créé, il suffit de modifier l'adresse IP dans le DNS pour que ce nom pointe sur le nouveau serveur.

    La suite logique sera de supprimer les réplicas des dossiers publics de l'ancien serveur, puis de désinstaller tous les rôles de l'ancien serveur.

    A bientôt,

     


    Thierry DEMAN. Exchange MVP. https://www.mcpvirtualbusinesscard.com/VBCServer/MVPtdeman/profile (69 MCPs) http://base.faqexchange.info

    mercredi 16 mai 2012 11:10
    Modérateur
  • bonjour,

    Merci pour ces précisions.

    En fait, je ne souhaite pas remonter les informations d'IIS car ces dernières sont éronées (droit d'accès à owa HS par rapport au fichier webconfig) :

    l'accès à outlook anywhere bugue.

    Le reste de la configuration exchange est correcte.


    juju

    mercredi 16 mai 2012 12:11
  • Bonjour,

    Il y a une chose que je comprends : le nouveau serveur installé récupère les informations de configuration de l'ancien serveur dans la console exchange ainsi que les paramètre de l'ad, OK.

    Par contre, pourquoi réplique-t'il la configuration IIS de l'ancien serveur: c'est cette partie que je souhaiterais reconfigurer à zéro en tenant compte des  paramètres du serveur exchange nouvellement installé.

    Je vais tenter de désactiver l'owa de l'ancien serveur pour voir si la configuration IIS est répliqué lors de l'installation du nouveau...

    Mes interrogations peuvent paraître naïves mais c'est un cas de figure que je ne connais pas...

    dans l'attente de vos suggestions

    Merci!

    Julien


    juju

    mercredi 16 mai 2012 12:23
  • La configuration des accès IIS n'est pas récupérée via AD, donc pas de l'ancien serveur.

    Par contre est ce que vous désinstaller Exchange avant de supprimer un serveur et de le réinstaller?

    Pouvez vous nous indiquer quels sont les droits en erreur selon vous sur IIS, et pourquoi?

    mercredi 16 mai 2012 12:36
    Modérateur
  • Si vous un problème au niveau des répertoires virtuels IIS sur votre serveur, vous pouvez juste les re-créer:

    http://technet.microsoft.com/en-us/library/aa998237.aspx

    http://technet.microsoft.com/en-us/library/bb123752

    http://technet.microsoft.com/en-us/library/bb123679

    http://technet.microsoft.com/en-us/library/aa996916

    http://technet.microsoft.com/en-us/library/bb124231

    http://technet.microsoft.com/en-us/library/bb125176

    http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/96b4ff86-8e29-4dec-8f35-54f1dbf4ba52


    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.   

    Microsoft Student Partner 2010 / 2011
    Microsoft Certified Professional
    Microsoft Certified Systems Administrator: Security
    Microsoft Certified Systems Engineer: Security
    Microsoft Certified Technology Specialist: Windows Server 2008 Active Directory, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Network Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Applications Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows 7, Configuring
    Microsoft Certified Technology Specialist: Designing and Providing Volume Licensing Solutions to Large Organizations
    Microsoft Certified IT Professional: Enterprise Administrator
    Microsoft Certified IT Professional: Server Administrator
    Microsoft Certified Trainer

    Lien vers mon site Web: http://www.ahmedmalek.com/web/fr/home.asp

    Pour suivre mon activité: http://www.facebook.com/TunisianIt

    mercredi 16 mai 2012 12:46
  • Bonjour,

    J'ai (enfin!) réussi à installer mon second serveur exchange et transférer les bal, carnet d'adresse hors connexion etc etc. Pour cela, j'ai tout simplement modifier le nom du serveur.

    Cependant, j'ai deux problèmes :

    1/ je n'arrive pas à désinstaller correctement le 1er serveur exchange (ancien serveur) à cause de 2 bal systèmes (federatedmailboxxxx, systemmailboxxxxx que je n'arrive pas à déplacer ...)

    2/Sous Exchange, j'ai toujours la trace de l'ancien nom du nouveau serveur (pour rappel, c'était le nom du nouveau serveur lorsque l'installation a planté la première fois)

    Bref, j'aimerais bien enlever les traces des anciens serveurs dans le nouvel exchange installé?

    merci d'avance

    julien


    juju

    lundi 21 mai 2012 09:54
  • 1/ je n'arrive pas à désinstaller correctement le 1er serveur exchange (ancien serveur) à cause de 2 bal systèmes (federatedmailboxxxx, systemmailboxxxxx que je n'arrive pas à déplacer ...)

    Pouvez-vous nous communiquer le message d'erreur que vous avez?

    2/Sous Exchange, j'ai toujours la trace de l'ancien nom du nouveau serveur (pour rappel, c'était le nom du nouveau serveur lorsque l'installation a planté la première fois)

    Utiliser ADSI pour supprimer sa trace.

    http://serverfault.com/questions/179600/how-do-i-remove-an-orphaned-exchange-2010-server-from-the-organization


    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.   

    Microsoft Student Partner 2010 / 2011
    Microsoft Certified Professional
    Microsoft Certified Systems Administrator: Security
    Microsoft Certified Systems Engineer: Security
    Microsoft Certified Technology Specialist: Windows Server 2008 Active Directory, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Network Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Applications Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows 7, Configuring
    Microsoft Certified Technology Specialist: Designing and Providing Volume Licensing Solutions to Large Organizations
    Microsoft Certified IT Professional: Enterprise Administrator
    Microsoft Certified IT Professional: Server Administrator
    Microsoft Certified Trainer

    Lien vers mon site Web: http://www.ahmedmalek.com/web/fr/home.asp

    Pour suivre mon activité: http://www.facebook.com/TunisianIt

    lundi 21 mai 2012 11:40
  • Bonjour Julien,

    Je vous recommande d’utiliser les solutions proposées dans les articles suivants:

    Moving FederatedEmail/SystemMailbox from One Store to Another - Exchange 2010

    Recreate and enable missing arbitration user accounts and mailboxes in Exchange Server 2010

    Exchange 2010 - Error on FederatedEmail box move

    Federatedemail est une boite aux lettres arbitrage. Les boites aux lettres arbitrage sont utilisées pour la gestion des flux d’approbation.

    Concernant votre 2eme souci je vous recommande l’article proposé par Mr. X.

    Cordialement,

    Florin


    Florin CIUCA, MSFT  Votez! Appel à la contribution
    Nous vous prions de considérer que dans le cadre de ce forum on n’offre pas de support technique et aucune garantie de la part de Microsoft ne peut être offerte.

    lundi 21 mai 2012 12:13
  • Je vais tenter les 2 solutions proposées (Florin + M.X) demain chez mon client et vous tient informé.

    Encore merci pour votre réactivité!

    Concernant mon problème lié à IIS, j'ai un peu plus d'informations à vous communiquer :

    J'ai bien l'accueil d'owa sous ma session IE. Cependant, lorsque je renseigne mon login (nom de domaine\user comme défini dans l'authentification form d'owa dans la console mmc) + mot de passe, j'ai une réponse comme quoi il y a une authentification erroné (erreur login/mdp).

    De plus, dans IIS sous le répertoire "exchangeweb" + "exchange" j'ai une erreur dans la récupération des droits d'authentification (erreur ligne27 fichier webconfig).

    J'ai tenté une réinitialisation des répertoires virtuels ... sans succès.

    j'ai tenté de désactiver/réactiver owa ; sans succès non plus.

    De ces faits, lors de ma nouvelle installation sur le nouveau serveur, j'ai volontairement installé un exchange SP1. Suite au rapatriement des bal + carnet d'adresse + etc ... de l'ancien serveur, je vais tenter, par la suite, de migrer vers le SP2 ce qui, d'après certains forums, résoudrait ma problématique OWA + IIS.

    J'espère avoir des résultats positifs : je ne manquerai pas de vous les communiquer!


    juju

    mardi 22 mai 2012 09:39
  • Intervention reportée mercredi prochain...

    D'ici là, je suis ouvert au retour d'expérience de chacun..

    Merci

    julien


    juju

    vendredi 25 mai 2012 09:37