locked
Comment réparer Windows Média Player 12? RRS feed

  • Question


  • Bonjour,
    Pour une raison ou une autre, le fichier WMP12 dans Program Files (Windows 7) a disparu ainsi que certaines entrées de registre qui auraient permis de le désinstaller.  Lorsque je cherche a réinstaller WMP12 avec Update, la reponse est que je n'ai pas besoin d'update.  Il semble qu'un certains nombres de parametres sont restés qui empeche une réinstallation de WMP12, mais comme je ne peux plus le désinstaller, je ne sais comment faire.  J'ai bien nettoyé le registre, mais clairement pas assez.  Y aurait il une application pour désinstaller completemnt WMP12 ou quelle pourrait etre la solution?

    Merci.
    jeudi 18 février 2010 14:02

Réponses

  • Bonjour Phalsbourg,

    Pour activer Windows Média Player, il te faut aller dans Panneau de configuration -> Programmes et fonctionnalités -> Activer ou désactiver des fonctionnalités Windows (volet de gauche) -> déployer Fonctionnalités multimédia et cocher les sous rubriques.

    Pour réparer Windows Média Player, tu peux utiliser WinFix Utility de Ramesh Kumar (MVP) ou Fix WMP Utility

    @+

    Mon Blog Windows 7 - Windows Vista http://www.chantal11.com/
    • Marqué comme réponse chantal11MVP jeudi 18 février 2010 17:23
    jeudi 18 février 2010 14:48
  • Surprise et miracle.

    Lorsque j'active WMP12, le fichier apparait dans Program files.  Et puis il a disparu sous mes yeux.  J'ai ré-activé WMP12 et je me suis précipité dans le fichier lorsqu'il est apparu j'ai fait setup qui n'a rien donné et j'ai lancé le WMP.exec tout s'est remis en place.  J'ai cliqué avec quelques trepidation sur le message d'erreur, mais tout est reste en place et maintenant cela semble marcher.  Je n'y comprends absolument rien!
    • Marqué comme réponse chantal11MVP jeudi 18 février 2010 17:21
    jeudi 18 février 2010 15:22
  • Bonsoir,

    J'ose a peine le dire. 

    Ayant augmenté la taille de ma partition systeme afin de pouvoir effectuer la mise a niveau, tout semble s'etre remis en place tout seul et marcher.  WMP12 était installé mais ne fonctionnait pas.  Un petit coup de Fix WMP et c'était réglé.  SFC /Scannow fonctionne et ne détecte rien d'anormal.  Je vais maintenant sauvegarder l'ensemble au cas ou.

    Feignons d'être les maitres de ces mystères que nous ne comprenons pas.

    NB: Je précise que ma partition système était trop large de 8 Go et que je l'ai augmenté de 10 Go.  Allez savoir.
    • Marqué comme réponse chantal11MVP samedi 20 février 2010 17:39
    samedi 20 février 2010 17:20

Toutes les réponses

  • Bonjour Phalsbourg,

    Pour activer Windows Média Player, il te faut aller dans Panneau de configuration -> Programmes et fonctionnalités -> Activer ou désactiver des fonctionnalités Windows (volet de gauche) -> déployer Fonctionnalités multimédia et cocher les sous rubriques.

    Pour réparer Windows Média Player, tu peux utiliser WinFix Utility de Ramesh Kumar (MVP) ou Fix WMP Utility

    @+

    Mon Blog Windows 7 - Windows Vista http://www.chantal11.com/
    • Marqué comme réponse chantal11MVP jeudi 18 février 2010 17:23
    jeudi 18 février 2010 14:48
  • Bonjour,

    C'est en cherchant a activer WMP comme vous l'indiquez que je me suis apercu du probleme.  Apres avoir beaucoup cherché, il semble simplement que je n'ai plus WMP12 sur mon ordinateur (pas de fichier dans Progrem files etc.) mais qu'il reste des debris.  J'ai essaye de charger WMP10, WMP11 et cela ne fonctionne pas.  J'ai essaye WMP12, mais il semble que cela soit un update pour W7 N et le message qu'il renvoie est que je n'ai pas besoin d'update.  J'ignore ou je pourrais trouver tout simplement un WMP 12 a downloader a l'ancienne.  Ceci dit, je vait essayer les logiciels que vous indiquez  pour voir si une reparation est possible -j'en doute.

    Merci.
    jeudi 18 février 2010 15:03
  • Surprise et miracle.

    Lorsque j'active WMP12, le fichier apparait dans Program files.  Et puis il a disparu sous mes yeux.  J'ai ré-activé WMP12 et je me suis précipité dans le fichier lorsqu'il est apparu j'ai fait setup qui n'a rien donné et j'ai lancé le WMP.exec tout s'est remis en place.  J'ai cliqué avec quelques trepidation sur le message d'erreur, mais tout est reste en place et maintenant cela semble marcher.  Je n'y comprends absolument rien!
    • Marqué comme réponse chantal11MVP jeudi 18 février 2010 17:21
    jeudi 18 février 2010 15:22
  • Bonjour,

    Si la réparation par les 2 fix indiqués ne fonctionne pas, il faudrait alors peut-être envisager une ré-installation de Windows 7 par une mise à niveau, c'est-à-dire sans perte de données, ni de logiciels.
    http://www.chantal11.com/2009/04/installation-seven-mise-a-niveau-sans-perte-donnees-et-logiciels-reparer-windows-7/

    En effet, WMP fait partie intégrante de Windows 7, et cette fonctionnalité, à ma connaissance, ne peut être ré-installée à part.

    @+
    Mon Blog Windows 7 - Windows Vista http://www.chantal11.com/
    jeudi 18 février 2010 15:30
  • Chantal,

    1. Comme je l'ai dit plus haut, j'ai réussi par complet hasard a fixer le probleme (j'ai juste vu le fichier apparaitre et disparaitre lors de l'activation);

    2. Mais je vous remercie pour votre tutoriel car j'ignorais que l'on pouvait remettre a niveau W7 sans pertes de données et de logiciels et cela est très important (en fait j'avais hésité a le faire car j'ignorais l'option mise a niveau).  Super.

    Merci encore.
    jeudi 18 février 2010 15:48
  • Bonjour,

    En effet,  je n'avais pas vu la 2ème réponse.

    Si WMP est de nouveau fonctionnel, c'est l'essentiel !
    A l'arraché ..... mais il est là !

    Bonne continuation.

    @+
    Mon Blog Windows 7 - Windows Vista http://www.chantal11.com/
    jeudi 18 février 2010 17:21
  • Oui mais j'ai maintenant un probleme avec l'activation des fonctionnalités Windows qui parait corrompue (Tres lent et tres incomplet).  Je vais rebooter; sinon votre solution de remettre a niveau W7 va me servir.
    jeudi 18 février 2010 17:50
  • Bonjour,

    En effet, ton Windows 7 me semble bien mal en point !
    Une ré-installation pourrait en effet solutionner tes problèmes.

    Tu peux toujours tenter aussi un sfc /scannow pour réparer les fichiers système :

    Démarrer --> Tous les programmes --> Accessoires --> Clic-droit sur Invite de commandes --> Exécuter en tant qu'administrateur --> tu tapes
    sfc_/scannow
    _ étant un espace
    Tu laisses faire l'analyse.
    En fin d'analyse, un message t'indiquera si des fichiers corrompus ont été réparés.

    C'est bien la version finale (build 7600) qui est installée ? ce n'est pas la RC (build 7100) qui est en fin de validité ?
    Tu possèdes le DVD d'installation de Windows 7, estampillé Microsoft, ou Windows 7 a été pré-installé sur le PC (PC de marque) ?
    Dans le dernier cas, la mise à niveau ne sera peut-être pas possible.

    @+
    Mon Blog Windows 7 - Windows Vista http://www.chantal11.com/
    vendredi 19 février 2010 10:20
  • Merci de me répondre.

    1. SFC /Scannow ne donne rien.  Il semble ne pas fonctionner.  Tout va très vite et la fenêtre disparait aussitôt;

    2. J'ai downloadé une version sous forme exec. et non pas un fichier ISO, acheté en Juillet et mis a jour le 22/10.  Le build est le 7233 je crois.  IL s'agit de W7 Familaile Premium 32 bits.

    Mon probleme est donc, afin d'effectuer la mise a niveau suivi votre tutoriel, de le transformer, je présume en DVD bootable.  En effet lorsque je démarre par le setup.exe, l'image de démarrage apparait, mais lorsque je clique sur Démarrer maintenant, rien ne se passe.

    J'ajoute que WMP 12 ne fonctionne plus.  En effet, au reboot, la machine cherche a effectuer l'activation, puis apres le rallumage, decide, lorsque 100% de l'installation est effectuée, qu'il ya un probleme et annule toute l'installation. 
    J'ignore ce qui se passe, car je sais que WMP12 est installé puisque j'arrive a le faire fonctionner lorsque je "l'attrape" puis tout redisparait.  De plus le programme FixWin (WMP stop responding etc.) me renvoi un msg d'erreur disant que l'acces au registre lui a ete interdit.  Bref la totale.

    Voila, j'aimerais donc effectuer une mise a niveau mais je n'ai pas de sisk ISO.  Juste le Dossier (avec les fichiers exec, store 1 store2, etc) que j'ai downloadé du Windows Store.

    Le coup de main est vraiment bienvenu.
    Merci.
    vendredi 19 février 2010 13:48
  • Bonjour,

    La Build 7233 n'est pas une version officielle.
    C'est une Build récupérée certainement sur un site de Torrent.
    De plus, elle est complètement obsolète.
    La version finale étant la Build 7600. La licence pour cette version finale doit être achetée.

    En tapant Winver dans Rechercher, puis valider, une fenêtre indique la version utilisée.

    Donc je comprends qu'une version a été downloadée sur http://emea.microsoftstore.com/fr/Microsoft/Windows/Windows-7 , c'est bien ça ?
    Mais normalement, c'est bien une ISO qui est téléchargée, il me semble ?
    Il faudrait peut-être re-télécharger cette ISO en passant par la rubrique Compte dans Microsoft Store et choisir dans les options de téléchargement Téléchargement 32 bits ISO.

    De toutes les façons, il ne sera pas possible de passer de la Build 7233 à la version finale par une mise à niveau (dans la mesure où c'est bien la version 7233), il faut envisager une nouvelle installation.

    @+
    Mon Blog Windows 7 - Windows Vista http://www.chantal11.com/
    vendredi 19 février 2010 14:43
  • Je suis puzzled.  J'ai téléchargé officiellement du site emea. microsoftststore.com etc. avec facture et tout et tout.  Le choix était entre un disque ISO et un dossier.  J'ai pris le dossier car c'était plus facile pour moi et plus rapide.  Bon, il va falloir que je retourne dans mes petites fiches d'achat et voir ce que je peux faire.

    A bientôt peut être?
    vendredi 19 février 2010 14:48
  • Bonjour,

    En cas de problème, on peut toujours contacter le service après-vente par mail à cette adresse :
    MSStore.France@msdirectservices.com

    En expliquant la situation, je pense qu'une solution sera indiquée.

    @+
    Mon Blog Windows 7 - Windows Vista http://www.chantal11.com/
    vendredi 19 février 2010 14:54
  • Bonjour,

    J'essaye de decharger un disque ISO.  Il semble que le message du Microsoft store me le permets encore, mais je ne le saurais que lorsque ce sera fini.  Sinon, je vous remercie pour cet excellent conseil.  CE qui m'agace avec ce systeme, c'est que je ne le comprends pas et que donc je suis obliger de tatonner, d'experimenter et de chamaniser a chauque fois qu'un truc imprevu se presente.  Je vous riens au courant.  Merci.
    vendredi 19 février 2010 14:56
  • Bonjour,

    Bonne nouvelle, il semble que je puisse télécharger W7 autant de fois que je veux et sous la forme que je veux du Microsoft Store.  J'ai donc téléchargé une image ISO que j'ai gravé sur un DVD (si j'ai bien compris le fonctionnement de Imgburn).  Pas encore essayé la mise a niveau.

    Aucun des outils pour WMP12 ne fonctionne.  Lorsque j'arrive a "coincer" WMP12 et que j'utilise FixWin - WMP.  Je reçois un msg d'erreur "Accès au registre demandé non autorisé" avec des détails sur l'assembly que je ne comprends pas.  Dans cette configuration sfc ne fonctionne pas.

    Lorsque je reboote, l'activation de WMP12 prends place, mais tout a la fin, a 100%, le message est que ce n'est pas possible et l'activation est "rolled back".  Sans WMP12 sfc /scannow fonctionne mais ne détecte rien.

    Je suis un peu frustré du laconisme des differents messages.  Je ne connais pas assez pour savoir quel acces au registre est necessaire et pour quelle raison il n'est pas autorisé au systeme.  Lorsque je regarde dans le registre, je vois bien qu'il y a un certain nombres de clefs, mais je ne sait pas si leurs valeurs sont correctes.  Il semble que si je veuille regler ce pb frustrant je vais devoir mettre le disque W7.

    Dans toutes mes recherches, j'ai aussi remarqué que le pare-feu Zone Alarm semblait empêcher les restauration que ce soit de Windows ou d'Acronis.  Une fois que je l'ai supprimé, non sans mal, j'ai pu les effectuer.  J'ai l'impression que certains de ces logiciels sont plus une peine qu'un bénéfice.

    Merci.
    samedi 20 février 2010 09:09
  • Bonjour Phalsbourg,

    Je ne connais pas bien Zone Alarm, mais il posait déjà problème sous Vista, donc je présume que la situation est la même sous Windows 7.

    C'est en effet une bonne nouvelle que tu ais pu récupérer une image ISO de ton Windows 7. Tu as donc maintenant le DVD d'installation de Windows 7.

    Dans la mesure ou tu dis être sous la version 7233 (à confirmer), comme je l'expliquais plus haut, une mise à niveau ne sera pas possible. Il faudra ré-installer par une nouvelle installation, ce qui ne sera pas du luxe au vu des différents problèmes que tu rencontres.
    Ne pas oublier de sauvegarder tes données personnelles et bien entendu, il faudra ré-installer tous tes logiciels.

    @+

    Mon Blog Windows 7 - Windows Vista http://www.chantal11.com/
    samedi 20 février 2010 09:29
  • Bonjour,

    D'une manière générale, je fais une sauvegarde de système avec Windows une fois par semaine, une sauvegarde de système avec Acronis une fois par semaine, une sauvegarde de l'ensemble des partitions avec Acronis une fois par semaine et une sauvegarde de mes données une fois par jour.  Donc en principe je devrais être paré.  Il semble que ZA m'empêchait les restauration mais l'ayant supprimé et ayant restauré ma partition système hier sans probleme, je pense que je peux me lancer dans du dangereux.  En plus j'ai le système sur une partition C et toutes mes données sur une autre.  Un peu conservateur, mais parfois utile.

    Toutefois il est frustrant de ne pas comprendre ce qui se passe et pourquoi.

    Merci.
    samedi 20 février 2010 09:39
  • Bonjour,

    Oui bien sûr, c'est toujours frustrant !
    Ton système semble être corrompu, mais cette situation me semble normale si tu es toujours sous la version 7233 (version obsolète), ce que tu n'as toujours pas confirmé.
    Tape winver dans Rechercher pour connaître la version installée.

    @+
    Mon Blog Windows 7 - Windows Vista http://www.chantal11.com/
    samedi 20 février 2010 10:02
  • Version 6.1 (numéro 7600).

    Bien vu.
    samedi 20 février 2010 10:19
  • Bonjour,

    Donc tu as bien la version finale et c'est une bonne nouvelle, puisque tu vas pouvoir appliquer la procédure de la ré-installation sans perte de logiciels ni de données, c'est-à-dire par une mise à niveau.

    Cela ne va te prendre que peu de temps (tout dépendra du nombre de logiciels et de données à transférer) et j'espère solutionner ce problème de WMP "furtif".


    @+
    Mon Blog Windows 7 - Windows Vista http://www.chantal11.com/
    samedi 20 février 2010 12:16
  • Bonsoir,

    J'ose a peine le dire. 

    Ayant augmenté la taille de ma partition systeme afin de pouvoir effectuer la mise a niveau, tout semble s'etre remis en place tout seul et marcher.  WMP12 était installé mais ne fonctionnait pas.  Un petit coup de Fix WMP et c'était réglé.  SFC /Scannow fonctionne et ne détecte rien d'anormal.  Je vais maintenant sauvegarder l'ensemble au cas ou.

    Feignons d'être les maitres de ces mystères que nous ne comprenons pas.

    NB: Je précise que ma partition système était trop large de 8 Go et que je l'ai augmenté de 10 Go.  Allez savoir.
    • Marqué comme réponse chantal11MVP samedi 20 février 2010 17:39
    samedi 20 février 2010 17:20
  • Bonjour,

    Bonne nouvelle, en effet !

    C'est sûr, si Windows 7 se sentait un peu à l'étroit dans sa partition !

    Personnellement, n'ayant pas de problème de place sur mes disques durs, j'octroie toujours une partition de 60 Go minimum pour une installation de Vista ou Windows 7.

    Le DVD de Windows 7 gravé pourra toujours servir de toutes les façons si Windows avait un problème de démarrage.


    Bonne continuation,

    @+
    Mon Blog Windows 7 - Windows Vista http://www.chantal11.com/
    samedi 20 février 2010 17:47
  • Merci de votre patience.  Bonsoir.

    NB: A l'étroit avec 8Go de marge?  Je le saurais pour quand je serais vieux.
    samedi 20 février 2010 17:49