none
Microsoft exchange 2010 RRS feed

  • Question

  • Bonjour a tous ! Je rencontre un problème avec mon exchange serveur 2010. Lors d'envoie de mail avec pièces jointe, j'ai un message d'erreur me disant que nous dépassons la taille maximale de message autorisée (4Mo)

    J'ai regardé dans l'ensemble des paramètres de transport de l'organisation exchange, nous avons tout à 10 Mo, d'ailleurs en message interne nous n'avons aucun problème, nous rencontrons ce problème que lors de message vers l'extérieur.

    Je n'ai pas d'intermediaire, mon connecteur d'envoie renvoie sur mail.microsoft.messaging.com (Je me demande si cela ne peut pas provenir de la mais bon...)

    Avez vous deja rencontré ce type de problème, merci de votre retour !

    vendredi 11 septembre 2015 14:48

Toutes les réponses

  • Bonjour,

    Est ce que c'est ton serveur exchange qui genere le NDR? Verifier dans le contenu du NDR pour savoir c'est qui rejette le message.

    I faut savoir qu'il y a plusieurs niveau de limites :

    • Au niveau organisation
    • Au niveau connecteur
    • Au niveau lien intersite
    • Au niveau user

    Je propose de lancer les commandes suivantes pour tester :

    get-mailbox "userdeTest" | select MaxSendSize
    get-sendconnector | select identity, MaxMessageSize
    Get-AdSiteLink | select identity, MaxMessageSize
    Get-transportconfig | select MaxSendSize

    ref : https://technet.microsoft.com/fr-fr/library/bb124345(v=exchg.141).aspx

    • Proposé comme réponse Amine.G dimanche 13 septembre 2015 09:27
    dimanche 13 septembre 2015 09:27
  • Alors je viens d'effectuer les différentes commandes 

    pour le  user je suis a 20 Mo

    pour le connecteur je suis a 10 Mo

    pour le lien intersite je suis illimité

    pour le transportconfig je suis a 15 Mo

    Je n'arrive pas a voir ou cela coince, comme je le disais plus haut, en interne tout roule, c'est une fois que je sors que j'ai le problème. 

    Merci de ton retour 

    dimanche 13 septembre 2015 18:45
  • Est ce possible de poster le NDR ici?

    Est ce que le connecteur utilise un smarthost ou routage par MX?

    dimanche 13 septembre 2015 19:42
  • Voila le NDR

    Impossible de remettre ce message à quiconque, car il est trop volumineux. La limite est de 4 Mo. La taille de ce message est de 5 Mo.

    xxx@gmail.com 
    Ce message dépasse la taille maximale de message autorisée. Réduisez la taille du message et réessayez de l'envoyer.



    Informations de diagnostic pour les administrateurs :

    Serveur de génération : Serveurexchange.domaine.local

    xxx@gmail.com
    #550 5.3.4 SMTPSEND.OverAdvertisedSize; message size exceeds fixed maximum size ##

    Pour des raisons de sécurités, j'ai masqué le nom du serveur mais voila ce que nous avons lors de l'envoie d'un mail.

    je passe par un mx, mes mails sont routés vers mail.microsoft.messaging.com

    dimanche 13 septembre 2015 20:23
  • Lances la commande suivante et partage le résultat :

    get-transportconfig| select identity, ExternalDsnMaxMessageAttachSize


    • Modifié Amine.G dimanche 13 septembre 2015 20:48
    dimanche 13 septembre 2015 20:47
  • Alors j'ai ExternalDsnMaxMessageAttachSize  10Mo

    dimanche 13 septembre 2015 21:12
  • L'exchange vient d'une migration d'un 2003 qui provient d'un 5.5. N'y aurait il pas dans la base de registre un endroit qui prend le pas sur les règles de transport !

    J'ai aussi regardé si ce n'etait pas une GPO ou autre mais je dois avouer que la je coince. L'exchange fonctionne normalement, nous avions toujours eu cette limite pas génante, mais depuis le changement de signature par la communication, nous voyons les effets de cette limitation plus souvent. Maintenant ou cela coince, je ne sais pas...

    dimanche 13 septembre 2015 21:16
  • je dirais que le problème ne vient pas de Exchange dans ce cas plutot du smart host. pour le confirmer tu peut faire le test suivant:

    1. installer un client SMTP de test (moi j'aime celui la http://download.cnet.com/SMTP-Diag-Tool/3000-2086_4-75701770.html)
    2. Envoyer un message de test avec les meme conditions comme si c'est exchange qui envoi : memes paramètres authentification du connecteur, même taille de la pience jointe, même smarthost

    dimanche 13 septembre 2015 21:30
  • Connecting to mail server.
    Connected.
    220 serveurexchange.domaine.local Microsoft ESMTP MAIL Service ready at Sun, 13 Sep 2015 22:07:38 -0400
    EHLO OD-INFO-20
    250-serveurexchange.domaine.local Hello [192.168.x.x]
    250-SIZE
    250-PIPELINING
    250-DSN
    250-ENHANCEDSTATUSCODES
    250-STARTTLS
    250-X-ANONYMOUSTLS
    250-AUTH NTLM
    250-X-EXPS GSSAPI NTLM
    250-8BITMIME
    250-BINARYMIME
    250-CHUNKING
    250-XEXCH50
    250-XRDST
    250 XSHADOW
    AUTH NTLM TlRMTVNTUAABAAAAB6IIAAAAAAAAAAAACgAKACgAAAAAAAAAAAAAD09ELUlORk8tMjA=
    334 TlRMTVNTUAACAAAAEAAQADgAAAAFgokC77ngxwipfD8AAAAAAAAAALIAsgBIAAAABgGxHQAAAA9FAEEAVQBYAEQATwBNADEAAgAQAEUAQQBVAFgARABPAE0AMQABABQARQBBAFUAWABTAEUAUgBWADMAMAAEABwAZQBhAHUAeABkAG8AbQAxAC4AbABvAGMAYQBsAAMAMgBlAGEAdQB4AHMAZQByAHYAMwAwAC4AZQBhAHUAeABkAG8AbQAxAC4AbABvAGMAYQBsAAUAHABlAGEAdQB4AGQAbwBtADEALgBsAG8AYwBhAGwABwAIADsE5CGS7tABAAAAAA==
    TlRMTVNTUAADAAAAGAAYAGwAAAAYABgAhAAAAAAAAAAAAAAAEAAQAEgAAAAUABQAWAAAAAAAAAAAAAAABYKIAAAAAAAAAAAPagBtAGIAbwB1AGwAaQBuAE8ARAAtAEkATgBGAE8ALQAyADAApy/1STo2x7oAAAAAAAAAAAAAAAAAAAAACCJ7UrViu0bc3zmOVKGWsrPU2gcfHtkj
    235 2.7.0 Authentication successful
    RSET
    250 2.0.0 Resetting
    MAIL FROM: <senderA@mondomaine.fr>
    250 2.1.0 Sender OK
    RCPT TO: <senderB@gmail.com>
    250 2.1.5 Recipient OK
    DATA
    354 Please start mail input.
    .
    250 Mail queued for delivery.
    Forcing disconnection from SMTP server.
    QUIT
    221 Closing connection. Good bye.
    Disconnected.

    Message Sent Successfully

    Voila ce que j'ai comme retour de Log, parcontre je recois toujours le NDR me disant que le fichier est trop volumineux. J'ai utilisé les meme conditions comme tu me l'as demandé !

    lundi 14 septembre 2015 02:15
  • Bonjour,

    Êtes-vous à jour au niveau Service Pack et Cumulative Update sur votre serveur Exchange ?


    Cordialement,

    Sylvain (MCP, MCTS Windows Server 2008 R2 Server Virtualization, MCTS Exchange 2010)

    Blog : http://sylvaincoudeville.fr

    lundi 14 septembre 2015 07:54
  • Bonjour, non malheureusement, je pense faire le necessaire cette semaine !

    Pensez vous que je puisse trouver une lumière avec les maj Cumulative et Service Pack ?

    lundi 14 septembre 2015 11:37
  • Après, vous pouvez toujours faire un test en utilisant le relais par les enregistrements MX plutôt que le Smarthost mail.microsoft.messaging.com sur le connecteur d'envoi.

    Si cela fonctionne, c'est que le relai SMTP n'autorise pas plus que 4 Mo (mais cela serait étonnant car votre NDR parle de votre serveur Exchange, pas du relais).

    Dans tous les cas, les Service Pack et les Cumulative Update corrigent des problèmes, donc oui, cela peut solutionner le votre (même s'il s'agit d'un problème survenu sans raison : les updates rejouent des scripts d'installation et permettent donc de remettre de l'ordre dans les configurations).


    Cordialement,

    Sylvain (MCP, MCTS Windows Server 2008 R2 Server Virtualization, MCTS Exchange 2010)

    Blog : http://sylvaincoudeville.fr

    lundi 14 septembre 2015 12:24
  • J'ai fait déjà le test en passant directement par les enregistrements MX, mais j'ai le meme résultat.

    Je vais programmer pour cette semaine des maj sur le serveur et je reviendrai vers vous pour vous dire ce qu'il en est. 

    Merci en tout cas de votre retour !

    lundi 14 septembre 2015 12:33
  • Bonjour masskillah972,

    Est-ce que le problème existe encore?

    Cordialement,

    Boyan

    lundi 5 octobre 2015 13:13
  • Bonjour, oui malheureusement ! Pas encore finalisé les MaJ mais pour ce que j'ai deja fait, aucune améliorations !
    mercredi 7 octobre 2015 02:59