none
Group Policy Management Console - Création de filtres WMI impossibles

    Question

  • Bonjour,Je souhaite utiliser des filtres wmi sur mes GPO, mais lorsque je clique sur le conteneur "Filtres WMI", un message "Erreur d'initialisation" s'affiche. Je ne peux pas créer de filtre (les fonctions du menu contextuel de ce conteneur sont grisées).

    J'ai pas mal investigué est finalement je pense que le problème vient du fait que dans ma console utilisateurs AD, je n'ai pas de sous-conteneur system\wmipolicy

    J'ai recherché comment créer ce conteneur, mais sans résultat.

    Pour info: c'est pareil sur nos 3 contrôleurs de domaine (2012R2).

    Merci de m'aider si c'est possible :)

    Eric

    lundi 9 avril 2018 10:29

Réponses

  • Merci beaucoup, j'ai pu avancer grâce à cet article, et finalement créer les conteneurs manquant en m'appuyant sur cet autre article:

    http://www.robinhobo.com/how-to-create-container-objects-in-active-directory-not-ous/

    J'ai pu créer un filtre wmi, il ne me reste qu'à affiner tout ça.

    Merci à tous pour votre aide et votre temps.

    Bonne journée :)

    mardi 10 avril 2018 09:26

Toutes les réponses

  • Bonjour,

    Avant tout, pouvez vous vous assurez que les controleurs de domaine sont bien à jour ?

    Avez vous des traces dans le journal d'évènement?


    lundi 9 avril 2018 10:46
  • Bonjour,

    Oui les contrôleurs sont bien à jour, du côté des journaux j'ai cet évènement récurrent dans le journal wmi-Activity:

    Id = {AED949A6-CFE8-0000-09B1-DFAEE8CFD301} ; OrdinateurClient = serveur2012R2; Utilisateur = Mondomaine\user ; IDProcessusClient = 872 ; Composant = Unknown ; Opération = Start IWbemServices::ExecQuery - root\policy : select * from MSFT_SomFilter where domain="mondomaine.fr" ; CodeRésultat = 0x80041014 ; CausePossible = Unknown

    Cela correspond aux moments ou j'ouvre le conteneur Filtres WMI et le message d'erreur d'initialisation.

    J'ai demandé à mon collègue qui est là depuis plus longtemps que moi, Les filtres wmi n'ont jamais fonctionné sur ces DC en 2012R2. Et avant d'avoir des DC en 2012R2, c'etait des 2003 mais il ne se rappelle pas de comment cela avait été fait à l'époque. En espérant que cela puisse aider.

    Merci de votre aide.

    lundi 9 avril 2018 12:34
  • WBEM_E_INITIALIZATION_FAILURE
    2147749908 (0x80041014)

    Component, such as a provider, failed to initialize for internal reasons.

    Pouvez vous suivre cet article : https://matteu31.wordpress.com/2017/04/06/reparer-wmi/
    lundi 9 avril 2018 12:45
  • J'avais déjà testé ces commandes. La première me remonte qu'il n'y a pas de problème. Je suis passé à la dernière étape (winmgmt /resetrepository) mais cela ne change rien.

    J'ai l'impression que le problème vient du fait que dans ma console "utilisateurs et ordinateurs  Active Directory" lorsque je déroule le conteneur caché "system" a priori il manque un sous conteneur "wmipolicy".

    Je ne sais pas s'il a été supprimé par erreur il y a des années, ou bien si c'est un bug qu'il y avait eu lors de la migration de 2003 vers 2012, ou autre chose.

    Qu'en pensez-vous?

    lundi 9 avril 2018 14:43
  • Dcdiag sur le serveur ? des erreurs ?
    lundi 9 avril 2018 16:32
    Modérateur
  • Bonsoir,

    avez-vous bien commencé par utiliser l'entrée "WMI Filters" dans la console d'administration des stratégies GPMC.MSC ?

    Le conteneur "WMIPolicy" doit contenir au moins 4 conteneurs différents.

    Le sous conteneur "SOM" contiendra les différents filtres WMI créés.

    A bientôt,


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(83 MCPs). MCSA Office 365 https://mvp.microsoft.com/en-us/mvp/Thierry%20Deman-7660 http://base.faqexchange.info

    lundi 9 avril 2018 18:05
  • Bonjour,

    Oui j'ai voulu utiliser l'entrée WMI Filters dans la GPMC, mais lorsque je clique dessus, un message échec d'initialisation s'affiche. Ensuite je ne peux pas créer de filtre ou en importer car les entrées du menu contextuel ("nouveau" et "importer") sont grisées. Ensuite et c'est là le problème je pense: le conteneur WMIPolicy n'existe pas. J'ai cherché à le recréer mais sans succès...

    mardi 10 avril 2018 07:59
  • Essayez de vous appuyer sur cet article :

    https://social.technet.microsoft.com/Forums/ie/en-US/a7646291-b220-4aba-99d9-46a1e91ac932/wmi-filter-option-missing-from-gpmc?forum=winserverGP

    mardi 10 avril 2018 08:15
  • Merci beaucoup, j'ai pu avancer grâce à cet article, et finalement créer les conteneurs manquant en m'appuyant sur cet autre article:

    http://www.robinhobo.com/how-to-create-container-objects-in-active-directory-not-ous/

    J'ai pu créer un filtre wmi, il ne me reste qu'à affiner tout ça.

    Merci à tous pour votre aide et votre temps.

    Bonne journée :)

    mardi 10 avril 2018 09:26