none
Connexion impossible à la DB WSUS qui tourne sur un SBS 2008 RRS feed

  • Question

  • Bonjour,

    J'ai un serveur SBS 2008 sur lequel tourne WSUS, sans aucun problème (la DB MICROSFT##SSEE existe et est démarrée).
    L'accès local ne pose pas de problème.

    Le port 1433 est ouvert (IN and OUT) dans le firewall.

    Je souhaiterais installer WSUS sur un serveur 2012 et le connecter à la DB du SBS 2008.
    Durant le process d'installation de WSUS, je fournis l'adresse de la DB : "SBS2008-SRV\MICROSFT##SSEE" et je reçois un message d'erreur.

    "Une erreur liée au réseau ou spécifique à l'instance s'est produite lors de l'établissement d'une connexion à SQL Server. Le serveur est introuvable ou n'est pas accessible. Vérifiez que le nom de l'instance est correct et que SQL Server est configuré pour autoriser les connexions distantes. (provider: SQL Network Interfaces, error: 26 - Erreur lors de la localisation du serveur/de l'instance spécifiés)"

    Comment dois-je faire pour me connecter à cette DB ?

    Merci d'avance pour votre aide.


    samedi 6 avril 2013 12:29

Réponses

  • SQL Server 2008: Server Properties

    … and open the Server Properties.

    SQL Server 2008: Server Properties - Connections

    Navigate to Connections and ensure that Allow remote connections to this server is checked. Check if this solves the problem. If it does, here you go, continue with whatever you were doing and have a nice day.

    Protocols for MSSQLServer

    If you’re still running in issues let’s dig a bit deeper. The next good thing to check is the SQL Server Network Configuration. Open the SQL Server Configuration Manager, unfold the node SQL Server Network Configuration and select Protocols for MSSQLServer (or whatever the name of your SQL Server instance is).

    SQL Server 2008: Protocols for MSSQLServer

    Make sure that TCP/IP is enabled and try again. Even though I hope that this resolved your problems there might still be an issue with…

    The Firewall

    If there is still no communication happening between your computer and the remote SQL Server you most likely need to configure your firewall settings. A good first step is to figure out which port is being used by TCP/IP (and which you need to open in your firewall). You can do this by right clicking TCP/IP and selecting Properties.

    SQL Server 2008: TCP/IP Properties

    Click on the tab IP Addresses and voilà – Port 1433 it is :-) That was easy enough and all there is left to do is to allow inbound TCP/IP traffic on Port 1433 in your firewall. In Windows 7 this works something like this. Open the Control Panel and navigate to Windows Firewall.

    Microsoft Windows 7 Firewall settings

    Click on Advanced Settings on the left hand side and you should see the Windows Firewall with Advanced Security. Select the Inboud Rules on the left hand side and click on New Rule… on the right hand side.

    Microsoft Windows 7 Firewall with Advanced Security

    This opens the New Inbound Rule Wizard which you can use to allow inbound traffic on Port 1433 for TCP/IP (and which is exactly how you configured your SQL Server in the steps above). Just follow the steps outlined below and you should be good :-)

    New Inbound Rule Wizard - Protocols and Ports

    New Inbound Rule Wizard - Protocols and Ports

    New Inbound Rule Wizard - Action

    New Inbound Rule Wizard - Profile

    New Inbound Rule Wizard - Name

    http://blogs.msdn.com/b/walzenbach/archive/2010/04/14/how-to-enable-remote-connections-in-sql-server-2008.aspx

    Cordialement,

    Bricoleur.


    sans l'acquisition d'un immense superflu chaque condition se sent misérable. DIDEROT

    • Marqué comme réponse Florin Ciuca mercredi 10 avril 2013 09:29
    samedi 6 avril 2013 23:45