none
Probleme Exchange 2010 : erreur setup install/uninstall RRS feed

  • Question

  • Bonjour à tous ! 

    J'ai un énorme problème avec exchange 2010, je n'arrive plus à lancer le setup (désinstallation ou même via mon dvd d'installation).

    je m'explique :

    Nous disposons actuellement d'un exchange 2003 qui fonctionne sur un autre serveur, le but etait de mettre en place exchange 2010 et d'effectuer la migration.

    Pour ce faire je me suis fié à divers forum et à l'outil de déploiement microsoft. Arrivé à l'installation du rôle mailbox : néant, impossible de l'installer.

    J'ai essayé de résoudre le problème toujours en me basant sur ce forum et d'autres conseils, résultat, plus rien ne tourne (le 2003 va très bien, et tant mieux).

    Je suis maintenant dans l'incapacité de lancer le setup, aussi bien d'installation que de désinstallation. Voici l'erreur lorsque je lance l'exe :

    Description:
      Stopped working

    Problem signature:
      Problem Event Name:    CLR20r3
      Problem Signature 01:    exsetupui.exe
      Problem Signature 02:    14.0.639.21
      Problem Signature 03:    4abc4f2b
      Problem Signature 04:    Microsoft.Exchange.Management
      Problem Signature 05:    14.0.0.0
      Problem Signature 06:    4abc4de1
      Problem Signature 07:    765
      Problem Signature 08:    6c
      Problem Signature 09:    System.InvalidCastException
      OS Version:    6.1.7601.2.1.0.272.7
      Locale ID:    1033

    J'arpente les forum armé d'espoir mais je me retrouve complètement coincé ... Avant d'essayer une nouvelle installation se problème doit être résolus même si éventuellement le serveur ne serra pas utilisé pour exchange (à savoir : je n'ai pas d'autre serveur à disposition que celui la, sachant qu'il contient l'active directory principal et divers logiciels vitaux).

    Mon but est de pouvoir effacer toute trace de cette installation d'exchange 2010 afin de recommencer au point de départ et éventuellement demander de l'aide au moment voulu (je n'ai jamais manipulé d'exchange auparavant).

    D'avance merci pour votre temps et votre aide éventuelle.

    Bien à vous,

    Boris

    jeudi 14 mars 2013 13:11

Toutes les réponses

  • Il n'est pas recommandé d'installer Exchange sur un controlleur de domaine, la politique de sécurité propre au DC pouvant entrainer des effets de bords sur Exchange.

    Concernant votre serveur, est ce que certains rôles Exchange ont été installés? Avez vous installé powershell v3 via les mises à jour?


    Bruce Jourdain de Coutance - Consultant Exchange http://brucejdc.blog.free.fr - Un script pour facilement monter son lab chez soi : http://social.technet.microsoft.com/Forums/fr-FR/windows8fr/thread/f26dd7dd-96b2-4b6a-a085-bc83d3d64599 Votez pour si ce script va vous servir!

    jeudi 14 mars 2013 13:20
    Modérateur
  • Merci pour votre réponse.

    Il faudra que je trouve une autre solution alors pour le serveur, mais il me faut vraiment désinstaller l'Exchange avant que je puisse récupérer la partition de disque qui lui à été attribué et éventuellement ne plus avoir les changements effectué au seins de l'AD. Des rôles ont effectivement été installé (tout les rôles nécessaires à exchange 2010 excepté le mailbox).

    J'ai installé des mises à jours et des SP (1 voir 2 j'ai peut être fait une erreur avec ça mais il était possible apparemment que mes premiers problèmes auraient pu être résolu suites a ces manipulations). Mais le powershell à été installé à partir du DVD sans mise à jour je pense

    jeudi 14 mars 2013 13:46
  • Vous pouvez deja regarder le fichier de log de l'installer d'Exchange, je ne sais pas si il a pu être renseigné :

    <system drive>\ExchangeSetupLogs\ExchangeSetup.log

    Avez vous essayer via le panneau "Programs and Features" ? Sur le CD en "Run as administrator" ? en cmdline avec setup.com /uninstall /roles:H,C,U,T

    H -> HUB

    C -> CAS

    U -> Unified Messaging

    T -> Managment tool

    http://technet.microsoft.com/en-us/library/aa997281(v=exchg.141).aspx


    Bruce Jourdain de Coutance - Consultant Exchange http://brucejdc.blog.free.fr - Un script pour facilement monter son lab chez soi : http://social.technet.microsoft.com/Forums/fr-FR/windows8fr/thread/f26dd7dd-96b2-4b6a-a085-bc83d3d64599 Votez pour si ce script va vous servir!

    jeudi 14 mars 2013 14:05
    Modérateur
  • J'ai essayé en administrateur, via le panneau de configuration et en mode commande, toujours la même erreur et le fichier detup.log m'indique juste gentillement : [ERROR] Specified cast is not valid.

    Je ne sais plus executer quoique ce soit venant de Exchange, même si les services tournent apparement (mais pour rien)

    jeudi 14 mars 2013 15:22
  • Si il n'y avait pas d'autres rôles hors Exchange sur le serveur je vous dirais de le supprimer et réinstaller, mais je pense que ce n'est pas une option viable dans votre cas?


    Bruce Jourdain de Coutance - Consultant Exchange http://brucejdc.blog.free.fr - Un script pour facilement monter son lab chez soi : http://social.technet.microsoft.com/Forums/fr-FR/windows8fr/thread/f26dd7dd-96b2-4b6a-a085-bc83d3d64599 Votez pour si ce script va vous servir!

    jeudi 14 mars 2013 15:36
    Modérateur
  • Seuls les roses de base Exchange sont installé excepté celui de mailbox.

    Vous parlez du serveur en lui même ?

    C'est tout bonnement impossible :/

    Est-il possible que le SP2 soit responsable ?

    Ou cela pourrait il venir d'une version de NET framework trop ancienne installée ?

    Je sais plus trop quoi faire ... et formater le disque contenant exchange ne resoudra probablement pas le problème voir pire.

    • Modifié Mesath jeudi 14 mars 2013 15:44 ajout
    jeudi 14 mars 2013 15:40
  • le SP2 Exchange ou Server? Oui c'est possible dans les deux cas.

    Si vous avez installer le SP2 Exchange, vous devez télécharger et utiliser le SP2 Exchange pour faire l'installation du Mailbox (ou la déinstallation totale), vous ne pouvez pas installer le rôle CAS en SP2, Hub en SP1 et Mailbox en RTM sur le même serveur par exemple.

    Si c'est le SP2 Server, voici la marche à suivre pour le désinstaller, cependant cela présente des risques http://technet.microsoft.com/en-us/library/dd351467(v=ws.10).aspx#Uninstalling


    Bruce Jourdain de Coutance - Consultant Exchange http://brucejdc.blog.free.fr - Un script pour facilement monter son lab chez soi : http://social.technet.microsoft.com/Forums/fr-FR/windows8fr/thread/f26dd7dd-96b2-4b6a-a085-bc83d3d64599 Votez pour si ce script va vous servir!

    jeudi 14 mars 2013 15:48
    Modérateur
  • Je parle du SP2 exchange, il est possible qu'il ait été installé et je pense que ça coinciderait avec le moment ou  l'erreur que j'obtient est apparue. Mais ça fait beaucoup de doute mais c'est ma seule piste personnelle.

    Comment pourrais je tester pour faire une desinstallation totale ?

    Merci


    • Modifié Mesath jeudi 14 mars 2013 16:07
    jeudi 14 mars 2013 16:02
  • lancer le setup.exe a partir du SP2 d'Exchange, pas depuis le SP1 ou le RTM.

    Bruce Jourdain de Coutance - Consultant Exchange http://brucejdc.blog.free.fr - Un script pour facilement monter son lab chez soi : http://social.technet.microsoft.com/Forums/fr-FR/windows8fr/thread/f26dd7dd-96b2-4b6a-a085-bc83d3d64599 Votez pour si ce script va vous servir!

    jeudi 14 mars 2013 19:13
    Modérateur
  • Je viens de tester via le sp2 en mode commande via powershell et rien de bon, toujours une erreur et un stop working setup :(

    pour info voici l'erreur soulevée par le powershell aprés l'affichage de la fenêtre windows me signalant que le setup a arreté de fonctionner :

    Unhandled Exception: System.InvalidCastException: Specified cast is not valid.
       at Microsoft.Exchange.Management.Deployment.RolesUtility.GetConfiguringStatus(ConfigurationStatus& status)
       at Microsoft.Exchange.Management.Deployment.Role.get_IsPartiallyInstalled()
       at Microsoft.Exchange.Setup.Common.SetupContext.GetSetupContext(PropertyBag parsedArguments)
       at Microsoft.Exchange.Setup.Common.RootDataHandler.OnReadData()
       at Microsoft.Exchange.Management.SystemManager.WinForms.SingleTaskDataHandler.OnReadData(CommandInteractionHandler in
    teractionHandler, String pageName)
       at Microsoft.Exchange.Management.SystemManager.WinForms.DataHandler.Read(CommandInteractionHandler interactionHandler
    , String pageName)
       at Microsoft.Exchange.Setup.Common.LauncherBase.Run(String[] args)
       at Microsoft.Exchange.Setup.Common.LauncherBase.MainCore[T](String[] args)
       at Microsoft.Exchange.Setup.ExSetup.ExSetup.Main(String[] args)

    Exchange Server setup encountered an error.

    vendredi 15 mars 2013 08:06
  • Pouvez-vous refaire une préparation du schéma? Cela ne devrait pas avoir d'impact puisque vous êtes sensé l'avoir deja fait, mais si elle n'a pas fonctionné correctement cela expliquerait l'erreur de cast.

    setup.com /ps

    Vous n'avez pas powershell v3 installé sur le serveur (ou Windows Management Framework 3.0. )

    Bruce Jourdain de Coutance - Consultant Exchange http://brucejdc.blog.free.fr - Un script pour facilement monter son lab chez soi : http://social.technet.microsoft.com/Forums/fr-FR/windows8fr/thread/f26dd7dd-96b2-4b6a-a085-bc83d3d64599 Votez pour si ce script va vous servir!

    • Proposé comme réponse Florin Ciuca jeudi 21 mars 2013 07:13
    • Marqué comme réponse Florin Ciuca mercredi 3 avril 2013 07:00
    • Non marqué comme réponse Mesath vendredi 19 avril 2013 09:04
    lundi 18 mars 2013 08:34
    Modérateur
  • Cela ne fonctionne pas du tout :/ 
    En réalité, quelque soit le setup exchange que je lance, cela se termine par une erreur "invalid cast" comme expliqué précédemment. 

    J'ai installé un autre exchange 2010 sur un autre serveur, et je pense que celui la fonctionne parfaitement car je vais bientôt passer à la phase de migration des mailbox. 

    Cependant mon manager voit le premier exchange 2010 installé et le repertorie dans la console de management.

    Je n'ai plus eu le temps de me pencher sur le probleme que j'ai soulevé ici car j'ai mis la priorité sur d'autres tâches et notamment une nouvelle installation exchange. 

    Mon but est donc de pouvoir désinstaller l'exchange 2010 qui me pose problème, mais quoi que je tente je finis sur une erreur de setup ... 
    Je vais finir par effacer le disque qui contient l'installation mais j'ai peur que cela ne soit pas propre du tout et que la Management Console continue a voir les rôles qui ont été installés :/ 

    Je sais pas du tout comment me débarrasser de cette installation ratée :(...


    • Modifié Mesath vendredi 19 avril 2013 09:11
    vendredi 19 avril 2013 09:11
  • Bonjour,

    Pour supprimer manuellement un serveur Exchange, vous pouvez utiliser la console adsiedit.msc mais avec beaucoup de précautions. (Je vous conseille de faire une sauvegarde de votre AD avant toute manip)

    Le serveur Exchange est situé dans la partition Configuration : "CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=VotreOrganisation,"


    Note : Si ma réponse vous a été utile, ou apporté une résolution; merci de voter ou de la marquer comme réponse.

    lundi 22 avril 2013 09:43