none
Windows Server Backup code 38 usb drive RRS feed

  • Question

  • Bonjour à tous,

    Je rencontre une difficulté à comprendre pour quelle raison (et résoudre le problème) :

    Sur un serveur LENOVO Ts130 (SRV 2012 Foundation) avec pilote d'origine puis mis à jour, système à jour. 

    A la re connexion, suite à une déconnexion propre de disque dur externe usb après réalisation de la sauvegarde, celui-ci ne se connecte pas parce que : Windows ne peut pas charger le pilote de périphérique de ce matériel car une instance précédente du pilote de périphérique est encore en mémoire.

    La seule solution que j'ai pu trouver et qui fonctionne est de redémarrer ... une serveur ... c'est ennuyeux, je ne peux pas concevoir que ce soit la seule solution.

    Ps: j'ai pu expérimenter cela également sur des machines sous windows 7 (disque dur et clé usb) puis le problème à disparu ....

    Merci de toutes les pistes de solutions proposées, je paie une (ou plusieurs) bière à celui ou celle qui me trouve la solution ;o)

    John

    dimanche 11 mai 2014 10:59

Réponses

  • Bonjour John,

    J'ai eu ce même problème sur un serveur avec un Disque dur WD il y'a quelques mois, c'est vrai que c'est un mystère mystérieux, je vous donne ma solution de contournement, saches qu'il y'en a pas d'autres (aucune KB décrit ce problème, parce que c'est plutôt lié au hardware et non pas à l'OS).

    1. D'abord, il suffit de désactiver & réactiver ton périphérique depuis le gestionnaire de périphériques (devmgmt.msc), ça résoudra le problème immédiatement et surtout ça t'évitera de rebooter ton serveur, surtout s'il s'agit d'un srv de prod.

    2. se rapprocher du fabriquant de l'USB Drive ou checker sur son site de support si un correctif /patch est  proposé.

    Je m'étais rapproché de WD qui m'ont envoyé un patch par mail et que j'ai appliqué sur le serveur et je n'avais plus de problème.

    Microsoft propose la solution suivante (nécessitant un redémarrage de serveur #Méthode2) sinon tente de lancer l'assistant de dépannage:

    Code 38

    Windows ne peut pas charger le pilote de périphérique de ce matériel car une instance précédente du pilote de périphérique est encore en mémoire. (Code 38)
    Résolution recommandée
    Le pilote n'a pas pu être chargé car une instance antérieure est encore chargée. Redémarrez l'ordinateur. 

    Utilisez l'Assistant de dépannage

    Si vous n'avez pas encore exécuté l'Assistant de dépannage, faites-le maintenant.
    1. Dans la boîte de dialogue Propriétés du périphérique, cliquez sur l'onglet Général .
    2. Cliquez sur résolution des problèmes pour démarrer l' Assistant de dépannageL'Assistant vous pose quelques questions simples et fournit une solution à votre problème en fonction des réponses que vous fournissez.
    3. Suivez les étapes de résolution fournies par l'Assistant pour résoudre le problème.
    Redémarrez votre ordinateur.

    Cliquez sur Démarrer, sur Arrêter, puis sélectionnez redémarrer dans la boîte de dialogue Arrêt de Windows à redémarrer l'ordinateur.

    Tenez nous au courant.

    A+

    HK.

    PS : n'hésites pas à faire des recherches avec les mots clé "Model disque dur + Model Serveur + CODE 38", tu pourras tomber sur des articles proposant le correctif pour corriger ce bug. ce n'est pas un problème MS.


    Hicham KADIRI | Just Another IT Guy

    • Marqué comme réponse Florin Ciuca jeudi 5 juin 2014 13:45
    dimanche 11 mai 2014 12:46

Toutes les réponses

  • Bonjour John,

    J'ai eu ce même problème sur un serveur avec un Disque dur WD il y'a quelques mois, c'est vrai que c'est un mystère mystérieux, je vous donne ma solution de contournement, saches qu'il y'en a pas d'autres (aucune KB décrit ce problème, parce que c'est plutôt lié au hardware et non pas à l'OS).

    1. D'abord, il suffit de désactiver & réactiver ton périphérique depuis le gestionnaire de périphériques (devmgmt.msc), ça résoudra le problème immédiatement et surtout ça t'évitera de rebooter ton serveur, surtout s'il s'agit d'un srv de prod.

    2. se rapprocher du fabriquant de l'USB Drive ou checker sur son site de support si un correctif /patch est  proposé.

    Je m'étais rapproché de WD qui m'ont envoyé un patch par mail et que j'ai appliqué sur le serveur et je n'avais plus de problème.

    Microsoft propose la solution suivante (nécessitant un redémarrage de serveur #Méthode2) sinon tente de lancer l'assistant de dépannage:

    Code 38

    Windows ne peut pas charger le pilote de périphérique de ce matériel car une instance précédente du pilote de périphérique est encore en mémoire. (Code 38)
    Résolution recommandée
    Le pilote n'a pas pu être chargé car une instance antérieure est encore chargée. Redémarrez l'ordinateur. 

    Utilisez l'Assistant de dépannage

    Si vous n'avez pas encore exécuté l'Assistant de dépannage, faites-le maintenant.
    1. Dans la boîte de dialogue Propriétés du périphérique, cliquez sur l'onglet Général .
    2. Cliquez sur résolution des problèmes pour démarrer l' Assistant de dépannageL'Assistant vous pose quelques questions simples et fournit une solution à votre problème en fonction des réponses que vous fournissez.
    3. Suivez les étapes de résolution fournies par l'Assistant pour résoudre le problème.
    Redémarrez votre ordinateur.

    Cliquez sur Démarrer, sur Arrêter, puis sélectionnez redémarrer dans la boîte de dialogue Arrêt de Windows à redémarrer l'ordinateur.

    Tenez nous au courant.

    A+

    HK.

    PS : n'hésites pas à faire des recherches avec les mots clé "Model disque dur + Model Serveur + CODE 38", tu pourras tomber sur des articles proposant le correctif pour corriger ce bug. ce n'est pas un problème MS.


    Hicham KADIRI | Just Another IT Guy

    • Marqué comme réponse Florin Ciuca jeudi 5 juin 2014 13:45
    dimanche 11 mai 2014 12:46
  • Bonjour Icham,

    Avec du retard mais je te prie de bien vouloir m'en excuser, MERCI.

    solution 1 : aucun effet, déjà tenté maintes et maintes fois sans succès ;o( le code 38 empêche la détection et force un redémarrage.

    solution 2 : pas de réponse de WD ni même de Lenovo (sav MEDION ... oscour !!)

    Le problème n'est pas réglé, j'ai même pire ... 

    Pour circonvenir le problème, j'avais planifié un redémarrage du serveur en plein nuit ... mais, et bien que je n'ai rien changé au bios, si le dd est connecté, le serveur ne démarra pas ...(WD Mypassport USB3)

    Je ne réglerais jamais ce problème en laissant les disques durs, je vais mettre un nas à la place.

    Si toutefois j'ai des réponses de WD et Lenovo, je posterais ici la solution qui marche.

    vendredi 18 juillet 2014 12:00