none
Création de cluster de basculement RRS feed

  • Question

  • Bonjour,

    Actuellement je rencontre un problème lors de la création d'un cluster, que se soit via l'assistant ou via powershell, ce cluster qui devra être avec 3 nœuds.

    Aucun Warning ou même Error n'a été signalée lors de la validation de configuration, sauf que lors de la création du cluster des erreur s'affichent, voici ci dessous l'erreur création cluster en mode powershell et aussi celle via l’assistant :

    New-Cluster : Une erreur s'est produite lors de cette opération.
        Une erreur s'est produite lors de la création du cluster « Mon_Cluster ».
        Une erreur s'est produite lors de la création du cluster « Mon_Cluster ».
        La base de données de sécurité du serveur n'a pas de compte d'ordinateur pour la relation d'approbation avec cette
    station de travail
    Au caractère Ligne:1 : 1
    + New-Cluster -Name SiegeClusterHV -Node SiegeHV3, SiegeHV2 -StaticAddress 172.30. ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [New-Cluster], ClusterCmdletException
        + FullyQualifiedErrorId : New-Cluster,Microsoft.FailoverClusters.PowerShell.NewClusterCommand 

    jeudi 21 janvier 2016 11:00

Réponses

  • Bonjour tout le monde,

    le problème est résolu suite à l'application de la KB976424 sur le ou les contrôleurs de domaine.

    Merci pour toutes vos aides précieuses, et je reste à votre disposition pour toutes autres informations.

    Cordialement,

    ZAOUCHI Selim

    • Proposé comme réponse F.ABASSI jeudi 28 janvier 2016 14:36
    • Marqué comme réponse Emile Supiot jeudi 28 janvier 2016 15:21
    jeudi 28 janvier 2016 13:26

Toutes les réponses

  • Bonjour Selim,

    Une question toute bête (étant donné que le problème est "pour moi" lié principalement à un probleme de relation trust entre ton (es) serveur(s) HV) :

    As-tu essayé de sortir et réintégrer tes serveurs ds le domaine AD  et relancez ta cmd PS pour créer le Cluster HV ?

    De mémoire, il peut également y avoir un problème sur un attribut AD précis voir deux, à savoir :

    dNSHostName et ServicePrincipalName

    Affiche les fonctionnalités avancées au niveau de la console ADUC, double-clique sur l'objet "Compte Ordi" d'un des serveurs HV posant problème > Editeur d'attribut > et localise les deux attributs cités ci-dessus.

    dis moi les valeurs déja configurées sur ces deux attribut.

    A+
    HK.


    Hicham KADIRI | Just Another IT Guy
    eBook RDS 2012 R2 désormais disponible !

    jeudi 21 janvier 2016 13:28
  • Bonjour Hicham,

    effectivement, nous avons réintégré à plusieurs reprises nos trois serveurs dans le domaine, on a même réinstallé le système d'exploitation, on a aussi utilisé de nouveaux hostname, toujours même  souci que ce soit avec l'assistant ou avec la cmd PS, a noter aucune GPO n'est appliquée à ces derniers.

    voici les attributs demandés :

    dNSHostName : mon_serveur.mon_domaine.int

    ServicePrincipalName : plusieurs valeurs indiquées sur cette dernière dont MSServerClusterMgmtAPI

    à noter aussi que j'utilise le compte admin du domaine pour la création du cluster, ce compte admin fait partie aussi des groupes administrateurs locaux des trois noeuds

    Cordialement,

    ZAOUCHI Selim

    jeudi 21 janvier 2016 14:18
  • Bonjour Selim 

    + Hichem 

    Es ce que vous avez tenté de ré créer ce cluster avec toujours le même nom si oui, essayer avec un autre nom ?!

    Je vous propose de jeter un coup d'oeuil ça semble intéressant dans votre cas, puisque j'estime qu'il y un problème de permission quelque part sur votre AD 

    Prestage Cluster Computer Objects in Active Directory Domain Services

     



    vote if you think useful

    vendredi 22 janvier 2016 10:44
  • Bonjour Fethi,

    en effet nous avons tester avec d'autres hostname que ce soit pour les serveurs que se soit pour le nom choisi pour le cluster.

    d'autre part nous utilisons le compte administrateur de domaine, et aucune GPO n'est appliquée sur l'OU des trois serveurs destinés à la mise en place du failover.

    aucun parefeu fait barrière entre les serveurs et active directory, aussi aucun antivirus n'est installé sur ces derniers.

    Cordialement,

    ZAOUCHI Selim

    lundi 25 janvier 2016 10:04
  • Bonjour,

    il faudra peut être suivre la procédure utilisée pour la création d'un cluster utilisé par le DAG Exchange.

    => Créer l'objet "computer" pour le nom du futur cluster, le désactiver et donner les droits "complets" sur cet objet aux 2 nœuds/serveurs du cluster.

    => N'installer qu'un seul nœud au moment de la création, ajouter le 2ème nœud qu'ensuite.

    A+


    Thierry DEMAN. Exchange MVP. MCSE:Messaging 2013,MCSE:Server Infrastructure 2012(82 MCPs). MCSA Office 365 https://mvp.microsoft.com/en-us/mvp/Thierry%20Deman-7660 http://base.faqexchange.info

    lundi 25 janvier 2016 13:25
  • Bonjour Thierry,

    c'est fait et le problème persiste encore.

    nous avons donné le contrôle total pour les noeuds/serveurs du cluster, toujours les même erreurs.

    Cordialement,

    ZAOUCHI Selim

    lundi 25 janvier 2016 14:01
  • Bonjour Selim 

    Une suggestion: est ce que vous avez cloné ces machines ?!

    Entre autre je vous propose de réinitialiser le channel entre ces 3 nœuds et votre DC avant de lancer l'installation du cluster: 

    #Start remote powershell session
    Enter-PSSession -ComputerName worksation1
    #Reset the password
    Reset-ComputerMachinePassword -Credential domain/username -Server dc-server
    #Test trust relationship
    Test-ComputerSecureChannel
    Exit-PSSessionssue. 

    Cordialement.


    vote if you think useful


    • Modifié F.ABASSI mardi 26 janvier 2016 10:41
    mardi 26 janvier 2016 10:40
  • Bonjour tout le monde,

    le problème est résolu suite à l'application de la KB976424 sur le ou les contrôleurs de domaine.

    Merci pour toutes vos aides précieuses, et je reste à votre disposition pour toutes autres informations.

    Cordialement,

    ZAOUCHI Selim

    • Proposé comme réponse F.ABASSI jeudi 28 janvier 2016 14:36
    • Marqué comme réponse Emile Supiot jeudi 28 janvier 2016 15:21
    jeudi 28 janvier 2016 13:26