locked
Problème de Maitre Explorateur RRS feed

  • Question

  • Bonjour,

    Comme indiqué dans le titre il semble que j'ai un problème avec le Maitre Explorateur du domaine.

    Description du réseau :
    4 serveurs sur un domaine composé de 3 sous-réseaux
    - PDC : Controleur Principal du domaine sur réseau 192.168.2.X équipé de Windows Serveur 2003 R2
    - DC1 : Controleur de domaine sur réseau 192.168.7.X équipé de Windows Serveur 2003 R2
    - DC2 : Controleur de domaine sur réseau 192.168.3.X équipé de Windows Serveur 2003 R2
    - DC3 : Controleur de domaine sur réseau 192.168.3.X équipé de Windows Serveur 2012
    DC2 sera supprimé du réseau prochainement

    La clé HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters\IsDomainMaster est égale à True sur PDC, à False sur DC1, DC2 et DC3
    La clé HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters\MaintainServerList est égale à YES sur PDC et à Auto sur DC1, DC2 et DC3

    La commande browstat vw 1 renvoie bien "PDC" pour PDC et "BDC" pour les 3 DCs.
    Par contre 3 des 4 serveurs renvoient "MBR" ! (PDC, DC1 et DC2)

    La commande Browstat Status :
    - sur le réseau 192.168.2.X indique PDC comme Maitre explorateur
    - sur le réseau 192.168.3.X indique DC2 comme Maitre explorateur
    - sur le réseau 192.168.7.X indique DC1 comme Maitre explorateur

    La commande netdiag /fix passe bien toutes les étapes. Juste un "Warning" sur le "NetBT name test" : [WARNING] At least one of the <00> 'WorkStation Service', <03> 'Messenger Service', <20> 'WINS' names is missing.

    Si j'exécute les commandes NSLOOKUP AdresseIP_PDC, NSLOOKUP AdresseIP_DC1 et NSLOOKUP AdresseIP_DC2 :
    - sur le réseau de DC2, c'est DC2 qui répond à la résolution d'adresse
    - sur le réseau de DC1, c'est PDC qui répond à la résolution d'adresse
    - sur le réseau de PDC, c'est DC1 qui répond à la résolution d'adresse

    En executant wireshark je vois passer régulièrement des demandes d'élection du Maitre Explorateur lancées par PDC. Wireshark m'indique que PDC n'est pas MBR !

    Dans l'observateur d'événements système j'ai régulièrement le service MRxSmb qui renvoie une erreur 8003 : Le maître explorateur a reçu une annonce de serveur de l'ordinateur DC2 qui pense qu'il est le maître explorateur sur le domaine pour le transport NetBT_Tcpip_{XXXXXXXX-XXXX-XXX. Le maître explorateur s'arrête ou une élection est provoquée.

    Je dois avouer que je ne comprends pas bien. La clé IsDomainMaster des DCs étant sur FALSE je ne comprends pas pourquoi ils sont Maitre Explorateur :(

    Je précise que dans l'ensemble le réseau fonctionne bien.

    Je me demande simplement si cela ne serait pas la cause d'un autre problème : sur chacun des réseaux se trouve un serveur NAS CISCO ; or, parfois, l'accès par leur nom à ces serveurs ne fonctionne plus pendant quelques heures, alors que l'accès par l'adresse IP fonctionne, puis ça revient tout seul. (Petite précision : il est possible de rendre les serveurs NAS CISCO Maitre Explorateur, bien entendu ce n'est pas le cas pour ceux qui sont installés sur le domaine)

    Si quelqu'un a une idée pour résoudre ce problème de Maitre Explorateur je suis preneur ;)

    mercredi 3 juillet 2013 11:52

Réponses

  • Bonjour,

    Dans l'observateur d'événements système j'ai régulièrement le service MRxSmb qui renvoie une erreur 8003 : Le maître explorateur a reçu une annonce de serveur de l'ordinateur DC2 qui pense qu'il est le maître explorateur sur le domaine pour le transport NetBT_Tcpip_{XXXXXXXX-XXXX-XXX. Le maître explorateur s'arrête ou une élection est provoquée.

    Essayez ceci:

    Dans DC2 ---> Panneau de configuration ---> Outils d'administration ---> Services, recherchez "Explorateur d'ordinateurs" vérifiez que ce service ne soit pas sur "démarré" si oui, arrêtez ce service en double cliquant sur "Explorateur d'ordinateurs" modifiez le type de démarrage sur "Désactivé". "OK" pour appliquer la modification.

    Pour que la modification soit appliquée, redémarrez la machine.

    Vérifiez que tous vos ordinateurs se trouvent sur le même sous-réseau.

    Cordialement,

    Bricoleur.


    sans l'acquisition d'un immense superflu chaque condition se sent misérable. DIDEROT


    jeudi 4 juillet 2013 23:43

Toutes les réponses

  • Bonjour,

    Dans l'observateur d'événements système j'ai régulièrement le service MRxSmb qui renvoie une erreur 8003 : Le maître explorateur a reçu une annonce de serveur de l'ordinateur DC2 qui pense qu'il est le maître explorateur sur le domaine pour le transport NetBT_Tcpip_{XXXXXXXX-XXXX-XXX. Le maître explorateur s'arrête ou une élection est provoquée.

    Essayez ceci:

    Dans DC2 ---> Panneau de configuration ---> Outils d'administration ---> Services, recherchez "Explorateur d'ordinateurs" vérifiez que ce service ne soit pas sur "démarré" si oui, arrêtez ce service en double cliquant sur "Explorateur d'ordinateurs" modifiez le type de démarrage sur "Désactivé". "OK" pour appliquer la modification.

    Pour que la modification soit appliquée, redémarrez la machine.

    Vérifiez que tous vos ordinateurs se trouvent sur le même sous-réseau.

    Cordialement,

    Bricoleur.


    sans l'acquisition d'un immense superflu chaque condition se sent misérable. DIDEROT


    jeudi 4 juillet 2013 23:43
  • Bonjour,

    Merci beaucoup Bricoleur pour ta réponse ;)

    Désolé de ne pas être passé avant mais je n'ai pu m'en occuper qu'hier.

    Le problème venait bien de là. Changer la clé de registre ne suffit pas, il faut bien désactiver le service "Explorateur d'ordinateurs". J'ai donc désactivé le service par GPO.

    Tout fonctionne bien sur le réseau principal et la commande browstat vw 1 ne me donne plus que le PDC en MBR.

    Il me reste néanmoins quelques soucis sur les 2 réseaux secondaires.

    La commande browstat status sur un des 2 sous-réseaux : trouve bien PDC en Master mais renvoie "Unable to retrieve list from PDC : 64"

    La commande browstat status sur l'autre sous-réseaux renvoie : "Master name cannot be determined from GetAdaptaterStatus" mais elle utilise bien le PDC comme backup. Par contre sur ce sous-réseaux, la commande arrive bien à trouver la liste des serveurs mais le numéro qui suit "\Device\NetBT_Tcpip_<" n'est pas le même que sur le réseau principal ce qui ne me parait pas logique de prime abord.

    Sinon après quelques tests rapide de la commande nslookup sur les différents réseaux, elle semble maintenant fonctionner de façon conforme.

    J'étudie tout ça la semaine prochaine et je vous tiens au courant.

    vendredi 12 juillet 2013 12:19
  • Bonjour,

    Reprenons dans l'ordre:

    - commande browstat status ... "Unable to retrieve list from PDC : 64"

    Il nous faudrait d'avantage de détails, logs, journaux d'événements etc. x32 /64 bits ?

    Vérifiez tout de même que le NetBIOS soit active sur TCP/IP. Mais ceci peut-être lié aux problèmes ci-dessous.

    - commande browstat status sur l'autre sous-réseaux renvoie : "Master name cannot be determined from GetAdaptaterStatus.

    Je crois savoir que vos Cisco sont dotés de fonctionnalités d'assistance IP afin de diminuer le trafic réseau pour un paquet de diffusion propagé à tous les sous-réseaux. Si vous avez spécifié une adresse d'assistance IP et que le transfert UDP est activé, Les paquets de diffusion sont transférés par défaut aux ports suivants:

    . Time service Port 37

    .TACACS         Port 49

    . Domain Name Services Port 53

    . Trivial File Transfer Port 69

    . DHCP (BootP) Port 67 & 68

    . NetBIOS Name Service port 137

    . NetBIOS Datagram Server Port 138

    La transmission de diffusin NetBIOS sur le port UDP 138 affecte votre Maître Explorateur. Désactivez la transmission sur les ports 137 & 138.

    - "\Device\NetBT_Tcpip_<" n'est pas le même que sur le réseau principal ce qui ne me parait pas logique de prime abord.

    . Ceci peut-être provoqué par une élection forcée de votre machine en tant que maître explorateur.

    . Vos cartes réseaux sont connectés au même sous-réseaux.

    . Si elles ne le sont pas directement, elles le sont indirectement par l'intermédiaires d'autres sous-réseaux auxquels elles sont connectées.

    . Le maître explorateur utilise un masque de sous-réseau incorrect.

    Vérifiez à l'aide du service WINS que les serveurs WINS pointent vers eux-mêmes en tant que serveurs WINS principal et secondaire dans la configuration TCP/IP.

    Pour obtenir des informations en invite de commandes:

    Net Helpmsg ErrorNumber

    Cordialement,

    Bricoleur.


    sans l'acquisition d'un immense superflu chaque condition se sent misérable. DIDEROT

    vendredi 12 juillet 2013 21:59
  • Bonjour,

    Encore une fois merci pour ta réponse Bricoleur.

    Donc :

    - L'erreur "Unable to retrieve list from PDC : 64" n'apparait plus sur le sous-réseaux où se trouvent DC2 et DC3. Tout semble bien fonctionner sur ce sous-réseau.

    - L'erreur "Master name cannot be determined from GetAdaptaterStatus" perdure sur l'autre sous-réseau.

    D'ailleurs, bizarrement, ce matin, pendant quelques minutes, les ordinateurs (Workstation et serveurs) du sous-réseau n'apparaissait plus dans la liste des ordinateurs allumés, pourtant on pouvait y accéder par l'adresse IP et par les lecteurs réseaux enregistrés dans les postes de travail. C'est revenu tout seul.

    - Concernant les serveurs NAS CISCO je dois avouer ne pas avoir trouver les fonctionnalités d'assistance IP dont tu parles. S'il s'agit des serveurs RADIUS ils sont tous désactivés.

    - Concernant le WINS, seul le PDC est serveur WINS, et il pointe bien sur lui-même. Est-ce qu'il faudrait que j'installe des serveurs WINS secondaires ?

    - NSLOOKUP fonctionne de façon correcte sur tous les réseaux.

    En fait, à mon avis, le problème du sous-réseau de DC1 vient du DNS.

    En effet, lorsque je fais un DCDIAG /test:dns sur le réseau principal il me signale que l'adresse IP d'un des serveurs root est fausse. Idem sur le sous-réseau de DC2 et DC3, ce qui me parait logique. Par contre, je n'obtiens pas cet avertissement sur le réseau de DC1 ... ce qui ne me parait normal.

    D'autre part, je m'aperçois que j'ai une erreur récurrente dans les logs du serveur DNS de ce sous-réseau. Pour l'expliquer il faut que je décrive un peu plus le domaine :

    Le nom du domaine est : nom_du_domaine.fr (je précise qu'il s'agit d'un réseau interne et pas d'un intranet malgré l'extension utilisée).

    DC1 se trouve sur un site nommé nom_du_site.nom_du_domaine.fr

    Dans les zones de recherche directes de tous les serveurs j'ai bien 2 zones : nom_du_domaine.fr et _msdcs.nom_du_domaine.fr

    Or, depuis quelques jours, j'ai une erreur 4007 dans l'observateur d'événements du serveur DNS de DC1 qui me dit que le serveur n'a pas pu ouvrir  la zone _msdcs.nom_du_site.lan ! Ce qui semble normal puisque cette zone n'existe pas ou, plus exactement n'existe plus.

    Je vais approfondir de ce côté là. Je vous tiens au courant dès que j'ai du nouveau.

    lundi 15 juillet 2013 12:25
  • Je pense avoir résolu mon souci de DNS sur le sous-réseau (une erreur dans le paramétrage des redirecteurs pour les autres domaine DNS).

    La commande DCDIAG /test:dns envoie bien maintenant le même avertissement que sur les autres réseaux concernant un des serveurs root.

    Par contre, pas d'incidence sur l'erreur dans BROWSTAT STATUS pour le moment.

    J'ai programmé un redémarrage du serveur secondaire cette nuit au cas où.

    Je vous tiens au courant.

    lundi 15 juillet 2013 12:54
  • Pour info, le redémarrage de DC1 n'a rien changé pour l'erreur dans browstat status.

    D'autre part, ce matin, l'ensemble du sous-réseau était de nouveau invisible dans le parcours réseau. En fait, hier c'est un ordinateur qui n'avait pas encore reçu la GPO désactivant le service qui avait pris le relais du maitre explorateur, c'est pour ça que les ordinateurs étaient apparus au bout de quelques minutes.

    Du coup, obligé de lancer l'explorateur d'ordinateur sur DC1. Évidemment, je n'ai plus l'erreur GetAdaptaterStatus mais c'est DC1 qui est désigné Maitre explorateur sur son sous-réseau. Si je stoppe de nouveau le service explorateur, les ordinateurs disparaissent au bout de quelques minutes et l'erreur GetAdaptaterStatus réapparait.

    Je pense avoir résolu mes soucis de DNS, par contre j'ai un avertissement concernant un souci dans la réplication. Il est probable que le problème vienne de là. J'approfondis cette piste et je vous tiens au courant.

    mardi 16 juillet 2013 09:58