locked
Demarrage de serveur virtuel Exchange impossible (serveur de production!!!) RRS feed

  • Question

  • Bonjour,

    Le serveur virtuel sur lequel nous avions mis en production Exchange était sature. Nous avons donc supprime le fichier VHD correspondant au dernier snapshot réalisé pour gagner de l'espace disque. Il se trouve que depuis ca, un message d'erreur nous empeche de demarrer le serveur en question. Le message indique qu'il est impossible de charger la machine virtuelle puisqu'un fichier avhd est manquant. Effectivement je ne trouve trace de ce dernier nulle part.

    Par contre j'ai bien retrouve une sauvegarde du fichier vhd. Malheureusement aucune sauvegarde du fichier avhd. Je suis en panique car c'est le serveur de production de l'entreprise. Leur messagerie est KO a l'heure actuelle du coup. J'ai crée une utre machine virtuelle et tente de restaurer mon image vhd avec sans succes: Windows semble vouloir se lancer puisqu'il commence a charger puis ecran noir. Y a t il une chance que je puisse restaurer mon serveur Hyper v avec mon vhd ? ou autrement ? je précise que la suppression du fichier a été faite directement dans le répertoire de stockage mais que la machine virtuelle est toujours dans la liste.

    dimanche 21 avril 2013 11:10

Réponses

  • Bonjour,

    La c'est pas bon si vous avez supprimé le fichier de snapshot manuellement... Est ce que vous voyez des snapshot au niveau de votre machine virtuelle ?

    Dans tout le cas je pense qu'il vous faudra faire un restauration du serveur à partir de votre sauvegarde. 


    Cordialement Denis ECHE, Ingénieur Système-Réseaux. Certifié MCSA/MCSE Server Infrastructure 2012. Mon Blog Si ma réponse vous a été utile, ou a permis la résolution de votre problème; merci de Voter ou de la marquer comme Utile.

    lundi 22 avril 2013 06:20
  • Bonjour,

    Je confirme ce que dit Denis car normalement lorsque l'on veut supprimer un snapshot, on doit le faire depuis la console hyper-v pour que le snapshot se "merge" au VHD. Donc si vous l'avez fait manuellement, le seul moyen est une restauration.


    Note : Si ma réponse vous a été utile, ou apporté une résolution; merci de voter ou de la marquer comme réponse.

    lundi 22 avril 2013 07:49

Toutes les réponses

  • Bonjour,

    Certain sont meilleur que moi en hyper-v, mais j'ai trouver ce lien qui peut peut-etre aider; http://blogs.msdn.com/b/robertvi/archive/2008/08/26/howto-recover-snapshots.aspx (Howto recover snapshots)

    Merci


    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Twitter - @yagmoth555 ()
    Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/

    lundi 22 avril 2013 02:56
  • Bonjour,

    La c'est pas bon si vous avez supprimé le fichier de snapshot manuellement... Est ce que vous voyez des snapshot au niveau de votre machine virtuelle ?

    Dans tout le cas je pense qu'il vous faudra faire un restauration du serveur à partir de votre sauvegarde. 


    Cordialement Denis ECHE, Ingénieur Système-Réseaux. Certifié MCSA/MCSE Server Infrastructure 2012. Mon Blog Si ma réponse vous a été utile, ou a permis la résolution de votre problème; merci de Voter ou de la marquer comme Utile.

    lundi 22 avril 2013 06:20
  • Bonjour,

    Je confirme ce que dit Denis car normalement lorsque l'on veut supprimer un snapshot, on doit le faire depuis la console hyper-v pour que le snapshot se "merge" au VHD. Donc si vous l'avez fait manuellement, le seul moyen est une restauration.


    Note : Si ma réponse vous a été utile, ou apporté une résolution; merci de voter ou de la marquer comme réponse.

    lundi 22 avril 2013 07:49
  • Bonsoir,

    Je confirme que seule la restauration s'avere etre la solution. Il a fallut remonter une sauvegarde. Seulement, cette sauvegarde est tres ancienne vu que les erreurs provenant de logiciel de sauvegarde ARCSERVE. Aucun cliche depuis des mois.

    On est en train de verifie que la restauration est bien conforme.

     

    mardi 23 avril 2013 23:53
  • Bonjour,

    La c'est pas bon si vous avez supprimé le fichier de snapshot manuellement... Est ce que vous voyez des snapshot au niveau de votre machine virtuelle ?

    Dans tout le cas je pense qu'il vous faudra faire un restauration du serveur à partir de votre sauvegarde. 


    Cordialement Denis ECHE, Ingénieur Système-Réseaux. Certifié MCSA/MCSE Server Infrastructure 2012. Mon Blog Si ma réponse vous a été utile, ou a permis la résolution de votre problème; merci de Voter ou de la marquer comme Utile.


    Je confirme
    mardi 23 avril 2013 23:53