none
Problème de connexion RDS RRS feed

  • Question

  • Bonjour,

    Nous travaillons depuis plusieurs jours sur un projet RDS sous Windows 2012 R2. Nous avons suivi à la lettre la procédure décrite dans le livre "Hicham KADIRI" et après plusieurs essais plus ou moins heureux nous avons enfin réussi à nous connecter. Mais de manière très régulière quoi que aléatoire il nous faut recommencer la validation du certificat sur le serveur Passerelle.

    Voici l'infra sur laquelle nous travaillons :

    Un serveur Windows 2012R2 StandAlone hébergé chez Ikoula.

    HyperV avec une carte dédiée TS

    2 Serveurs Active Directory - DNS (AD)
        * 1 Serveur Licences (SQL optionnel)
        * 1 serveur accès Web et passerelle
        * 1 Serveur Broker
        * 4 Serveurs TSE dont 1 RemoteAPP
        * et 2 Serveurs de fichiers

    1 Serveur Ubuntu FireWall et routage

    Nous étions partis initialement sur deux serveurs distincts pour Accès Web et Passerelle, mais nous n'avons jamais réussi à aller au delà de l'accès Web. Nous avons donc réunis les deux rôles sur l'un des serveurs.

    Le certificat utilisé est le certificat racine de notre entreprise (Comodo) et a été importé exporté via IIS dans les règles de l'art.

    Cela pour l'environnement. Nous sommes confrontés à des problèmes d’authentification multiples, soit de la part de la passerelle, soit du broker et peut être de l'AD (compte refusés) et de temps en temps de l'accès Web. La réimportation du certificat résout parfois le problème, parfois non ... Ceci est donc un SOS.

    Merci de toutes les réponses et conseils que vous pourrez nous fournir.

    Amicalement

    mercredi 6 juillet 2016 10:38

Réponses

  • Bonjour,

    Nous avons résolu le problème de certificat en changeant de nom de domaine et en achetant un certificat SSL lié à ce nom de domaine et non plus le certificat racine utilisé précédemment.

    Par contre nous rencontrons un nouvel incident :
    lorsque certains client cherche à se connecter, si les différentes étapes semblent être validées, la session ne s'ouvre pas. Après vérifications, nous constatons que seuls les clients ayant une version de MSTSC égale à 6.3.9600 rencontrent le problème.

    Une recherche approfondie des paquets échangés remonte l'information suivante :  il semblerait que chaque client en version MSTSC 6.3.9600 cherche à communiquer en UDP, alors que ceux qui y parviennent, à la fois sur les versions 6.1.X et la 10.0.X communiquent en TCP et arrivent très bien à joindre un des trois RDSH que nous avons.

    Voici notre Architecture :

        2 Serveurs Active Directory - DNS (AD)
        1 Serveur Licences / SQL (Pas encore configurée)
        1 serveur accès Web et passerelle
        1 Serveur Broker
        4 Serveurs TSE (Service de Bureaux à Distance) dont 1 RemoteAPP
        2 Serveurs de fichiers

    Nous avons également un Firewall (ubuntu 14.04) qui redirige les flux TCP 443 et 3389 ainsi que les flux UDP 3391 et 3389 vers notre RDGW.

    Auriez-vous déjà rencontré ce type de problème? Et si oui, existe-t-il un correctif?
    mardi 19 juillet 2016 11:41

Toutes les réponses

  • Bonjour,

    Je n'ai pas lu le livre, mais juste pour qu'on soit bien d'accord, de mémoire, il faut que le certificat porte le nom de la ferme pour les HOST est ce que c'est bien le cas ?

    Pour le tsweb me semble que c'est le nom du site web du cou et pour la passerelle le nom du serveur

    mercredi 6 juillet 2016 16:31
  • Bonjour

    Vous avez des messages d'erreurs ou des captures d écran ?

    Cordialement

    jeudi 7 juillet 2016 14:09
  • Bonjour,

    Nous avons résolu le problème de certificat en changeant de nom de domaine et en achetant un certificat SSL lié à ce nom de domaine et non plus le certificat racine utilisé précédemment.

    Par contre nous rencontrons un nouvel incident :
    lorsque certains client cherche à se connecter, si les différentes étapes semblent être validées, la session ne s'ouvre pas. Après vérifications, nous constatons que seuls les clients ayant une version de MSTSC égale à 6.3.9600 rencontrent le problème.

    Une recherche approfondie des paquets échangés remonte l'information suivante :  il semblerait que chaque client en version MSTSC 6.3.9600 cherche à communiquer en UDP, alors que ceux qui y parviennent, à la fois sur les versions 6.1.X et la 10.0.X communiquent en TCP et arrivent très bien à joindre un des trois RDSH que nous avons.

    Voici notre Architecture :

        2 Serveurs Active Directory - DNS (AD)
        1 Serveur Licences / SQL (Pas encore configurée)
        1 serveur accès Web et passerelle
        1 Serveur Broker
        4 Serveurs TSE (Service de Bureaux à Distance) dont 1 RemoteAPP
        2 Serveurs de fichiers

    Nous avons également un Firewall (ubuntu 14.04) qui redirige les flux TCP 443 et 3389 ainsi que les flux UDP 3391 et 3389 vers notre RDGW.

    Auriez-vous déjà rencontré ce type de problème? Et si oui, existe-t-il un correctif?
    mardi 19 juillet 2016 11:41
  • Bonjour CatGuid,

    Je vous conseille de créer un nouveau thread pour le deuxième incident.

    Cordialement,
    Teodora


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    mardi 19 juillet 2016 12:22