none
OAB EXCHANGE 2010 RRS feed

  • Question

  • j'ai besoin de l'aide concernant notre serveur Exchange 2010 qui héberge les trois roles MB,HUB,CAS.

    aprés une migration de 2003 vers 2010 et dégradation de serveur Exchange 2003, j'ai constaté un probléme au niveau de service OAB, l'event id 5000 s'affiche dans le journal application, voici l'erreur :

    Log Name:      Application
    Source:        MSExchange Management Application
    Date:          24/01/2011 23:07:52
    Event ID:      5000
    Task Category: AdminAuditLog
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      EXchange.mydomain.co.ma
    Description:
    Failed to save admin audit log for this cmdlet invocation.
    Organization: 
    Log content:
    Subject: mydomain.co.ma/Users/Administrateur : Update-OfflineAddressBook
    Body:
    Cmdlet Name: Update-OfflineAddressBook
    Object Modified: \Offline address Book
    Parameter: Identity = \Offline address Book
    Caller: mydomain.co.ma/Users/Administrateur
    Succeeded: True
    Error: None
    Run Date: 2011-01-24T23:07:52
    OriginatingServer: EXCHANGE (14.01.0218.011)
     
    Error:
    Exception thrown during AdminLogProvisioningHandler.Validate: Microsoft.Exchange.Data.Storage.ObjectNotFoundException: The discovery mailbox, a hidden default mailbox that is required to search mailboxes, can't be found. It may have been inadvertently deleted. This mailbox must be re-created before you can search mailboxes.
       at Microsoft.Exchange.Data.Storage.Infoworker.MailboxSearch.MailboxDataProvider.GetDiscoveryMailbox(ADRecipientSession session)
       at Microsoft.Exchange.Management.SystemConfigurationTasks.AdminAuditLogHelper.CheckArbitrationMailboxStatus(OrganizationId organizationId, ADUser& user, ExchangePrincipal& principal, String& errorMessage)
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="MSExchange Management Application" />
        <EventID Qualifiers="49152">5000</EventID>
        <Level>2</Level>
        <Task>5</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2011-01-24T23:07:52.000000000Z" />
        <EventRecordID>8353</EventRecordID>
        <Channel>Application</Channel>
        <Computer>EXCHANGE.mydomain.co.ma</Computer>
        <Security />
      </System>
      <EventData>
        <Data>Subject: mydomain.co.ma/Users/Administrateur : Update-OfflineAddressBook
    Body:
    Cmdlet Name: Update-OfflineAddressBook
    Object Modified: \Offline address Book
    Parameter: Identity = \Offline address Book
    Caller: mydomain.co.ma/Users/Administrateur
    Succeeded: True
    Error: None
    Run Date: 2011-01-24T23:07:52
    OriginatingServer: EXCHANGE (14.01.0218.011)
    </Data>
        <Data>
        </Data>
        <Data>Exception thrown during AdminLogProvisioningHandler.Validate: Microsoft.Exchange.Data.Storage.ObjectNotFoundException: The discovery mailbox, a hidden default mailbox that is required to search mailboxes, can't be found. It may have been inadvertently deleted. This mailbox must be re-created before you can search mailboxes.
       at Microsoft.Exchange.Data.Storage.Infoworker.MailboxSearch.MailboxDataProvider.GetDiscoveryMailbox(ADRecipientSession session)
       at Microsoft.Exchange.Management.SystemConfigurationTasks.AdminAuditLogHelper.CheckArbitrationMailboxStatus(OrganizationId organizationId, ADUser&amp; user, ExchangePrincipal&amp; principal, String&amp; errorMessage)</Data>
      </EventData>
    </Event>

     

    mon probleme est critique , je remercie toute aide.

    merci d'avance

     

    mercredi 26 janvier 2011 11:38

Réponses

  • Desactiver:
    Get-Mailbox -Arbitration -Database "votre DB" | Disable-Mailbox -Arbitration

    Supprimer:
    Get-Mailbox -Arbitration -Database "votre DB"| Remove-Mailbox -Arbitration -RemoveLastArbitrationMailboxAllowed

    Executez les trois commandes peut etre que ça reglera votre probleme:

    Setup.com /PrepareAD
    Setup.com /PrepareSchema
    Setup.com /PrepareDomain

    ensuite redemarrer votre serveur

     

    jeudi 27 janvier 2011 17:13

Toutes les réponses

  • Bonjour,

    Je suppose que vous avez suprimé la boite aux lettre de research. Vous avez juste à la créer à nouveau avec la commande:

    New-Mailbox SearchResults -Discovery -UserPrincipalName SearchResults@votredomaine.fr

    et verifier avec la commande:

    Get-Mailbox -Resultsize unlimited -Filter {RecipientTypeDetails -eq "DiscoveryMailbox"}

    Redemarrer votre serveur ou service.

    Sur Exchnage 2003 l'OAB est stocké dans une base de donnée de dossier publique, vous devez aussi migré ces éléments dans votre nouvelle infrastructure Exchange.

    Penser à decomissioner le serveur Exchange 2003 après.

    A+

    mercredi 26 janvier 2011 14:10
  • BONJOUR

    merci pour votre réponse, le probleme c'est que aprés avoir migrer vers exchange 2010 et désinstaller, nous avons eu un probleme pour monter les bases de données qui n'arrivé plus a monter, des attributs ont été supprimé dans l'active directory.

    un autre serveur avec les trois rloes a été installé pour résoudre se probleme, j'ai resturer les bases de données vers se nouveau serveur et ca a marché.

    maintenant j'ai l'erreur 5000 qui s'affiche dans le journal application aprés update de OAB

    merci

    mercredi 26 janvier 2011 16:04
  • Bonjour

    avez vous un resultat lorsque vous executez cette commande?

    Get-Mailbox -Resultsize unlimited -Filter {RecipientTypeDetails -eq "DiscoveryMailbox"}

    si vous n'avez pas de resultat essayé la commande:

    get-mailbox –arbitration

    vous devriez avoir un resultat comme: "SystemMailbox{e0dc1c29-89c3-4034-b678-e6c29d823ed9}"

    si vous n'avez pas de resultat executez la commande:

    setup.com /preparead

    et ensuite:

    Enable-Mailbox “SystemMailbox{e0dc1c29-89c3-4034-b678-e6c29d823ed9}” –Arbitration

    Biensur si le guid est différent modifier le.

    Une fois les commandes effectuées, tester à nouveau avec les commandes:

    Get-Mailbox -Resultsize unlimited -Filter {RecipientTypeDetails -eq "DiscoveryMailbox"}

    get-mailbox –arbitration

    ensuite essayer votre Update-OfflineAddressBook

    A+

    jeudi 27 janvier 2011 10:45
  • bonjour,

    merci encore pour l'intéret que vous portez a ma requette.

    j'ai executé ces commandes, ca m'affiche des warning voici le résultat :

    [PS] C:\Windows\system32>Get-Mailbox -Resultsize unlimited -Filter {RecipientTypeDetails -eq "DiscoveryMailbox"}

    Name                      Alias                ServerName       ProhibitSendQuota
    ----                      -----                ----------       -----------------
    DiscoverySearchMailbox... DiscoverySearchMa... exchange        50 GB (53,687,091,200 bytes)


    [PS] C:\Windows\system32>get-mailbox -arbitration

    Name                      Alias                ServerName       ProhibitSendQuota
    ----                      -----                ----------       -----------------
    SystemMailbox{1f05a927... SystemMailbox{1f0... exchange        unlimited
    WARNING: The object mydomain.co.ma/Users/SystemMailbox{1f05a927-b561-4175-a582-7ecd67165b15} has been corrupted, and
    it's in an inconsistent state. The following validation errors happened:
    WARNING: Database is mandatory on UserMailbox.
    WARNING: Database is mandatory on UserMailbox.
    SystemMailbox{e0dc1c29... SystemMailbox{e0d... exchange        unlimited
    WARNING: The object mydomain.co.ma/Users/SystemMailbox{e0dc1c29-89c3-4034-b678-e6c29d823ed9} has been corrupted, and
    it's in an inconsistent state. The following validation errors happened:
    WARNING: Database is mandatory on UserMailbox.
    WARNING: Database is mandatory on UserMailbox.
    FederatedEmail.4c1f4d8... FederatedEmail.4c... exchange        1 MB (1,048,576 bytes)
    WARNING: The object mydomain.co.ma/Users/FederatedEmail.4c1f4d8b-8179-4148-93bf-00a95fa1e042 has been corrupted, and
    it's in an inconsistent state. The following validation errors happened:
    WARNING: Database is mandatory on UserMailbox.
    WARNING: Database is mandatory on UserMailbox.

    Merci

     

    jeudi 27 janvier 2011 11:47
  • La boite discovery est corompu. Il faut

    allez dans le repertoire des binaires Exchange et Executez à nouveau

    setup.com /preparead

    et ensuite:

    get-mailbox -arbitration

    Ya il une erreur apres cet action?

    jeudi 27 janvier 2011 12:42
  • bonjour,

    j'ai déja exécuter setup.com /preparead” mais malheureusement le probleme persiste toujours.

    jeudi 27 janvier 2011 14:08
  • ok supprimer les systemes mailbox (3 en tout)

    SystemMailbox{1f05a927... SystemMailbox{1f0

    SystemMailbox{e0dc1c29... SystemMailbox{e0d

    FederatedEmail.4c1f4d8b-8179-4148-93bf-00a95fa1e042

    exporter votre registre, allez dans le registre dans localmachine\software\microsoft\exchangeserver\V14

    Dans un des dossiers MailboxRole, HubtransportRole or ClientaccessRole il y a une valeur  "Watermark" et/ou "Action" supprimer les.

    Ensuite et lancer à nouveau un setup.com /preparead" pour que le systeme puisse creer les mailbox systemes correctement

    j'attend votre retour

    jeudi 27 janvier 2011 14:30
  • Executer les trois commandes pour etre sur:

    Setup.com /PrepareAD
    Setup.com /PrepareSchema
    Setup.com /PrepareDomain

    jeudi 27 janvier 2011 14:32
  • Bonjour,

    merci pour votre reactiviter,

    lors de l'execution de la commande Remove-Mailbox "SystemMailbox{1f05a927-b561-4175-a582-7ecd67165b15}" -arbitration

    l'erreur suivante s'affiche :

    Exchange can't remove the arbitration mailbox "SystemMailbox{1f05a927-b561-4175-a582-7ecd67165b15}" because it's the la
    st one in the organization.
        + CategoryInfo          : NotSpecified: (mydomain.local/...2-7ecd67165b15}:ADObjectId) [Remove-Mailbox], Recipient
       TaskException
        + FullyQualifiedErrorId : 99D8773A,Microsoft.Exchange.Management.RecipientTasks.RemoveMailbox

    et pour la 2eme et 3eme boites :

    The arbitration mailbox "SystemMailbox{e0dc1c29-89c3-4034-b678-e6c29d823ed9}" is used by Exchange and can't be removed.
        + CategoryInfo          : NotSpecified: (mydomain.local/...8-e6c29d823ed9}:ADObjectId) [Remove-Mailbox], Recipient
       TaskException
        + FullyQualifiedErrorId : C7CDD705,Microsoft.Exchange.Management.RecipientTasks.RemoveMailbox

    les valeurs Watermark et/ou Action ne figure pas dans le chemain du registre localmachine\software\microsoft\exchangeserver\V14

     

    Merci d'avance.

    jeudi 27 janvier 2011 16:49
  • Executez les trois commandes peut etre que ça reglera votre probleme:

    Setup.com /PrepareAD
    Setup.com /PrepareSchema
    Setup.com /PrepareDomain

    ensuite redemarrer votre serveur

    jeudi 27 janvier 2011 17:00
  • Desactiver:
    Get-Mailbox -Arbitration -Database "votre DB" | Disable-Mailbox -Arbitration

    Supprimer:
    Get-Mailbox -Arbitration -Database "votre DB"| Remove-Mailbox -Arbitration -RemoveLastArbitrationMailboxAllowed

    Executez les trois commandes peut etre que ça reglera votre probleme:

    Setup.com /PrepareAD
    Setup.com /PrepareSchema
    Setup.com /PrepareDomain

    ensuite redemarrer votre serveur

     

    jeudi 27 janvier 2011 17:13
  • BONJOUR AKA N_ZORE

    MERCI POUR TA REACTIVITE ET POUR TON SOUTIEN.

     

    J'ai executé le plan que te ma donner et ca a marché, l'erreur ID 5000 ne s'affiche plus dans le journal Application, merci 1000 fois.

    mais j'ai aussi besoin de ton soutien pour un probleme de Public Folder aprés execution de l'outil best Practise une erreur de public folder s'affiche, voici l'erreur :

    Site server folder deleted

    The site-wide public folder database for administrative group 'Exchange Administrative Group (FYDIBOHF23SPDLT)' has been deleted. Current public folder store: 'CN=Public Folder DataBase_MBX_01\0ADEL:eb131ce3-4202-4ef2-b659-38cfd34cb6a3,CN=Deleted Objects,CN=Configuration,DC=mydomain,DC=co,DC=ma'.

     

    je pense que sa a rapport avec le sevreur Exchnage 2010 qui a été supprimé

     

    Merci pour ta collaboration

     

    lundi 31 janvier 2011 15:12
  • Bonjour,

    Avez vous une nouvelle base de donnée de dossier publique?

    Contient elle des données restaurées?

    Avez vous desintallé les serveurs correctement?

    Vous pouvez aller voir ce blog la modification devrait résoudre votre problème.

    http://makanzore.wordpress.com/2011/01/31/erreur-exbpa-site-folder-server-deleted/

    A+

    lundi 31 janvier 2011 16:36