none
Serveur NPS (2012 r2) et domaine à 2 point RRS feed

  • Question

  • Bonjour,

    j'assaye de connecter mon serveur NPS (2012r2) à mon domaine ad (2008 r2). 

    Le serveur NPS me remonte des message d'erreur "le domaine spécifié n'existe pas"

    J'ai bien inscrit mon serveur dans l'active directory (bien présent dans le groupe "serveurs RAS et IAS").

    Mon problème vient de mon domaine qui possède un point :

    batiment.ville.priv

    Le serveur NPS me remonte qu'il ne trouve pas le domaine "batiment.ville"

    Je pense que cela vient du point qui a été historiquement saisi sous NT4...

    La solution d'ajouter un clef "DefaultDomain"dans HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP\ControlProtocols\Builtin ne fonctionne hélas pas ...

    Comment indiquer au serveur NPS de consulter le domaine batiment.ville.priv au lieu du domaine batiment.ville ???

    merci

    Fabien

    Contrary to what others have said, you do not need to rename your domain or back rev to 2008 non-R2.

    I was able to resolve this issue by adding the following reg key to force authentication to use the DNS name, instead of the NetBIOS name:

    HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP\ControlProtocols\Builtin

    Contrary to what others have said, you do not need to rename your domain or back rev to 2008 non-R2.

    I was able to resolve this issue by adding the following reg key to force authentication to use the DNS name, instead of the NetBIOS name:

    HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP\ControlProtocols\Builtin

    mardi 11 avril 2017 14:26

Réponses

  • Bonjour,

    Dans ce cas soit ce domaine n'existe pas ou le serveur DNS interrogé par le serveur NPS n'est pas capable de résoudre la zone DNS du domaine batiment.ville. Notez bien que batiment.ville et batiment.ville.priv répresentent  deux domaine différents.

     


    Please don't forget to mark the correct answer, to help others who have the same issue. Thameur BOURBITA MCSE | MCSA My Blog : http://bourbitathameur.blogspot.fr/

    mercredi 12 avril 2017 07:42
    Modérateur
  • Bonjour, oui tu as raison sur toute la ligne mais c'est mieux expliqué :)

    Sur ma NIC j'ai bien batiment.ville.priv

    J'ai eu des doute sur ws2008r2 ad et 2012 nps.

    J'ai donc installé un 2008 r2 mais j'ai exactement le même message d'erreur que sur le 2012.

    J'ai même activé le service NPS sur un DC et j'ai le même message aussi.

    Je pense donc bien au problème netbios / dns à cause du "." en trop ...

    en tout cas merci pour vos réponses

    Fabien

    • Marqué comme réponse LISON FABIEN mercredi 12 avril 2017 15:00
    mercredi 12 avril 2017 14:09
  • Bonjour, oui tu as raison sur toute la ligne mais c'est mieux expliqué :)

    Sur ma NIC j'ai bien batiment.ville.priv

    J'ai eu des doute sur ws2008r2 ad et 2012 nps.

    J'ai donc installé un 2008 r2 mais j'ai exactement le même message d'erreur que sur le 2012.

    J'ai même activé le service NPS sur un DC et j'ai le même message aussi.

    Je pense donc bien au problème netbios / dns à cause du "." en trop ...

    en tout cas merci pour vos réponses

    Fabien

    Avez vous essayé de déclarer le suffix priv dans les paramètres de la carte réseau du serveur NPS.
    Dans ce cas s'il n'arrive pas à résoudre la résoudre la zone batiment.ville , il va retenter la résoudre en ajoutant .priv à la fin. Dans ce cas quand vous lancer un ping batiment.ville ; il va retournet l'ip batiment.ville.priv



    Please don't forget to mark the correct answer, to help others who have the same issue. Thameur BOURBITA MCSE | MCSA My Blog : http://bourbitathameur.blogspot.fr/

    • Marqué comme réponse LISON FABIEN mercredi 12 avril 2017 14:59
    mercredi 12 avril 2017 14:23
    Modérateur

Toutes les réponses

  • Bonjour,

    Il faut que le serveur NPS est capable de résoudre le nom DNS du domaine en question. 

    nslookup batiment.ville.priv

    Depuis le serveur NPS taper les commandes suivantes pour savoir s'il arrive bien à trouver un DC du domaine en question:

    nltest /dsgetdc:batiment.ville.priv
    set logonserver
    
    


    Please don't forget to mark the correct answer, to help others who have the same issue. Thameur BOURBITA MCSE | MCSA My Blog : http://bourbitathameur.blogspot.fr/

    mardi 11 avril 2017 14:42
    Modérateur
  • Bonjour et merci pour ta réponse; pas de soucis pour résoudre les noms "batiment.ville.priv" avec les commandes que tu me m'indiques.

    Par contre mon journal d’événement indique domaine introuvable sur "batiment.ville", j'ai donc essayé tes commandes sur ce domaine et j'ai :

    serveur : ok

    adresse : ok

    dns request timed out

    merci

    mercredi 12 avril 2017 07:26
  • Bonjour,

    Dans ce cas soit ce domaine n'existe pas ou le serveur DNS interrogé par le serveur NPS n'est pas capable de résoudre la zone DNS du domaine batiment.ville. Notez bien que batiment.ville et batiment.ville.priv répresentent  deux domaine différents.

     


    Please don't forget to mark the correct answer, to help others who have the same issue. Thameur BOURBITA MCSE | MCSA My Blog : http://bourbitathameur.blogspot.fr/

    mercredi 12 avril 2017 07:42
    Modérateur
  • Bonjour oui j'ai bien noté. Par contre dans mon cas ce n'est pas 2 domaine.

    Mon serveur NPS essaye d'attaquer le nom de domaine "batiment.ville" alors qu'il n'existe pas.

    Comment le forcer à attaquer le nom de domaine "batiment.ville.priv" ?

    merci

    mercredi 12 avril 2017 08:11
  • Bonjour LISON FABIEN,

    depuis le Menu "Exécuter" > saisissez : NCPA.CPL > quel est le suffix DNS qui apparaît sur votre NIC /vNIC) ?

    le NPS server est connecté à quel domaine exactement ?

    de mémoire, je sais qu'un problème de résolution NetBIOS existe au niveau du service NPS (2012 R2) membre d'un domaine AD sous 2008 (R2).

    On parle :

    >batiment.ville (nom NetBIOS) : nom netbios posant problème de résolution

    >batiment.ville.priv (nom DNS : FQDN) depuis lequel on arrive à contacter les serveurs DNS et résoudre des entrées xx.batiment.ville.priv

    étudier la piste du "problème --By Design-- entre WS2008 R2 (AD)/2012 (NPS)"

    j'ai eu ce cas pour un de mes clients dans le passé.

    tenez nous au courant, n'd GoodLuck.

    a+

    HK



    Hicham KADIRI | Just Another IT Guy
    Livre de référence RDS 2012 R2 désormais disponible !
    RDS 2012 R2 reference book is now available !
    Découvrez tous mes eBooks )

    mercredi 12 avril 2017 08:32
  • Bonjour, oui tu as raison sur toute la ligne mais c'est mieux expliqué :)

    Sur ma NIC j'ai bien batiment.ville.priv

    J'ai eu des doute sur ws2008r2 ad et 2012 nps.

    J'ai donc installé un 2008 r2 mais j'ai exactement le même message d'erreur que sur le 2012.

    J'ai même activé le service NPS sur un DC et j'ai le même message aussi.

    Je pense donc bien au problème netbios / dns à cause du "." en trop ...

    en tout cas merci pour vos réponses

    Fabien

    • Marqué comme réponse LISON FABIEN mercredi 12 avril 2017 15:00
    mercredi 12 avril 2017 14:09
  • Bonjour, oui tu as raison sur toute la ligne mais c'est mieux expliqué :)

    Sur ma NIC j'ai bien batiment.ville.priv

    J'ai eu des doute sur ws2008r2 ad et 2012 nps.

    J'ai donc installé un 2008 r2 mais j'ai exactement le même message d'erreur que sur le 2012.

    J'ai même activé le service NPS sur un DC et j'ai le même message aussi.

    Je pense donc bien au problème netbios / dns à cause du "." en trop ...

    en tout cas merci pour vos réponses

    Fabien

    Avez vous essayé de déclarer le suffix priv dans les paramètres de la carte réseau du serveur NPS.
    Dans ce cas s'il n'arrive pas à résoudre la résoudre la zone batiment.ville , il va retenter la résoudre en ajoutant .priv à la fin. Dans ce cas quand vous lancer un ping batiment.ville ; il va retournet l'ip batiment.ville.priv



    Please don't forget to mark the correct answer, to help others who have the same issue. Thameur BOURBITA MCSE | MCSA My Blog : http://bourbitathameur.blogspot.fr/

    • Marqué comme réponse LISON FABIEN mercredi 12 avril 2017 14:59
    mercredi 12 avril 2017 14:23
    Modérateur
  • Bonjour je viens d'essayer mais toujours pareil, c'etait une superbe idée.

    message dans le journal système : Aucun contrôleur de domaine n’est disponible pour le domaine batiment.ville

    mercredi 12 avril 2017 14:27
  • merci pour votre aide
    mercredi 12 avril 2017 14:28
  • Bonjour je viens d'essayer mais toujours pareil, c'etait une superbe idée.

    message dans le journal système : Aucun contrôleur de domaine n’est disponible pour le domaine batiment.ville

    Pour ce message il vaut mieux de déclarer le nom DNS complet du domaine  batiment.ville.priv. C'est plus propore.
    Merci de ne pas oublier de marquer les réponses qui vous semblent utiles


    Please don't forget to mark the correct answer, to help others who have the same issue. Thameur BOURBITA MCSE | MCSA My Blog : http://bourbitathameur.blogspot.fr/


    mercredi 12 avril 2017 14:49
    Modérateur
  • oui mais le soucis est que le nps attaque batiment.ville ....
    mercredi 12 avril 2017 15:03