none
Problème de résolutions de nom Exchange 2007 RRS feed

  • Discussion générale

  • Bonjour, j'ai un problème sous Outlook pour la découverte automatique du serveur Exchange.

    Mon serveur exchange 2007 est sous le service pack 3.Il fonctionne sous windows 2008 sp2.

    En fait le problème vient du premier démarrage d'Outlook. J'ai un message d'erreur qui me dit que "La connexion à Microsoft Exchange n'est pas disponible. Outlook doit être en ligne ou connecté pour effectuer cette action." Si je clique sur OK, le nom du serveur Microsoft Exchange qui apparaît est bien "serveurmail.domain.local" simplement si je me Vérification du nom, j'obtiens le même message d'erreur. Si à la place du nom, je mets l'adresse IP (192.168.6.241), alors il me remplace l'adresse en nom du serveur comme indiquée ci-dessus et il me valide bien le nom.

    Ce problème se pose sous Windows Vista et 7. Sous 7 se pose un soucis supplémentaire, lorsque l'on est pas sur le même réseau, il faut mettre le certificat dans l'autodiscover sur accepter puis mettre l'adresse ip dans outlook qu'il résoud bien et là cela fonctionne. par contre je suis obligé de remettre par la suite le certificat sur ignoré, sinon je n'ai plus de gestionnaire d'absence de bureau.

    Mon certificat dans iis contient bien les informations nécessaires sur les serveurs. Pour le moment, je n'utilise pas Outlook Anywhere.

     

    Ce problème est pesant en sachant que les utilisateurs tournent et cela provoque des inconvéniants.

    Les entrées nom du serveur et autodiscover sont bien dans le DNS en statique.

    Et je peux résoudre le nom en faisant un nslookup. Que ce soit le nom ou l'adresse ip. 

     

    Merci pour votre aide car la je craque.

     

     

    vendredi 15 octobre 2010 11:47

Toutes les réponses

  • Bonjour ,

    ton probléme me semble causé par le DNS sur les clients > qu'est ce qu'ils ont comme DNS primaire et auxiliare  , pas d'entrés dans  le fichier Hosts ?

    quand vous faites > nslookup > NomduserveurExchange  ça donne quoi ?

    avez vous des erreurs dans le journal d'évènements du serveur Exchange  ?

    pour les popup d'authentification autodiscover > Est ce qu'un proxy est configuré sur les pc > cocher ne pas utiliser le proxy pour les adresses locales.

    tester aussi le configuration automatique de la messagerie

    Vous pouvez également utiliser Outlook 2007 pour tester les informations de configuration automatique fournies par le service de découverte automatique. Pour utiliser le client Outlook 2007 pour tester la configuration automatique à l'aide d'Outlook 2007, connectez-vous à la boîte aux lettres de l'utilisateur pour lequel vous voulez tester la configuration automatique, puis procédez comme suit :

    1. Pendant l'exécution d'Outlook 2007, maintenez enfoncée le touche CTRL, cliquez avec le bouton droit sur l'icône Outlook dans la zone de notification, puis sélectionnez Tester la configuration automatique de la messagerie .
    2. Vérifiez que l'adresse de messagerie correct figure dans la zone de texte à côté de Adresse de messagerie .
    3. Désactivez les cases à cocher à côté de Utiliser Guessmart et Authentification Guessmart sécurisée .
    4. Dans la page Tester la configuration automatique de la messagerie page , vérifiez que la case à cocher à côté de Utiliser la découverte automatique est activée, puis cliquez sur le bouton Tester .

    merci de nous tenir au courant .

     

    Khalil

     


    ----------- Merci Khalil Benz [MCSE - MCTS 2008 - MCTS ISA- MCT]
    vendredi 15 octobre 2010 13:43
  • Pour le dns, j'ai uniquement l'adresse du contrôleur de domaine qui fait serveur dns : 192.168.6.240

    Lorsque je fais nslookup mailsrv.domaine.local -> j'ai bien le nom qui est résolu en adresse ip du serveur de messagerie

    Je n'ai aucune erreur dans l'observateur d'événements du serveur Exchange. J'ai augmenté le niveau d'événements et j'ai les messages MSExchange Autodiscover par exemple :

    La demande Autodiscover a été traitée, SID de l'utilisateur : « S-1-5-21-3238336179-650513222-566855595-3787 », adresse de l'hôte : « 192.168.6.22 », nom de l'hôte : « 192.168.6.22 ».

    puis un autre événements

    La configuration a été générée pour xxxxx@domaine.com.

    puis il m'indique que la connexion a été coupée.

     

    Il n'y a aucun proxy sur le réseau pour le moment.

     

    j'ai testé la configuration automatique de la messagerie. Directement sur Exchange j'ai obtenu les résultats suivants :

    [PS] C:\Windows\system32>Test-OutlookWebServices |fl


    Id      : 1003
    Type    : Information
    Message : Test imminent d'AutoDiscover avec l'adresse de messagerie xxxxx@atiam.org.

    Id      : 1007
    Type    : Information
    Message : Serveur de test mailsrv.domaine.local avec le nom publié https://mailsrv.domaine.local/EWS/Exchange.asmx & .

    Id      : 1019
    Type    : Information
    Message : Point de connexion de service AutoDiscover valide trouvé. L'URL d'AutoDiscover sur cet objet est https://mailsrv.domaine.local/Autodiscover/Autodiscover.xml.

    Id      : 1006
    Type    : Information
    Message : Service de découverte automatique contacté à https://mailsrv.domaine.local/Autodiscover/Autodiscover.xml
              .

    Id      : 1016
    Type    : Success
    Message : [EXCH]-Service AS contacté à https://mailsrv.domaine.local/EWS/Exchange.asmx. Le temps écoulé était de 3
              1 millisecondes.

    Id      : 1015
    Type    : Success
    Message : [EXCH]-Service OAB contacté à https://mailsrv.domaine.local/EWS/Exchange.asmx. Le temps écoulé était de
              0 millisecondes.

    Id      : 1014
    Type    : Success
    Message : [EXCH]-Service UM contacté à https://mailsrv.domaine.local/UnifiedMessaging/Service.asmx. Le temps écoul
              é était de 0 millisecondes.

    Id      : 1006
    Type    : Success
    Message : Le service de découverte automatique a été testé.

     

    ---------

    Sur un Outlook directement, si le certificat dans autodiscover est sur ignorer, j'ai bien la configuration qui réussie :

    Dans l'onglet Résultats,

     

    Autoconfiguration has started, this may take up a minute

    Autoconfiguration found the following settings :

     

    Display Name : Dupont

    Protocal : Exchange RPC

    Server : malsrv.domaine.local

    login Name : dupont

    Availability Service URL : https://mailsrv.domaine.local/EWS/Exchange.asmx

    OOF URL : https://mailsrv.domaine.local/EWS/Exchange.asmx

    OAB URL : https://mailsrv.domaine.local/OAB/b88ea47a-2ca3-4b27-ad82-13e5b56c0cda/

    Unified Message Service URL : https://mailsrv.domaine.local/UnifiedMessaging/Service.asmx

    Auth Package : Unspecified

     

    Dans l'onglet Journal :

    Attempting URL https://mailsrv.domaine.local/Autodiscover/Autodiscover.xml found through SCP

    Autodiscover to https://mailsrv.domaine.local/Autodiscover.xml starting

    Autodiscover to https://mailsrv.domaine.local/Autodiscover.xml succeeded (0x00000000)

    et enfin le fichier XML :

    <?xml version="1.0" encoding="utf-8"?>

    <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">

      <Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a">

        <User>

          <DisplayName>Dupont</DisplayName>

          <LegacyDN>/o=Organisation/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=dupont</LegacyDN>

          <DeploymentId>9181044b-7e2b-40db-97ac-c9d3d2f9487c</DeploymentId>

        </User>

        <Account>

          <AccountType>email</AccountType>

          <Action>settings</Action>

          <Protocol>

            <Type>EXCH</Type>

            <Server>mailsrv.domaine.local</Server>

            <ServerDN>/o=organisation/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=mailsrv</ServerDN>

            <ServerVersion>72038053</ServerVersion>

            <MdbDN>/o=organisation/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=mailsrv/cn=Microsoft Private MDB</MdbDN>

            <AD>dc.domaine.local</AD>

            <ASUrl>https://mailsrv.domaine.local/EWS/Exchange.asmx</ASUrl>

            <EwsUrl>https://mailsrv.domaine.local/EWS/Exchange.asmx</EwsUrl>

            <OOFUrl>https://mailsrv.domaine.local/EWS/Exchange.asmx</OOFUrl>

            <UMUrl>https://mailsrv.domaine.local/UnifiedMessaging/Service.asmx</UMUrl>

            <OABUrl>https://mailsrv.domaine.local/OAB/b88ea47a-2ca3-4b27-ad82-13e5b56c0cda/</OABUrl>

            <CertPrincipalName>Microsoft Exchange</CertPrincipalName>

          </Protocol>

          <Protocol>

            <Type>WEB</Type>

            <Internal>

              <OWAUrl AuthenticationMethod="Basic, Fba">https://mailsrv.domaine.local/owa/</OWAUrl>

              <Protocol>

                <Type>EXCH</Type>

                <ASUrl>https://mailsrv.domaine.local/EWS/Exchange.asmx</ASUrl>

              </Protocol>

            </Internal>

          </Protocol>

        </Account>

      </Response>

    </Autodiscover>

     

    Voilà, je pense que j'ai fait le tour des diagnostiques possibles. Ce que je tiens à préciser, c'est que sur un poste sous XP, cela fonctionne. Pas sous Vista ni sous 7.

     

    Merci pour votre aide.

    lundi 18 octobre 2010 09:28
  • Bonjour,

    pour l'erreur de certificat il faut que le poste client fasse confiance à l'autorité de certification qui a générée le certificat du serveur Exchange.

    Il faut donc installer le certificat de l'autorité de certification sur le poste client.

     

    Pour la configuration du profile Outlook regarde ce lien:

    http://social.answers.microsoft.com/Forums/en-US/w7network/thread/c81cfb94-ef6e-44ce-a683-063e60a5cc87

    Notamment:

    -le serveur DNS configuré sur le poste client

    -essayer de supprimer les profils Outlook existants ( Backuper de la clé "HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem ")

    -décocher la case "Encrypt data between Microsoft Office Outlook and Microsoft Exchange "

    -installer la dernière version d'Outlook 2007 (SP2 + Mise à jour cumulative du 31 août 2010, de 2007 office )

    -Vérifier la règle de firewall Windows "Inbound Rules – Microsoft Office Outlook" et configurer le protocol TCP au lieu d'UDP

    -Essayer de désactiver le Firewall (firewall.cpl)

    -vérifier l'état des services Exchange (test-serviceHealth), redémarrer éventuellement les services MSExchangeSA et MSExchangeAB

    Voila quelques pistes bon courage :)

    lundi 18 octobre 2010 13:16
  • J'ai désactivé le firewall sur les postes. Cela ne vient pas du protocole ip qui n'est pas bon car le problème se pose sous Vista et 7

    J'ai essayé de supprimé les profils et de les recréer. Le problème ne vient pas d'un pc, mais de plusieurs pc, de constructeurs différents.

    J'ai essayé en décochant la case crypter les données ....

    Pour le certificat, le certificat racine est déployé sur les postes du domaine.

    Le DNS est donnée par le DHCP et correspond bien aux autres configurations.

    J'ai redémarré le serveur. et même les services.

    le test-serviceealth donne les résultats suivants :

    [PS] C:\Windows\system32>Test-ServiceHealth |fl


    Role                    : Rôle serveur de boîtes aux lettres
    RequiredServicesRunning : True
    ServicesNotRunning      : {}
    ServicesRunning         : {IISAdmin, MSExchangeADTopology, MSExchangeIS, MSExchangeMailboxAssistants, MSExchangeMailSubmissi
                              on, MSExchangeRepl, MSExchangeSA, MSExchangeSearch, MSExchangeServiceHost, MSExchangeTransportLogS
                              earch, MSFTESQL-Exchange, W3Svc}

    Role                    : Rôle serveur d'accès au client
    RequiredServicesRunning : True
    ServicesNotRunning      : {}
    ServicesRunning         : {IISAdmin, MSExchangeADTopology, MSExchangeFDS, MSExchangeServiceHost, W3Svc}

    Role                    : Rôle serveur de transport Hub
    RequiredServicesRunning : True
    ServicesNotRunning      : {}
    ServicesRunning         : {MSExchangeADTopology, MSExchangeEdgeSync, MSExchangeTransport, MSExchangeTransportLogSearch}

    Voilà, et ça m'énerve de pas trouver. Je le répète, cela fonctionne bien sous windows xp. Outlook est en SP2

     

    Alors question : qu'elle est la différence pour outlook entre xp et vista/7 à part le noyau ??

     

    Merci pour votre aide

    lundi 18 octobre 2010 14:50
  • N'y a t'il personne qui a eu le même problème que moi ?

     

    mercredi 3 novembre 2010 10:26
  • Bonjour.

    J'ai exactement le même problème.

    Avez-vous résolu le problème depuis?

    Merci d'avance pour votre réponse

     


    olive
    jeudi 13 janvier 2011 14:58