none
certificat exhange 2007 RRS feed

  • Question

  • bonjour,

    j'ai le certificat de mon Exchange qui a expiré hier et en le recréant, j'ai toujours le meme message d'erreur dans Outlook.

    j'ai supprimé le vieu certificat et crée un nouveau, tout a l'air correct niveau serveur.

    j'ai un message quand je lance l'utilitaire BestPRactice Analizer : 

    Le compte d'ordinateur pour le serveur Exchangeserveur.domain.LOCAL ne semble pas contenir le nom NetBios du serveur Exchange pour la ressource « SMTP ». Il se peut que l'authentification Kerberos échoue lors de l'envoi de messages entre serveurs. L'outil s'attendait à trouver « SMTP/serveur » dans le « servicePrincipalName ».

    merci de votre aide ! 

    si il manque des info n'hésitez pas à demander !

    lundi 5 novembre 2012 15:38

Réponses

  • Vous devriez afficher le certificat et vérifier qu'il s'agit bien de celui qui vous avez recrée, il est probable que vous n'ayez qu'importer le nouveau certificat sur le serveur CAS, mais sans l'installer pour qu'il soit utilisé. La documentation Technet me semble assez flou sur ce sujet.

    Le certificat est bien présent dans le store du serveur CAS? Il a bien été installé dans IIS sur la connexion SSL :

    • ouvrer la console IIS
    • aller sur le site
    • click droit et Edit binding
    • editer le type HTTPS et vérifier le certificat utiliser
    • si ce n'est pas le bon vous pouvez le changer ici, et redémarrer le site

    Il existe aussi une cmdlet pour demander à Exchange d'activer le certificat (Enable-ExchangeCertificate), il suffit sur votre CAS de faire

    Get-ExchangeCertificate

    De relever le Thumberprint du certificat à activer, puis

    Enable-ExchangeCertificat -Thumberprint "le th" -Services IIS

    mercredi 7 novembre 2012 08:53
    Modérateur

Toutes les réponses