none
Profils d'utilisateurs inactifs ajoutés lors de la synchronisation malgré les filtres RRS feed

  • Question

  • Bonjour à tous,

    Nous avons mis en place le moteur de recherche SharePoint ainsi que la synchronisation des profiles utilisateurs avec l'AD. Pour cette synchro, j'ai paramétré des filtres afin de ne pas prendre en compte les utilisateurs inactifs. 

    Les utilisateurs inactifs sont dans une OU spécifiques, que je n'ai pas sélectionnée dans ma connexion et pour être sur de ne pas en avoir, j'ai également ajouté le filtre UserAccountControl Bit On equal 2.

    Malgré cela, des utilisateurs inactif, qui se trouve dans l'OU que je n'ai pas sélectionné, apparaissent dans la base de profiles. J'ai lancé une full synchro, pour voir si ces profils seraient supprimés mais ça n'est pas le cas.

    Sauriez-vous d'où pourrait venir ces profils et comment m'en débarrasser ?

    Merci et bonne journée


    Edit : Je suis sous SharePoint 2010
    mercredi 9 octobre 2013 09:36

Réponses

  • a votre place j essaierais d abord en incluant le OU ou sont déplacer les compte supprimer.

    ensuite vous pourriez par exemple supprimer quelque compte du UPSa la main (des compte actif et 1 ou 2 compte désactiver), puis vous relancer votre synchro avec les filtres, et si effectivement les comptes désactiver ne sont pas copier il vous faudra donc supprimer touts les comptes du UPS (plutôt que de supprimer UPS) et relancer un synchro

    cela devrais fonctionner. On attend de vos nouvelles

    Moncef

    • Marqué comme réponse fred_mantes jeudi 10 octobre 2013 10:59
    jeudi 10 octobre 2013 10:16

Toutes les réponses

  • bonjour

    Pourriez vous svp, faire une copie d ecran de vos filtre et nous les partager.

    d apres votre description cela devrais fonctionner.... mais ...

    Merci

    Salutations

    Moncef Maloum

    mercredi 9 octobre 2013 14:14
  • Avez-vous deja fait un FULL import avant d'apliquer les filtres UserAccountControl equal 2?

    Si c'est oui; il faudrait supprimer le User Profile Service Application; le recréer; PAS d'import; Impliquer vos filtres; PUIS Importer..

    Courage,

    Gokan


    My Technical Blog on Wordpress


    jeudi 10 octobre 2013 06:36
  • Bonjour,

    D'abord merci pour vos réponses.

    Voici les filtres : 

    Attribute Operator Filter
    employeeID Is not present  
    employeeID Starts with 0
    employeeID Starts with 1
    employeeID Starts with 2
    employeeID Starts with 3
    employeeID Starts with 4
    employeeID Starts with 5
    employeeID Starts with 6
    employeeID Starts with 7
    employeeID Starts with 8
    employeeID Starts with 9
    userAccountControl Bit on equals 514
    userAccountControl Bit on equals 2

    Tous les opérateurs sont OR.

    Il y a effectivement eu une synchro avant les l'applications des filtres. Il n'y a pas d'autres moyen que de tout supprimer ? Il y a eu un gros travail sur les userProperties et ça serait sympa d'éviter de tout refaire.

    Autre question, si un utilisateur se trouvant dans une OU prise en compte dans ma connexion est déplacé dans une OU qui n'est pas prise en compte, comment est-ce gérer ?

    Merci pour tout !

    jeudi 10 octobre 2013 07:41
  • Vous ne devais pas utiliser Bit on equals 514, 514 correspond a la valeur du masque du compte pour 512 (compte normal) + 2 (compte désactiver), cependant l intérêt de l opérateur Bit On equal est de permettre de vérifier letat de 2ieme bit, et dans le cas d un compte désactiver (quelque soit les spécificité du compte)  est toujours égale a 1, donc logiquement vous devez utiliser Bit On equal  2 uniquement pour définir tout les compte désactiver.donc a partir de la je ne vois que 2 options:

    1/ je vous conseil de supprimer et recrée tout vos filtres, car par default les opérateurs joignant plusieurs filtres sont des AND, une fois crée il n ya aucun moyen de vérifier si vous avez utiliser des AND ou des OR, donc refaites le en pensant a bien contrôler cette étape.

    2/si ca ne marche pas alors il faudra essayer comme proposer par Gokan, effectivement de mémoire il me semble que les comptes filtres ne sont pas supprimer d une base existant mais juste ignorer ...(pas tout a fait sur, Gokan peux tu apporter quelques détails STP)

    Merci

    jeudi 10 octobre 2013 09:31
  • Effectivement le Bit on equals 514 ne sert à rien, je vais le supprimer.

    Je vais tenter de supprimer tous les filtres et de les recréer au cas où.

    Est-ce-qu'il est préférable d'inclure l'OU où sont stocker les utilisateurs supprimés et de les gérer par filtre ? J'ai peur que le déplacement dans une OU qui n'est pas dans ma connexion ne soit pas gérer comme des utilisateurs à supprimer de la base de profil.

    Cordialement

    • Marqué comme réponse fred_mantes jeudi 10 octobre 2013 10:59
    • Non marqué comme réponse fred_mantes jeudi 10 octobre 2013 10:59
    jeudi 10 octobre 2013 09:48
  • a votre place j essaierais d abord en incluant le OU ou sont déplacer les compte supprimer.

    ensuite vous pourriez par exemple supprimer quelque compte du UPSa la main (des compte actif et 1 ou 2 compte désactiver), puis vous relancer votre synchro avec les filtres, et si effectivement les comptes désactiver ne sont pas copier il vous faudra donc supprimer touts les comptes du UPS (plutôt que de supprimer UPS) et relancer un synchro

    cela devrais fonctionner. On attend de vos nouvelles

    Moncef

    • Marqué comme réponse fred_mantes jeudi 10 octobre 2013 10:59
    jeudi 10 octobre 2013 10:16
  • J'ai supprimé le filtre Bit on equals 514, j'ai rajouté l'OU dans la connexion et supprimé quelques comptes inactifs. Ils n'ont pas été rajoutés par la synchro donc je pense qu'effectivement je vais devoir les faire à la main.

    Merci pour votre aide

    jeudi 10 octobre 2013 10:58
  • Bonjour à Tous

    @Gokan : ta proposition va bien dans un contexte de EV mais est c'est quand même un peu la bombe atomique pour tuer des souris , et en situation de PROD c'est juste inacceptable !

    @fred (et @moncef) : le service UPS marque les comptes inactifs dans son système quand :

    • le compte est importé de l'AD alors qu'il est déjà inactif
    • le compte a été importé à un moment donné comme actif, puis à été "manquant" dans l'A.D. ou marqué inactif dans l'AD

    Dans la seconde situation, l'UPS garde "la trace " de ce compte pendant les 3 prochaines synchros ! (je vous dit ça de mémoire, je ne sais plus exactement si c'est 3 ou 4 mais c'est sur il les gardent un certain temps... pour plus de détails voir harbar.net LE gourou de l'UPS)

    Donc je pense que votre filtre est bon, les utilisateurs auraient fini par être supprimé au bout de quelques synchro...

    Pour la petite histoire, ça marche comme ça parceque il y a un process de réattribution du MySite de l'utilisateur qui viens d'etre desactivé, pour permettre de notifier son manager, de lui donner les droits d'admin et d'avoir le temps de récupérer le contenu du MySite de la personne qui a par exemple quitté l'entreprise.


    Blog Sharepoint : www.paslatek.net Twitter : @LimozinLionel

    • Proposé comme réponse lionel limozin vendredi 11 octobre 2013 16:06
    vendredi 11 octobre 2013 16:06