none
Populate newsfeed

    Question

  • Hi 

    Sometimes I've to populate the newsfeed - but on 2 users I get the error:

    Update-SPRepopulateMicroblogFeedCache : Repopulation failed. Please check logs for error

    at NewsFeedpopulate.ps1:24 char:9

    .......................

    foreach ($oUser in $Profiles ) {
        if ($oUser.item("SPS-PersonalSiteCapabilities").Value -eq 14 ){
            $personalurl = $url + $oUser.item("personalspace").Value
            Write-Host $oUser.item("AccountName").Value
            Update-SPRepopulateMicroblogFeedCache -ProfileServiceApplicationProxy $proxy -accountname $oUser.item("AccountName").Value 

    ....................

    It runs on everybody else 

    when I look in the log I only see this:

    MicroBlogList.GetMicroBlogPostsForRePopulation http://mysite/personal/<user1>/ Repop query returns 10 items, created 10 entity posts, 10 co-feed posts, 0 reply ref-posts, 18 tag ref-posts, 0 rollup-posts, total 38 cache entries

    I've checked the Personal Site Capabilities is set to 14 and the feed service provider on the 2 profiles and it looks fine

    Can anyone assist? 

    lundi 10 avril 2017 05:25

Réponses

  • Still 1 user (have +400 in the microfeed list) giving error

    also tried to set this: 

    $upa = Get-SPServiceApplication | where {$_.TypeName -Like "User Profile Service Application"}
    $upa.FeedCacheTTLHours=1200
    $upa.FeedCacheLastModifiedTimeTtlDeltaHours=1200
    $upa.FeedCacheObjectCountLimit=200000
    $upa.FeedCacheRoomForGrowth=2000
    $upa.Update()
    • Modifié JmATK jeudi 27 avril 2017 09:09
    • Marqué comme réponse JmATK lundi 1 mai 2017 05:44
    jeudi 27 avril 2017 09:03

Toutes les réponses