none
Probleme avec OWA sur Exchange 2010 RRS feed

  • Discussion générale

  • Bonjour; voila suite à un P2V de mon serveur Exchange 2010, je ne peux plus y accéder en OWA. Sinon le serveur fonctionne très bien les mails entre et sortant sans problème, j'ai essayé la commande Setup.com /m:RecoverServer, mais je pense qu'il me manque des informations à renseigner sur cette commande.

    Je pense qu'il faut republier owa dans IIS mais la je n'y connais rien. Exchange est installé sur un serveur 2008 R2 Enterprise (en vitrtualisation via HYPER V)

    J’en appel à votre aide, merci d’avance

     


    Anthony - MCP
    lundi 18 octobre 2010 09:31

Toutes les réponses

  • Bonjour,

    je te propose d'exécuter  Test-servicehealth |fl   un Test-OwaConnectivity et un Test-OutlookWebServices

     

     

    Test-OwaConnectivity -URL:https://mail.contoso.com/owa

     

    Test-OutlookWebServices –Identity neil@neilhobson.com | fl

    merci de poster le résultat pour qu'on puisse t'aider

     

    khalil


    ----------- Merci Khalil Benz [MCSE - MCTS 2008 - MCTS ISA- MCT]
    mardi 19 octobre 2010 15:48
  • Bonjour, desolé pour le retard alors j ai effectué les testes (en esperant que je les ai bien executé)

    [PS] C:\Windows\system32>Test-servicehealth |fl


    Role                    : Rôle serveur de boîtes aux lettres
    RequiredServicesRunning : True
    ServicesRunning         : {IISAdmin, MSExchangeADTopology, MSExchangeIS, MSExchangeMailboxAssistants, MSExchangeMailSub
                              mission, MSExchangeRepl, MSExchangeRPC, MSExchangeSA, MSExchangeSearch, MSExchangeServiceHost
                              , MSExchangeThrottling, MSExchangeTransportLogSearch, W3Svc, WinRM}
    ServicesNotRunning      : {}

    Role                    : Rôle serveur Client Access
    RequiredServicesRunning : False
    ServicesRunning         : {IISAdmin, MSExchangeADTopology, MSExchangeFBA, MSExchangeFDS, MSExchangeIMAP4, MSExchangeMai
                              lboxReplication, MSExchangePOP3, MSExchangeProtectedServiceHost, MSExchangeRPC, MSExchangeSer
                              viceHost, W3Svc, WinRM}
    ServicesNotRunning      : {MSExchangeAB}

    Role                    : Rôle serveur de transport Hub
    RequiredServicesRunning : True
    ServicesRunning         : {IISAdmin, MSExchangeADTopology, MSExchangeEdgeSync, MSExchangeServiceHost, MSExchangeTranspo
                              rt, MSExchangeTransportLogSearch, W3Svc, WinRM}
    ServicesNotRunning      : {}

    [PS] C:\Windows\system32>Test-OutlookWebServices -Identity anthony@ans-informatique.fr | fl


    RunspaceId : c672210d-b0e5-4450-8af5-1c5ccfaa2317
    Id         : 1019
    Type       : Information
    Message    : Un point de connexion de service AutoDiscover valide a été trouvé. L'URL AutoDiscover sur cet objet est ht
                 tps://SRV-MESSAGERIE.anstimas.local/Autodiscover/Autodiscover.xml.

    RunspaceId : c672210d-b0e5-4450-8af5-1c5ccfaa2317
    Id         : 1013
    Type       : Error
    Message    : Réception de l'erreur La connexion sous-jacente a été fermée : Une erreur inattendue s'est produite lors d
                 e l'envoi. lors du contact de https://SRV-MESSAGERIE.anstimas.local/Autodiscover/Autodiscover.xml.

    RunspaceId : c672210d-b0e5-4450-8af5-1c5ccfaa2317
    Id         : 1013
    Type       : Error
    Message    : Réception de l'erreur Impossible de lire les données de la connexion de transport : Une connexion existant
                 e a dû être fermée par l'hôte distant. lors du contact de https://SRV-MESSAGERIE.anstimas.local/Autodiscov
                 er/Autodiscover.xml.

    RunspaceId : c672210d-b0e5-4450-8af5-1c5ccfaa2317
    Id         : 1013
    Type       : Error
    Message    : Réception de l'erreur Une connexion existante a dû être fermée par l'hôte distant lors du contact de https
                 ://SRV-MESSAGERIE.anstimas.local/Autodiscover/Autodiscover.xml.

    RunspaceId : c672210d-b0e5-4450-8af5-1c5ccfaa2317
    Id         : 1023
    Type       : Error
    Message    : Impossible de contacter le service de découverte automatique.

    RunspaceId : c672210d-b0e5-4450-8af5-1c5ccfaa2317
    Id         : 1013
    Type       : Error
    Message    : Réception de l'erreur La connexion sous-jacente a été fermée : Une erreur inattendue s'est produite lors d
                 e l'envoi. lors du contact de https://srv-messagerie.anstimas.local/EWS/Exchange.asmx.

    RunspaceId : c672210d-b0e5-4450-8af5-1c5ccfaa2317
    Id         : 1013
    Type       : Error
    Message    : Réception de l'erreur Impossible de lire les données de la connexion de transport : Une connexion existant
                 e a dû être fermée par l'hôte distant. lors du contact de https://srv-messagerie.anstimas.local/EWS/Exchan
                 ge.asmx.

    RunspaceId : c672210d-b0e5-4450-8af5-1c5ccfaa2317
    Id         : 1013
    Type       : Error
    Message    : Réception de l'erreur Une connexion existante a dû être fermée par l'hôte distant lors du contact de https
                 ://srv-messagerie.anstimas.local/EWS/Exchange.asmx.

    RunspaceId : c672210d-b0e5-4450-8af5-1c5ccfaa2317
    Id         : 1025
    Type       : Error
    Message    : [EXCH] Erreur lors du contact du service AS à https://srv-messagerie.anstimas.local/EWS/Exchange.asmx. Le
                 temps écoulé était de 2 millisecondes.

    RunspaceId : c672210d-b0e5-4450-8af5-1c5ccfaa2317
    Id         : 1013
    Type       : Error
    Message    : Réception de l'erreur La connexion sous-jacente a été fermée : Une erreur inattendue s'est produite lors d
                 e l'envoi. lors du contact de https://srv-messagerie.anstimas.local/EWS/Exchange.asmx.

    RunspaceId : c672210d-b0e5-4450-8af5-1c5ccfaa2317
    Id         : 1013
    Type       : Error
    Message    : Réception de l'erreur Impossible de lire les données de la connexion de transport : Une connexion existant
                 e a dû être fermée par l'hôte distant. lors du contact de https://srv-messagerie.anstimas.local/EWS/Exchan
                 ge.asmx.

    RunspaceId : c672210d-b0e5-4450-8af5-1c5ccfaa2317
    Id         : 1013
    Type       : Error
    Message    : Réception de l'erreur Une connexion existante a dû être fermée par l'hôte distant lors du contact de https
                 ://srv-messagerie.anstimas.local/EWS/Exchange.asmx.

    RunspaceId : c672210d-b0e5-4450-8af5-1c5ccfaa2317
    Id         : 1027
    Type       : Error
    Message    : [EXCH] Erreur lors du contact du service UM à https://srv-messagerie.anstimas.local/EWS/Exchange.asmx. Le
                 temps écoulé était de 2 millisecondes.

    RunspaceId : c672210d-b0e5-4450-8af5-1c5ccfaa2317
    Id         : 1113
    Type       : Error
    Message    : Réception de l'erreur La connexion sous-jacente a été fermée : Une erreur inattendue s'est produite lors d
                 e l'envoi. lors du contact de https://srv-messagerie.anstimas.local/ews/exchange.asmx.

    RunspaceId : c672210d-b0e5-4450-8af5-1c5ccfaa2317
    Id         : 1113
    Type       : Error
    Message    : Réception de l'erreur Impossible de lire les données de la connexion de transport : Une connexion existant
                 e a dû être fermée par l'hôte distant. lors du contact de https://srv-messagerie.anstimas.local/ews/exchan
                 ge.asmx.

    RunspaceId : c672210d-b0e5-4450-8af5-1c5ccfaa2317
    Id         : 1113
    Type       : Error
    Message    : Réception de l'erreur Une connexion existante a dû être fermée par l'hôte distant lors du contact de https
                 ://srv-messagerie.anstimas.local/ews/exchange.asmx.

    RunspaceId : c672210d-b0e5-4450-8af5-1c5ccfaa2317
    Id         : 1125
    Type       : Error
    Message    : [Server] Erreur lors du contact du service AS à https://srv-messagerie.anstimas.local/ews/exchange.asmx. L
                 e temps écoulé était de 2 millisecondes.

    RunspaceId : c672210d-b0e5-4450-8af5-1c5ccfaa2317
    Id         : 1113
    Type       : Error
    Message    : Réception de l'erreur La connexion sous-jacente a été fermée : Une erreur inattendue s'est produite lors d
                 e l'envoi. lors du contact de https://srv-messagerie.anstimas.local/ews/exchange.asmx.

    RunspaceId : c672210d-b0e5-4450-8af5-1c5ccfaa2317
    Id         : 1113
    Type       : Error
    Message    : Réception de l'erreur Impossible de lire les données de la connexion de transport : Une connexion existant
                 e a dû être fermée par l'hôte distant. lors du contact de https://srv-messagerie.anstimas.local/ews/exchan
                 ge.asmx.

    RunspaceId : c672210d-b0e5-4450-8af5-1c5ccfaa2317
    Id         : 1113
    Type       : Error
    Message    : Réception de l'erreur Une connexion existante a dû être fermée par l'hôte distant lors du contact de https
                 ://srv-messagerie.anstimas.local/ews/exchange.asmx.

    RunspaceId : c672210d-b0e5-4450-8af5-1c5ccfaa2317
    Id         : 1127
    Type       : Error
    Message    : [Server] Erreur lors du contact du service UM à https://srv-messagerie.anstimas.local/ews/exchange.asmx. L
                 e temps écoulé était de 1 millisecondes.

    La commande Test-OwaConnectivity je pense que je ne l utilise pas correctement

    [PS] C:\Windows\system32>Test-OwaConnectivity -URL:https://srv-messagerie/owa

    Demande d'informations d'identification Windows PowerShell applet de commande Test-OwaConnectivity à la position 1 du
    pipeline de la commande
    Avertissement : un script ou une application sur l'ordinateur distant SRV-MESSAGERIE.ANSTIMAS.LOCAL demande ces
    informations d'identification. Entrez-les seulement si vous faites confiance à l'ordinateur distant et à l'application
    ou au script en faisant la demande.

    Fournissez des valeurs pour les paramètres suivants :
    MailboxCredential

    Impossible de traiter la commande, car un ou plusieurs paramètres obligatoires sont absents :  MailboxCredential.
        + CategoryInfo          : InvalidArgument: (:) [Test-OwaConnectivity], ParameterBindingException
        + FullyQualifiedErrorId : MissingMandatoryParameter,Test-OwaConnectivity

     


    Anthony - MCP
    vendredi 22 octobre 2010 09:37
  • Bonjour,

     

    déja tu as un service qui n'est pas démarré MSExchangeAB, il faut le démarrer

    net start MSExchangeAB quand tu fait  https://srv-messagerie.anstimas.local/OWA  , qu'est ce que tu as comme message ?

     

    pour la commande voici la syntaxe à suivre :

    Test-OwaConnectivity -URL:https://mail.domain.com/owa -MailboxCredential:(get-credential domain\khalil )

    A+

    Khalil


    ----------- Merci Khalil Benz [MCSE - MCTS 2008 - MCTS ISA- MCT]

    vendredi 22 octobre 2010 09:58
  • D’abord merci pour ton aide

    Donc j ai démarré le service

    Quand je tape cette URL https://srv-messagerie.anstimas.local/OWA j obtiens qu’il ne puisse pas afficher cette page

    Si je tape http://srv-messagerie.anstimas.local/OWA/ j obtiens :

     

    Erreur de serveur

    <fieldset>

    403 - Interdit : accès refusé.

    Vous n'avez pas l'autorisation d'afficher ce répertoire ou cette page à l'aide des informations d'identification que vous avez fournies.

    </fieldset>

    j ai vraiment l impression d'avoir un probleme de publication IIS

    [PS] C:\Windows\system32>Test-OwaConnectivity -URL:https://srv-messagerie/owa -MailboxCredential:(get-credential anstima
    s\administrateur)
    AVERTISSEMENT : Le test n'a pas pu établir de connexion avec Outlook Web App.

    ClientAccessServer MailboxServer URL                     Scenario Result  Latency Error
                                                                               (ms)
    ------------------ ------------- ---                     -------- ------  ------- -----
                                     https://srv-messager... Ouver... Échec           Le tes...

    ca marche mieux comme ca la commande :)


    Anthony - MCP
    vendredi 22 octobre 2010 10:24
  • re Bonjour

    • Quand tu tapes l'URL , .est ce que la machine sur laquelle tu fais le test appartient au domaine? si c'est pas le cas est ce que tu as une pop up authentification , il faut mettre Domain\login ensuite le mot de passe
    • Verifie que l'horloge du serveur Exchange est synchronisé avec les controleurs de domaines ainsi que l'horloge du poste client Par défaut, la différence de temps autorisée est de cinq minutes. L'authentification échoue si la différence d'heure dépasse cinq minutes.
    • Regarde les proprietés de la boite aux lettres si OWA est activé ou non tu peux utiliser la cmdlet pour activer OWA 

                Set-CASMailBox -Identity Khalil@domain.com -OWAEnable $true

    voila pour commencer

    merci

    Khalil

     

     


    ----------- Merci Khalil Benz [MCSE - MCTS 2008 - MCTS ISA- MCT]
    vendredi 22 octobre 2010 10:58
  • re

    Alors pour commencer un petit rappel :

    Avant de faire mon P2V mon OWA fonctionnait

    Je peux te dire aussi que la machine sur laquelle à été fait le test est sur le serveur lui même et aussi sur une machine au domaine, il n y a pas de pop up authentification, mon serveur est à l heure et se synchronise avec mon DC, tout mon parce que info est à l heure.

    L'OWA est bien actif sur mes comptes


    Anthony - MCP
    vendredi 22 octobre 2010 13:39
  • Bonjour

     

    peut tu vérifier que l'authentification Intégrée est activé sur le repertoire virtuel OWA

    Exchange 2007 SP1

     Utilisation d'Exchange Management Console pour configurer l'authentification intégrée Windows pour Outlook Web Access
    1. Dans la console de gestion Exchange, localisez le répertoire virtuel à configurer pour utiliser l'authentification Windows intégrée à l'aide des informations de l'étape 2 ou 3.

    2. Si vous exécutez le rôle serveur de boîtes aux lettres sur l'ordinateur exécutant le rôle serveur d'accès au client, procédez comme suit :

      • Pour modifier un répertoire virtuel Exchange 2007, sélectionnez Configuration du serveur, Accès au client, puis cliquez sur l'onglet Outlook Web Access. Le répertoire virtuel Exchange 2007 par défaut est /owa.
      • Pour modifier un répertoire virtuel hérité, sélectionnez Configuration du serveur, Boîtes aux lettres, puis cliquez sur l'onglet WebDAV. Les répertoires virtuels hérités par défaut sont les suivants : /Public, /Exchweb, /Exchange et /Exadmin.
    3. Si vous n'exécutez pas le rôle serveur de boîtes aux lettres sur l'ordinateur exécutant le rôle serveur d'accès au client, sélectionnez Configuration du serveur, Accès au client, puis cliquez sur l'onglet Outlook Web Access.

    4. Dans le volet Travail, sélectionnez le répertoire virtuel à configurer pour utiliser l'authentification Windows intégrée, puis cliquez sur Propriétés.

    5. Cliquez sur l'onglet Authentification.

    6. Sélectionnez Utiliser une ou plusieurs des méthodes d'authentification standard.

    7. Cliquez sur Authentification intégrée Windows.

    8. Cliquez sur OK.

    Sinon tu peux le faire avec le PowerShell :

    Set-OwaVirtualDirectory -Identity "owa (Site Web par défaut)" -WindowsAuthentication $true

     

    A+

    Khalil


    ----------- Merci Khalil Benz [MCSE - MCTS 2008 - MCTS ISA- MCT]
    vendredi 22 octobre 2010 13:57
  • j ai essayé mais ca ne fonctionne pas non plus j ai redemarré le serveur car quand je tape la commande iisreset /noforce j ai une erreur :

    [PS] C:\Windows\system32>iisreset /noforce

    Tentative d'arrêt en cours...
    Échec de la tentative de redémarrage.
    Le service n'a pas répondu assez vite à la demande de lancement ou de contrôle. (2147943453, 8007041d)

    je sens de plus en plus que mon IIS est en vraque à cause du P2V

    Merci pour ton aide en tout cas


    Anthony - MCP
    vendredi 22 octobre 2010 14:41
  • Peut tu verifier que le certificat est encore valide ?

    as tu des erreurs dans le journal d'evenements ?

     sinon il faut penser à reinstaller IIS et le rôle CAS , en dernier lieu .

    Merci

    Khalil


    ----------- Merci Khalil Benz [MCSE - MCTS 2008 - MCTS ISA- MCT]
    vendredi 22 octobre 2010 15:23
  • Bonjour,

    Désolé pour le retard,

    Alors voici les erreurs dans le journal de IIS :

    Problème :

    Le pool d’applications « MSExchangePowerShellAppPool » est configuré pour s’exécuter en tant qu’administrateur, en tant que système local ou pour « Agir en tant que partie du système d’exploitation ».

    Impact :

    Le pool d’applications peut exécuter du code à privilèges élevés, y compris du code potentiellement malveillant, susceptible de perturber le fonctionnement de votre serveur.

    Résolution :

    Configurez le pool d’applications pour qu’il s’exécute sous sa propre identité.

    Problème :

    L’authentification de base est activée pour le chemin de configuration « MACHINE/WEBROOT/APPHOST », mais il lui manque une liaison SSL requise.

    Impact :

    Si vous utilisez l’authentification de base sans SSL, les informations d’identification sont envoyées en clair et risquent d’être interceptées par un code malveillant.

    Résolution :

    Utilisez l’authentification de base avec une liaison SSL et assurez-vous que l’application ou le site est configuré pour exiger SSL. Vous pouvez aussi utiliser une autre méthode d’authentification.

    Parcontre je ne sais pas aller vérifier si le certificat est encore valide.

    Merci pour ton aide


    Anthony - MCP
    jeudi 28 octobre 2010 14:34