none
Exchange Authentification sous Windows XP ou Seven RRS feed

  • Discussion générale

  • Bonjour,

    Je travaille acutellement sur un Exchange 2007 basé sur un server2008 avec un certificat valide et l'autodiscover activé.

    Je n'ai aucun souci pour synchroniser un compte exchange via Outlook 2007 sous Seven, mais lorsque je fais les mêmes manips sous XP, j'ai la fenêtre d'authentification au serveur qui revient en permanence et je ne peux pas continuer.

    J'ai vérifié les droits d'authentification au niveau du IIS (Windows authentification activée sans le mode kernerl) ; qu'est ce qui pourrait différer entre les deux OS ?

    Merci d'avance pour vos idées.

    mercredi 18 août 2010 11:49

Toutes les réponses

  • Bonjour,

    Le problème se pose uniquement en externe avec Outlook Anywhere, ou avez-vous la même chose en interne ?

     


    http://laubel.wordpress.com/
    mercredi 18 août 2010 16:44
  • Bonsoir,

    Uniquement en externe : en interne aucun souci pour synchro les comptes sous n'importe quel OS et de n'importe quelle manière.

    mercredi 18 août 2010 21:30
  • Donc voir la solution déjà donnée :

    http://social.technet.microsoft.com/Forums/fr-FR/1109/thread/fd8288a5-fa26-4fb6-a68b-da19fbb83cce

    Vous devez avoir le CN du certificat qui ne correspond pas à votre URL de connexion.


    http://laubel.wordpress.com/
    jeudi 19 août 2010 06:38
  • Bonjour,

    Oui, j'ai bien vu ceci du coup, j'ai tenté de changer comme expliqué, de nouveau, et là plus rien même sous seven : message d'erreur concernant le proxy et fenêtre d'authentification permanente.

    Pour info, j'ai un scertificat multisite et la commande que je tape est :

    Set-OutlookProvider EXPR -Server $null -CertPrincipalName msstd:exchange.company.fr

    Sachant que le CN de mon certificat est company (tout court), j'ai aussi essayé :

    Set-OutlookProvider EXPR - Server $null -CertPrincipalName company

     

    Pour info, les autre comandes actuelles que j'avais tapées sont :

    Set-OutlookProvider EXCH -Server "HOSTNAMElocal" -CertPrincipalName "HOSTNAMElocal" (il est compris dans mon certificat multi domaines)

    Set-OutlookProvider WEB -Server "exchange.company.fr" -CertPrincipalName "HOSTNAMElocal" exchange.company.fr

    jeudi 19 août 2010 13:15
  • Bonjour,

    Oulà vous êtes très éloigné des recommendations :o)

    Le CN doit correspondre au nom de connexion externe d'OA. A défaut il faut modifier le provider EXPR pour le faire correspondre avec un autre nom présent dans le certificat.

    Faites un Get-OutlookAnywhere |fl

    Faites un Get-outlookprovider expr | fl

    Faites un Get-ExchangeCertificate | fl

    Indiquez nous les résultats


     

     

     

     


    http://laubel.wordpress.com/
    jeudi 19 août 2010 13:46
  • Bonsoir,

    Voici les get demandés :

    Anywhere:

     

    ServerName                 : LocalName
    SSLOffloading              : True
    ExternalHostname           : exchange.company.fr
    ClientAuthenticationMethod : Ntlm
    IISAuthenticationMethods   : {Ntlm}
    MetabasePath               : IIS://LocalName.LocalDomain/W3SVC/1/ROOT/Rpc
    Path                       : C:\Windows\System32\RpcProxy
    Server                     : LocalName
    AdminDisplayName           :
    ExchangeVersion            : 0.1 (8.0.535.0)
    Name                       : Rpc (Default Web Site)
    DistinguishedName          : CN=Rpc (Default Web Site),CN=HTTP,CN=Protocols,CN=LocalName,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=Company-Org,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=LocalDomain,DC=LocalDomain
    Identity                   : LocalName\Rpc (Default Web Site)
    Guid                       : b652eaa8-6b86-433a-8c3a-3be076f86170
    ObjectCategory             : LocalDomain/Configuration/Schema/ms-Exch-Rpc-Http-Virtual-Directory
    ObjectClass                : {top, msExchVirtualDirectory, msExchRpcHttpVirtualDirectory}
    WhenChanged                : 05/08/2010 22:21:12
    WhenCreated                : 09/10/2008 14:46:31
    OriginatingServer          : ADname.LocalDomain
    IsValid                    : True

    Provider

     

    CertPrincipalName : msstd:exchange.company.fr
    Server            :
    TTL               : 1
    AdminDisplayName  :
    ExchangeVersion   : 0.1 (8.0.535.0)
    Name              : EXPR
    DistinguishedName : CN=EXPR,CN=Outlook,CN=AutoDiscover,CN=Client Access,CN=Company-Org,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=LocalDomain,DC=LocalDomain
    Identity          : EXPR
    Guid              : 70f92e73-4f25-423a-8200-577b3ab82667
    ObjectCategory    : LocalDomain/Configuration/Schema/ms-Exch-Auto-Discover-Config
    ObjectClass       : {top, msExchAutoDiscoverConfig}
    WhenChanged       : 19/08/2010 14:24:37
    WhenCreated       : 08/10/2008 17:01:11
    OriginatingServer : ADname.LocalDomain
    IsValid           : True

    Certificate

     

    AccessRules        : {System.Security.AccessControl.CryptoKeyAccessRule, System.Security.AccessControl.CryptoKeyAccessRule, System.Security.AccessControl.CryptoKeyAccessRule}
    CertificateDomains : {LocalName.LocalDomain, autodiscover.company.fr, autodiscover.company2.com, autodiscover.company3.com, exchange.company.fr, exchange.company2.com, exchange.company3.com, mail.company.fr, mail.company2.com, mail.company3.com, company.fr, company2.com, company3.com, webmail.company.fr, webma
                         il.company2.com, webmail.company3.com}
    HasPrivateKey      : True
    IsSelfSigned       : False
    Issuer             : CN=TBS X509 CA pro hosting, OU=TBS INTERNET CA, OU=Terms and Conditions: http://www.tbs-internet.com/CA/repository, O=TBS INTERNET, L=Caen, S=Calvados, C=FR
    NotAfter           : 01/01/2011 01:59:59
    NotBefore          : 01/01/2010 02:00:00
    PublicKeySize      : 2048
    RootCAType         : Unknown
    SerialNumber       : XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
    Services           : IMAP, POP, IIS, SMTP
    Status             : Invalid
    Subject            : CN=Company Complete Name, OU=0002 503511420, O=Company Complete Name, STREET=Comapny adress1, STREET=Company adress2, L=CompanyCity, S=CompanyRegion, PostalCode=CompanyCode, C=FR, CN=LocalName.LocalDomain, CN=autodiscover.company.fr, CN=autodiscover.company2.com, CN=autodiscover.company3.com, CN=exchange.company.fr, CN=exch
                         ange.company2.com, CN=exchange.company3.com, CN=mail.company.fr, CN=mail.company2.com, CN=mail.company3.com, CN=company.fr, CN=company2.com, CN=company3.com, CN=webmail.company.fr, CN=webmail.company2.com, CN=webmail.company3.com, CN=Company Complete Name
    Thumbprint         : XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

    J'ai modifié la fin des noms de domaines, si l'on peut résoudre mon souci ensemble tel quel cela m'arrangerait, sinon tant pis, je mettrais exactement les résultats des commandes.

    A savoir que company = subdomain.domain.fr

    Encore merci pour les réponses.

    jeudi 19 août 2010 15:52
  • ExternalHostname           : exchange.company.fr -> OK

    CertPrincipalName : msstd: exchange.company.fr -> OK

    Par contre je vois que le statut du certificat est invalide ?? Autre point : le type d'authentification qui est en NTLM, vous pouvez tester le comportement en BASIC ?

     

     

     

     

     


    http://laubel.wordpress.com/
    jeudi 19 août 2010 16:56
  • Bonsoir,

    Oui, j'ai déjà essayé en BASIC et il s'avère que la fenêtre d'authentification s'affiche en permanence, même sous Seven.

    Pour le certificat, j'ai remarqué la même chose en faisant l'extract, mais je n'ai aucune idée du pourquoi. J'ai d'autre certificats sur le serveur : des anciens qui ne sont donc plus actifs (7 ou 8), mais je ne pense pas que cela vienne de là.

    J'avais importé le certificat, il y a plusieurs mois avec la commande :

    Import-ExchangeCertificate -Path c:\xxxxxxxxxxxxxxx.p7b | Enable-ExchangeCertificate -Services "SMTP, IMAP, POP, IIS"

    jeudi 19 août 2010 17:30
  • Bonjour,

    Validez le certificat en faisant un test de connexion depuis l'outil en ligne : https://www.testexchangeconnectivity.com/

    Choisir le test Outlook Anywhere.

    Merci

     


    http://laubel.wordpress.com/
    vendredi 20 août 2010 06:42
  • Bonjour,

    Voici le résultat :

    SSL mutual authentication with the RPC proxy server is being tested.

    Verification of mutual authentication failed.

    Additional Details

    The certificate common name CompanyName, doesn't validate against Mutual Authentication string provided msstd:exchange.company.fr

    vendredi 20 août 2010 12:44
  • Ok

    Pour résumer : la configuration de votre certificat n'est pas correcte, par contre le fait de changer la configuration du provider devrait permettre de contourner le problème.

    Vous avez qu'elle version de SP sur Windows XP ? il faut le SP2 au minimum ?

     


    http://laubel.wordpress.com/
    vendredi 20 août 2010 12:57
  • Bonjour,

    Windows XP est en SP3.

    vendredi 20 août 2010 14:00
  • Bonjour,

    De quelle manière pourrait on configurer le provider autrement pour contourner ?

    lundi 23 août 2010 07:47
  • La configuration du Provider est une solution de contournement. Si cela ne résout pas le soucis il faut résoudre le problème directement en reconfigurant correctement votre certificat, pour faire correspondre votre CN avec le nom de connexion OA.
    http://laubel.wordpress.com/
    mardi 24 août 2010 07:52
  • Bonjour,

    Au final, le souci a été trouvé : notre fournisseur s'est trompé de type de certificat et d'autorité de certification.

    Je vous referais un up avec le nouveau, si le problème est résolu.

    jeudi 26 août 2010 16:54
  • Bonsoir,

     

    Le souci a bien été résolu : notre founisseur avait commis une erreur entre un multisites et un COMODO SAN.

     

    lundi 30 août 2010 17:31
  • Bonjour,

    J'ai exactement le même problème mais sur un poste Windows Xp Pro. avec Outlook 2007.  Le poste est dans le domaine.  Mon serveur Exchange eest un 2010.

    Sur le poste Windows 2007 Pro., je n'ai pas de problème de création de profil.  je suis capable de configurer le profil Outlook et d'envoyer et recevoir les courriels.

    Sur le poste de Windows Xp, il m'afficher tout le temps la fenêtre :

    Connecter à Exchange.mondomain

    Connexion à ExchangeDAG1.mondomain

    Nom Utilisateur :

    Mot de passe :

    Mais quand je rentre les informations, il ne peut pas valider.

    Avez vous des sugestion.

     

    Merci.

    Tu Tam.

    vendredi 8 octobre 2010 14:34