locked
Ma plateforme web - Internet Information Services - Apprendre à gérer son serveur web RRS feed

  • Discussion générale

  • Bonjour à tous,

    Voici le forum officiel "Ma plateforme web" consacré au projet "Apprendre à gérer son serveur web grâce à Windows Server 2008 R2".

    Posez dans cet espace toutes vos questions, suggestions ou remarques liées à ce projet web et nous essaierons d'y répondre dans les meilleurs délais.

    Et n'oubliez pas, pour débuter, une seule adresse : www.maplateformeweb.com

    Merci à tous.

    Jonathan et Ségolène pour l'équipe web Microsoft (web_fr@microsoft.com)

    mercredi 3 mars 2010 10:24

Toutes les réponses

  • Donc je repose ma question:
     
    J'ai perdu mon mot de passe de session administrateur apres l'avoir changer (probablement parce que je suis sur un clavier qwerty).

    Comment faire pour reinistialiser mon mot de passe administrateur? Est-ce que c'est possible ?
    jeudi 4 mars 2010 00:37
  • Bonjour Baptiste M,

    Pour toute question liée à l'accès à votre serveur, vous pouvez continuer à utiliser le forum d'entraide général. Privilégiez ce forum pour toute question liée au scénario même.

    Afin de vous aider, il faudrait que vous nous fournissiez l'identifiant de votre serveur. Il s'agit d'un nombre à 4 chiffres, information disponible depuis votre console d'administration. J'ai détaillé la procédure de façon plus explicite dans le forum d'entraide général.

    Merci beaucoup.

    Cordialement,

    Jonathan (web_fr@microsoft.com)
    jeudi 4 mars 2010 17:36
  • bonjour

    j'aimerais savoir ou declaré un ftp pour mettre les dossiers web en ligne

    cordialement
    samedi 6 mars 2010 15:50
  • Bonjour epsylon999

    Pour utiliser le serveur FTP de Windows Server 2008 R2, il faut aller dans le gestionnaire de serveur, dans le rôle IIS, il y a des services de rôle à ajouter pour FTP.

    Cordialement,
    Ségolène Hémar, de l'équipe web Microsoft (web_fr@microsoft.com)
    mardi 9 mars 2010 12:14
  • Bonjour Segolene

    j'ai regardé tous les services et je ne trouve pas les services correspondants
    quels sont ils?

    merci d'avance
    cordialement
    mardi 9 mars 2010 12:57
  • Bonjour epsylon999,

    Pour accéder au FTP, voici les étapes:
    -> Gestionnaire de Serveur -> Roles -> Serveur Web (IIS), scroller la fenêtre vers le bas ->  Ajouter des service de rôle, il faut aussi scroller la fenêtre vers le bas pour arriver à Serveur FTP, il y a 1 case à cocher pour activer les 2 sous-rôles.

    Cordialement,
    Ségolène Hémar, de l'équipe web Microsoft (web_fr@microsoft.com)
    mercredi 10 mars 2010 10:53
  • bonjour Segolène

    tous est ouvert cote ftp et je peux faire des copiers collers pour importer des fichiers
    mais, desolé, de vous embetez encore, c'est mon premier serveur w2008R2
    Et je ne sais pas comment declarer un compte ftp
    car a terme je voudrais testé des programmes php sous windows pour voir la portabilité

    mercredi 10 mars 2010 12:44
  • Bonjour epsylon999

    N'hésitez pas à exploiter les ressurces disponibles sur TechNet: voici la procédure pour créer un compte FTP : http://technet.microsoft.com/en-us/library/cc732621(WS.10).aspx. Et si besoin pour les permissions : http://technet.microsoft.com/en-us/library/cc754009(WS.10).aspx.

    Cordialement,


    Ségolène Hémar, de l'équipe web Microsoft (web_fr@microsoft.com)

    jeudi 11 mars 2010 12:35
  • Bonjour Segolène

    merci des renseignements, mais pour le ftp,
    j'ai testé en mode ftp sur l'ip apres avoir demarrer le service ftp (bien actif) et je n'y accede pas

    reponse:

    Erreur :    Délai d'attente expiré
    Erreur :    Impossible d'établir une connexion au serveur

    serveur: lb-webpi-1969v

    normalement meme sans compte ouvert je devrais au moins avoir acces au serveur non?

    Cordialement
    jeudi 11 mars 2010 13:11
  • Bonjour epsylon999

    Avez-vous vérifier que le port 21 était ouvert dans votr firewall?

    Cordialement,


    Ségolène Hémar, de l'équipe web Microsoft (web_fr@microsoft.com)

    jeudi 11 mars 2010 16:52
  • bonsoir Segolène

    je confirme tous est parfaitement ouvert dans le firewall j'ai bien verifié


    cordialement
    jeudi 11 mars 2010 17:54
  • bonsoir

    je relance la demande car je n'accede tjr pas au ftp

    cordialement
    lundi 15 mars 2010 19:02
  • Bonjour,

    Que donne la commande Telnet sur le port 21?

    Nicolas
    mardi 16 mars 2010 12:43
  • bonjour

    rien pour le telnet
    le port 21 est bien ouvert dans le pare feu, les services ftp sont ok
    mais rien n'y fait

    Erreur :    Délai d'attente expiré
    Erreur :    Impossible d'établir une connexion au serveur
    mardi 16 mars 2010 13:05
  • Peux-tu poster ta config FTP et la réponse à la commande telnet?

    Si tu te connectes en telnet sur un port X ouvert, tu dois avoir un écran noir. Sinon tu as une erreur.

    Tu essaies de te connecter avec l'adresse IP ou le nom?

    mardi 16 mars 2010 13:16
  • alors pour le ftp c'est soit l'ip soit le nom
    avec mon compte admin
    mais il accede a rien cote ftp
    mardi 16 mars 2010 13:35
  • C'est très compliqué de répondre à ton problème.
    Il nous faudrait ta config ftp.

    Tu parles d'un compte admin. Admin de quoi?

    Tu parlais dans un précédent post que tu pouvais copier/coller pour importer tes fichiers? Qu'entends tu par là?
    A quel moment, le serveur ftp n'est donc pas joignable?
    mardi 16 mars 2010 13:42
  • En plus des questions que je me pose,
    tu as bien créé un site?
    mardi 16 mars 2010 13:56
  • Excusez moi pour le triple message.

    Peux-tu faire un test en ligne de commande depuis ton client

    ftp IP_du_serveur

    user anonymous (si tu as activé les connexions anonymes (activé par défaut).

    Si cela fonctionne. C'est un problème de règle de ton pare feu sur ton serveur ftp.
    Il faut donc créer une règle autorisant l'accès via d'autres applications que ftp.exe

    Cordialement,

    Nicolas
    mardi 16 mars 2010 14:19

  • salut

    le reglage ou du firewall?
    car le service ftp est ouvert le pare feu a le port 21 d'ouvert
    j'utilise filezilla pour le ftp

    le test est simplz
    fpt ip du serveur port 21

    et rien ne se passe

    Adresse IP : 109.238.3.204

    dns :
    lb-webpi-1969v.maplateformeweb.com


    Statut :    Résolution de l'adresse de lb-webpi-1969v.maplateformeweb.com
    Statut :    Connexion à 109.238.3.204:21...
    Erreur :    Délai d'attente expiré
    Erreur :    Impossible d'établir une connexion au serveur
    Statut :    Attente avant nouvel essai...

    cordialement
    mardi 16 mars 2010 16:58
  • OK. Le test ftp a bien été effectué en ligne de commande? c'est important pour le diagnostic.

    As-tu créé un site dans la console gestion FTP?
    http://learn.iis.net/page.aspx/301/creating-a-new-ftp-site/



    Nicolas
    mardi 16 mars 2010 18:33
  • non rien a ete creer c'est mon 1er serveur windows
    j'ai ouvert les services ftp et installé la plateforme web sur le serveur
    mardi 16 mars 2010 18:54
  • Il faut donc créer un site comme l'explique le tuto ci-dessous:

    http://learn.iis.net/page.aspx/301/creating-a-new-ftp-site/


    cordialement,
    mardi 16 mars 2010 19:09
  • bonjour

    je commence a perde espoir rien n'y fait

    on a pas de doc valide en plus en anglais
    pas cool de la part de microsoft un simple service ftp est une galere sans nom


    cordialement
    mercredi 17 mars 2010 09:35
  • Voici la doc officielle MS: http://support.microsoft.com/kb/309007/fr
    mercredi 17 mars 2010 09:57
  • le resultat est identique je me demande si je vais pas renoncé trop de perte de temps pour un service de base ...
    mercredi 17 mars 2010 15:46
  • Bonsoir epsylon999,

    Je vous remercie par avance pour votre patience, le temps pour nous d'intervenir, le cas échéant, sur votre machine ou d'élaborer un tuto. J'essaie de revenir vers vous avec une réponse pour le début de semaine prochaine.

    Merci de votre compréhension.
    Cdlt,
    Jonathan Chachoua, de l'équipe web Microsoft (web_fr@microsoft.com)
    jeudi 18 mars 2010 18:18
  • Bonsoir,

     Je peux vous suggérer Filezilla server

     http://filezilla-project.org/

     je viens de l'installer en  5 min. et ça marche ( ne pas oublier de configurer le firewall pour que ça passe)
    jeudi 18 mars 2010 19:32
  • Rebonsoir,
    Même avec l'aide de Jonathan Chachoua (cf Citation du post original à la fin de ce message), je n'arrive toujours pas à installer le composant IIS permettant de se connecter par le Web au Bureau à distance sur mon serveur lb-webpi-4871v.maplateformeweb.com.
    Quelqu'un aurait-il une solution explicite à me proposer?
    En vous remerciant par avance.
    Matthias BERNIER.

    Post original sur le forum d'entraide général:
    Bonjour à tous,

    Voici le résultat des interventions effectuées.

    Machine n°3147 : aucun problème détecté ; la VM a été relancée sans modification.

    Machine n°4422 : aucun problème détecté ; la VM a été relancée sans modification.

    Machine n°2994 : le host est lent en RDP, aucun indicateur en rouge au niveau du host, une trentaine d'utilisateurs ont initialisé leur machine sur ce host. Le mot de passe administrateur a été changé pour cette VM. Voici la mention d'indication pour votre mot de passe : "mot de passe mon serveur microsoft". Merci de rééssayer de vous connecter et de m'indiquer si des problèmes subsistent.

    Machine n°2822 : vous avez effectivement exécuté l'assistant de configuration de la stratégie de sécurité, qui, comme on le sait bien maintenant, désactive l'exception RDP. Nous avons remis dans son état d'origine et tout testé. Votre serveur a été redémarré proprement.

     

    Machine n°4945 (109.238.15.108) : aucun problème, le mot de passe n'a pas été changé, il s'agit de : Gi7#Yl2+Gd5&Oo5@ (pensez à le changer). Le serveur a été redémarré proprement.

     

    Machine n°4462 : le disque faisait 16 GB. La machine a été réinitialisée par application du snapshot d'origine (mot de passe d'origine changé).

     

    Machine n°1664 : le host est lent, en effet. Mais ni le trafic réseau ni la file de disque ne sont dans le rouge. La session a été ouverte à distance depuis VINCENT-BUREAU ; aucun problème de notre côté.

     

    Pour Matthias Bernier (alias linux78) : oui, pour vous connecter à distance à votre serveur "maplateformeweb.com", vous devez avoir sur votre ordinateur un logiciel de connexion à distance, et une fois connecté au serveur, vous pouvez mettre en oeuvre dans IIS le composant d'administration à distance.

    Voilà pour toutes ces réponses.

    Merci.
    Cdlt,


    Jonathan Chachoua, de l'équipe web Microsoft (web_fr@microsoft.com)
    jeudi 18 mars 2010 19:53
  • Bonsoir,
    j'ai une vrai question relative au serveur Web.

    J'ai essayé de publier mon site web ASP.NET MVC sur la vm. Et j'obtient l'exceptiont suivante : System.BadImageFormatException

    En regardant un peu sur le net, cette erreur survient lorsque l'on essai d'exécuter une dll de code natif compilée en 32 bit sur un environnement 64bit...

    Mais mon projet ne contient pas de code natif, c'est un projet MVC 1.0 en pur C#!

    De plus dans VS2008 je n'ai pas la possibilité de choisir ma plateforme cible... le seul choix est Active (Any CPU)

    Comment résoudre ce problème?!

    Merci!
    jeudi 18 mars 2010 21:17
  • Bonjour,

    Cette erreur semble provenir plutôt de la partie développement que de la partie infrastructure.
    Je te conseille de lire attentivement la note sur MSDN concernant cette exception et de poser ta question sur MSDN.
    http://msdn.microsoft.com/fr-fr/library/k7137bfe.aspx

    Cordialement,

    Nicolas
    jeudi 18 mars 2010 22:07
  • bonsoir le dysfonctionnement est resolue tous marche merci pour tous cordialement
    vendredi 19 mars 2010 21:14
  • Bonjour,

    Cette erreur semble provenir plutôt de la partie développement que de la partie infrastructure.
    Je te conseille de lire attentivement la note sur MSDN concernant cette exception et de poser ta question sur MSDN.
    http://msdn.microsoft.com/fr-fr/library/k7137bfe.aspx

    Cordialement,

    Nicolas

    Sa fait maintenant 3jours que je cherche et j'en arrive à la conclusion que c'est coté serveur que sa cloche.

     

    Exemple:

    1. Je crée un nouveau projet MVC sur ma machine (une machine x86) SANS rien modifier par rapport au projet vide 

    2. je le déploie sans rien modifier (donc la target plateformeest à "Any CPU")

    3. Le site marche sans PB (et un ptit test me permet de voir qu'il tourne en x64 car les objets IntPtr ont une taille de 8bit)

     

    2 eme test

    1b. Je crée un nouveau projet MVC sur ma machine (une machine x86) SANS rien modifier par rapport au projet vide

    2b. je le déploie sans rien modifier (donc la target plateforme est à "Any CPU")

    3b. Je modifie l'assembly avec CorFlags.exe et j'active le mode 32bit ( commande>CorFlags.exe monassembly.dll /32BIT+ )

    4b. Le site ne marche plus et j'obtient la fameuse exception BadImageFormatException

     

    Evidemment c'est la même chose si je le fait avec l'interface en compilant le site avec l'option Target Plateform: x86

     

    J'ai aussi essayé d'activer WOW64 avec commande> Ldr64.exe setwow sa marche pas plus.... (à moins qu'il faille reboot mais j'hésite à reboot ma VM desfois quelle ne redémarre plus...)

     

    Apparemment la VM ne peut PAS exécuter des programmes .NET en mode x86

     

    Je ne sais plus quoi faire la j'ai exploré toutes les possibilités, car même un projet MVC VIDE refuse de tourner..

     

    samedi 20 mars 2010 15:38
  • Le problème venait bien de IIS7


    Voila la solution:

    Dans le pool de votre application cliquez PARAMETRES AVANCES... puis mettre à true la proriété ACTIVER LES APPLICATIONS 32BIT 

     

    Voila remerciez moi maintenant ;)

    samedi 20 mars 2010 20:36
  • Bonjour linux78,

    Suite à votre post du 18 mars, pourriez-vous détailler le problème que vous rencontrez en m'envoyant des copies d'écran par mail (adresse ci-dessous) ? J'aurai ainsi plus de facilités à vous répondre.

    Merci.

    Cdlt,


    Jonathan Chachoua, de l'équipe web Microsoft (web_fr@microsoft.com)
    jeudi 1 avril 2010 17:41
  • bonjour

     

    j'ai le même soucis que epsylon999 avec ftp j'ai lu et relu les différents liens (ceci dis pas trouvé d'aide pour IIS 7.5) mais rien a faire, un coup de main serai le bienvenue.

    ma machine est 4300V et je cherche à accéder au site  
    http://primactif.maplateformeweb.com/jeconomise/

    merci pour votre patience

     


    POUPON
    lundi 19 avril 2010 18:28
  • Bonjour Primactif,

    Je vous propose de continuer nos échanges par mail. On utilisera ce forum pour poster la solution dès qu'on l'aura trouvée. :)

    Merci.

    Cdlt,


    Jonathan Chachoua, de l'équipe web Microsoft (web_fr@microsoft.com)
    mardi 20 avril 2010 13:12
  • Bonjour à tous,

    Je partage avec vous la procédure que PRIMACTIF a suivie pour se connecter en FTP à son serveur, merci à lui de me l'avoir transmise.

    Le message d'erreur qu'il rencontrait était le suivant :

    Statut :                          Résolution de l'adresse de primactif.maplateformeweb.com

    Statut :                          Connexion à 109.238.12.231:21...

    Statut :                          Connexion établie, attente du message d'accueil...

    Réponse :                     220 Microsoft FTP Service

    Commande :                 USER Administrateur

    Réponse :                     530 Valid hostname is expected.

    Erreur :                          Impossible d'établir une connexion au serveur

    Voici ce qu'il a fait pour résoudre ce problème :

    1°) Créer un site depuis VS2010. Un répertoire virtuel est ainsi créé sous « défaut Web Site » avec le nom "mon_repertoire", par exemple.

     

    2°) Faire clic droit sur le serveur et faire "Ajouter un site FTP".

    Donner le nom du site FTP (le même) "mon_repertoire" et sélectionner le répertoire du site web "C:\inetpub\wwwroot\mon_repertoire".

     

    3°) Dans le nouveau site FTP, modifier dans « Paramêtre SSL FTP » pour le mettre en "Autoriser les connexions SSL". Par défaut, il s'agit de "Exiger des connexions SSL".

    J'espère que ça pourra aider les personnes qui sont dans le même cas que lui.

    Merci beaucoup.

    Cordialement,


    Jonathan Chachoua, de l'équipe web Microsoft (web_fr@microsoft.com)
    vendredi 23 avril 2010 13:16
  • Bonjour

    Moi j'aimerai activer le son de mon serveur. Je me suis connecter mais je ne peux pas écouter les vidéo, il n'y a pas de son.

    Merci

    dimanche 16 mai 2010 23:01
  • Bonjour chercheur01,

    Pourriez-vous m'adresser votre demande par mail à web_fr@microsoft.com ? Ou sinon, merci de m'indiquer l'identifiant de votre serveur.

    Je vous enverrai la procédure pour le faire.

    Merci.
    Cdlt,


    Jonathan Chachoua, de l'équipe web Microsoft (web_fr@microsoft.com)
    lundi 17 mai 2010 10:34
  • bonjour,

    j'essaie vainement de me connecter en FTP à mon serveur. J'ai suivi la procedure de  PRIMACTIF en créant les meme nom de repertoire : j'ai bien un site FTP de créér ( au meme niveau que "default web site".

    Les roles FTP sont bien dans IIS et demarrés .

    - Pour me connecter je me sert de FILEZELLA ( car il marche tres bien avec d'autre Hebergement IKOULA.

    iL NE TROUVE PAS LE SERVEUR /

    Statut : Connexion à 109.238.10.141:21...

    Erreur : Délai d'attente expiré

    Erreur : Impossible d'établir une connexion au serveur

     

  • Voici les login de mon serveir:
  • Adresse IP : 109.238.10.141
  • Compte : Administrateur
  • Mot de passe:
  • Nom complet du serveur: lb-webpi-3698v.maplateformeweb.com

     

    en tapanr la commande ftp 109.238.10.141 , pareil rien ne se passe.

    Merci de Votre Aide    Desvernes Claude

lundi 31 mai 2010 09:11
  • Bonjour Cdes,

    Pour installer et configurer FTP sur votre serveur, je vous conseille ce tutoriel : http://learn.iis.net/page.aspx/263/installing-and-configuring-ftp-on-iis-7/

    Merci,

    Cordialement.


    Jonathan Chachoua, de l'équipe web Microsoft (web_fr@microsoft.com)
    mardi 1 juin 2010 15:10
  • Merci pour le lien , mais depuis 2 mois que j'essaye de faire un serveur FTP , je le coNNAIS par coeur.

    J'ai vu plus haut que "epsylon999" a eu le meme probleme pour creer son FTP. Serait il possible de Savoir comment il a fait.

    Si non je laisse tomber le FTP.

    Cordialement      Desvernes Claude

     

    vendredi 4 juin 2010 09:33
  • Bonjour,

    J'ai un problème avec le serveur WEB, impossible à partir de mon site web que je viens d'installer sur la serveur Ma plateforme web d'envoyer des mails en php

    Sur IIS, j'ai une erreur 500

    Sur wamp, j'ai une erreur php

    Warning: mail() [function.mail]: SMTP server response: 554 5.7.1 <tadressedestinataire@gmail.com>: Relay access denied in C:\wamp\www\FR\enregistrer.php on line 156

    J'utilise comme SMTP celui de mon FAI (ORANGE)

    smtp.orange.fr sur le port 25

    lundi 19 juillet 2010 09:41
  • Bonjour,

    J'ai installé "Silverlight 4 Beta Client for Facebook" sur ma plateforme web server 2008 R2 et après que je me login, je n'ai pas accès à la page d'accueil... pourquoi? merci d'avance de vos réponses.

    mercredi 28 juillet 2010 20:47
  • Bonjour,

    up...up... et je peux accéder au contenu de facebook/silverlight4... sur ma plateforme... (une demande de MAJ à été autorisé).

    mais quand je veux accéder à une page web, j'ai une indication: une erreur s'est produite lors de l'envoi d'une commande au programme et je ne peux ouvrir cette page web (IE est fermé)... et quand IE est ouvert, je n'ai plus aucune indication est j'ai accès à la page tout de suite?

    voilà^pour le moment...

     

    mercredi 4 août 2010 00:18
  • Bonjour;  cela dépend du sytheme d'exploitation que tu utilise, WINDOWS 7/10/ etc  après tu peut toujours  essayer (pour activer IIS au départ) tu va dans programmes, puis tu va dans activer des fonctionalites Windows; tu case la case a cocher IIS pour l'activer, tu sort puis attend un peu que ça enregistre et normalement c'est bon. Ps Précise le sytheme d'exploitation pour obtenir une réponse rapide, salut   
    lundi 27 novembre 2017 11:47