locked
Forcer "Netbios over Tcpip" par GPO ? RRS feed

  • Question

  • Bonjour,

     

    Je cherche à Forcer le paramètre Netbios over TCP/IP.

     

    L'idée serait  de le faire par une GPO (sur un SBS2003).

    Eventuellement par le DHCP car la majorité des postes l'utilisent.

     

    Cela fait un moment que je torune en rond car je ne trouve pas lesbon paramètres.

     

    Si quelqu'un à une piste, cela m'aidera.

     

    Merci par avance.

     

    Philippe.

     

     

    vendredi 10 octobre 2008 10:54

Réponses

  • Bonjour GPh,

     

    tu peux le faire en utilisant la routine suivante dans un script de logon:

     

    ' This code enables/disables the Netbios over TCP/IP setting.
    ' ------ SCRIPT CONFIGURATION ------
    Const SET_NETBIOS = 2  ' 0 = Use setting from DHCP; 1 = Enable; 2 = Disable
    strComputer = "."
    ' ------ END CONFIGURATION ---------
    
    set objWMIService = GetObject("winmgmts:\\" & strComputer & "\root\cimv2")
    set colNicConfigs = objWMIService.ExecQuery _
       ("SELECT * FROM Win32_NetworkAdapterConfiguration WHERE IPEnabled = True")
    
    For Each objNicConfig in colNicConfigs
       intNetBIOS = objNicConfig.SetTCPIPNetBIOS(SET_NETBIOS)
       WScript.Echo objNicConfig.Description & _
                    ": successfully set NetBIOS over TCP/IP to " & SET_NETBIOS
    Next
    
    attention à bien positioner SET_NETBIOS à 1 dans ton cas Smile
    à césar ce qui est à césar: la routine est sortie de là:
    http://techtasks.com/code/viewbookcode/1200
     
     
    cordialement,
     
    PierrE.
     
    lundi 13 octobre 2008 12:44

Toutes les réponses

  •  

    Bonjour,

     

    par défaut le netbios sur tcp/ip est activé sur les postes ayant une ip fixe (ipv4) et sur les postes ayant la configuration Default (et donc via le DHCP).

     

    Il est possible de forcer la désactivation de netbios/tcpip via DHCP (et par conséquent tu devrais vérifier si ce paramètre est correct sur ton DHCP si tu rencontres un problème : http://support.microsoft.com/kb/313314/en-us )

     

    Autrement, pour vérifier que netbios over tcp/ip est bien activé sur ton ordinateur, lances la commande

     

    net config server

     

     

    Netbios sur TCP/Ip est activé si tu obtiens quelque chose comme :

     

    Serveur actif sur
            NetbiosSmb (000000000000)
            NetBT_Tcpip_{20CB91A0-BBB6-4310-909D-68107A4C46A7} (001d090cd3bd)

     

    Netbios sur TCP/Ip est désactivé si tu obtiens quelque chose comme :

    Serveur actif sur
            NetbiosSmb (000000000000)

     

    @+

    vendredi 10 octobre 2008 14:37
  • Bonjour,

     

    Merci pour la réponse.

    Cepandant mon problème n'est pas comment le faire mais comment le faire de manière centrale sans repasser sur tout les postes à partir du gestionnaire de odmaine. (qui est aussi serveur DHCP)

     

     

    Philippe

     

     

     

     

    lundi 13 octobre 2008 11:50
  • Bonjour GPh,

     

    tu peux le faire en utilisant la routine suivante dans un script de logon:

     

    ' This code enables/disables the Netbios over TCP/IP setting.
    ' ------ SCRIPT CONFIGURATION ------
    Const SET_NETBIOS = 2  ' 0 = Use setting from DHCP; 1 = Enable; 2 = Disable
    strComputer = "."
    ' ------ END CONFIGURATION ---------
    
    set objWMIService = GetObject("winmgmts:\\" & strComputer & "\root\cimv2")
    set colNicConfigs = objWMIService.ExecQuery _
       ("SELECT * FROM Win32_NetworkAdapterConfiguration WHERE IPEnabled = True")
    
    For Each objNicConfig in colNicConfigs
       intNetBIOS = objNicConfig.SetTCPIPNetBIOS(SET_NETBIOS)
       WScript.Echo objNicConfig.Description & _
                    ": successfully set NetBIOS over TCP/IP to " & SET_NETBIOS
    Next
    
    attention à bien positioner SET_NETBIOS à 1 dans ton cas Smile
    à césar ce qui est à césar: la routine est sortie de là:
    http://techtasks.com/code/viewbookcode/1200
     
     
    cordialement,
     
    PierrE.
     
    lundi 13 octobre 2008 12:44
  • Super !

    Ca me conveint tout à fait, merci.

     

    Philippe.

     

     

     

    jeudi 16 octobre 2008 07:15