none
Citrix Xenapp error, .ica file FQDN vs IP address RRS feed

  • Question

  • I'm publishing Citrix XenApp web interface through UAG.

    The Citrix web interface comes up fine but when I launch an application I get the following error:

    Summation Enterprise ERROR
    Cannot connect to the Citrix MetaFrame server.
    Unable to contact the MetaFrame server browser. There may be network problems, or you may need to configure the correct server address in the Server location field.

    I have found that if I grab the the temporary .ica file (icaXXX.tmp) which was placed on the client in:
    c:\documents and settings\USERNAME\localsettings\temp\

    The file received from UAG/Citrix has the FQDN of the target Citrix server.
    Address=citrix-server.example.com:1494

    If I try to launch the application using the file I get the same error as above.

    However if I change the Address parameter in a copy of the .ica file to be the
    IP address, then I can launch the application using that .ica file without error.
    Address=192.168.1.12:1494

    I tried listing the shortname, longname and IP address in the list of Citrix Farm Servers on the published application (Citrix XenApp(Web Interface 5.0)) but I still get the error.

    Any ideas what might be wrong or more ways to diagnose?
    vendredi 26 mars 2010 23:46

Réponses

Toutes les réponses