locked
NLB sous VMWare problème après redémarrage RRS feed

  • Discussion générale

  • Bonjour,

    J'ai 2 serveurs W2K8StdR2 minus chacun de 2 vNICs sous VMWare ESXi 5

    HUBCAS00 : NIC1 (HUBCAS) 192.168.74.12/255.255.255.0 | NIC2 (PRIVNLB) 10.90.74.12/255.255.255.0

    HUBCAS01 : NIC1 (HUBCAS) 192.168.74.13/255.255.255.0  NIC2 (PRIVNLB) 10.90.74.13/255.255.255.0

    J'ai configuré un NLB en donnant un hostname.domain.local et l'IP 192.168.74.100 à mon cluster en utilisant un "Cluster operation mode" "Unicast".

    Dans VMWare, mon vSwitch est sur "Notify Switches : Yes" (/défaut)

    Dans VMWare, le port group pour ce VLAN est sur "Notify Switches : Yes" (/défaut)

    Lorsque je redémarre un des serveur, il reste près de 10 munites sur "Applying computer settings" et après le démarrage les services Exchange n'ont pu démarré faute de connexion réseau.

    Le fait est que le serveur redémarré est sans connexion à internet et sans communication vers l'extérieur jusqu'à ce que je désactive/réactive la PRIVNLB. Après cela, instantanément  tout fonctionne parfaitement, je peux redémarrer mes services et le NLB, OWA, ...  fonctionnent.

    J'essaye ensuite en "Multicast", le résultat est le même.

    ------------------

    J'essaye donc de repasser en Unicast (semble + compatible avec la majorité des switch dispo. sur le marché) et passe, dans VMWare, le "port group" du VLAN dédié à cette infra, et ce sur les 2 hosts ESXi à "Notify Switches :No".

    Je stoppe temporairement mon NLB sur ce serveur (HUBCAS01), "Initiate" un état "Stop" pour contrôler son état au prochaine redémarrage.

    Je redémarre mon serveur => OK ça marche. Démarrage rapide, réseau et services Exchange OK

    Je "Start" mon NLB, tout fonctionne bien.

    Je passe sur l'autre serveur (HUBCAS00), je "Stop" le NLB et oublie de "Initiate" un état "stop" pour contrôler son état au prochaine redémarrage.

    Je redémarre mon serveur, le NLB est "Started/Converged" => OK ça marche.

    Je répète l'action, je 'stop' et 'initiate' un état 'stop' pour contrôler l'état de HUBCAS00 au prochaine redémarrage.

    Je redémarre mon serveur => KO ça ne fonctionne plus. Démarrage lent, connexions réseau et services KO alors que je me suis juste assuré que le NLB soit 'stop' au démarrage du HUBCAS00.

    Pour info, le DRS garde chaque serveur sur un host différent.

    Bref, le fonctionnement me semble très instable et/ou alléatoire et j'aimerais avoir un avis extérieur.

    Votre avis m'intéresse donc au plus haut point.

     

    D'avance merci pour votre réponse

     


    laurent ulrich UNS SCRL, MS registered partner
    • Modifié NGiloteau jeudi 19 janvier 2012 23:28
    • Type modifié Florin Ciuca vendredi 3 février 2012 10:01
    jeudi 19 janvier 2012 23:26

Toutes les réponses

  • Bonsoir,

    y a t-il routage entre les 2 réseaux utilisés?

    Limiter les protocoles à sécuriser par NLB est aussi très important (HTTP,HTTPS et SMTP).

    A bientôt,


    Thierry DEMAN. Exchange MVP. https://www.mcpvirtualbusinesscard.com/VBCServer/MVPtdeman/profile (68 MCPs) http://base.faqexchange.info
    samedi 21 janvier 2012 23:23
  • Bonsoir,

    Merci pour votre réponse et sorry pour le délai, je suis pas mal occupé ces temps-ci.

    Il n'y a pas de routage entre les interfaces.

    Pour l'instant le NLB tourne sur 0 -> 65535 TCP&UDP.

    Appart le 80, 443 et 25, ne devrais-je pas également ajouter le RPC 143 et/ou l'un ou l'autre port ?

     

    D'avance merci pour votre réponse.


    laurent ulrich UNS SCRL, MS registered partner
    • Modifié NGiloteau vendredi 27 janvier 2012 09:41 faute de frappe ridicule
    jeudi 26 janvier 2012 21:43
  • Bonsoir,

    tout dépend des services utilisés sur les Hub/Cas !

    143 correspond à IMAP, ce n'est pas RPC.

    On peut penser ajouter POP3 (110), POP3S, IMAPS, ainsi le RPC client et l'AddressBook d'Exchange, à condition d'avoir fixé les ports !

    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\MSExchangeRPC\ParametersSystem]
    "TCP/IP Port"=dword:0000ea61
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\MSExchangeAB\Parameters]
    "RpcTcpPort"="60002"
    

    60001 et 60002 dans mon exemple.

    A bientôt,


    Thierry DEMAN. Exchange MVP. https://www.mcpvirtualbusinesscard.com/VBCServer/MVPtdeman/profile (68 MCPs) http://base.faqexchange.info
    samedi 28 janvier 2012 10:58
  • Bonjour,

    Merci beaucoup pour votre réponse, j'étudierai vos conseils très prochainement.

    Je ne manquerai pas de revenir vers vous dans un futur proche par rapport à l'avancement du projet mais pour l'instant, j'ai pu constater qu'il fallait:

    Mettre le NLB sur stop pour le prochain redémarrage lors d'un redémarrage.

    Mettre le NLB en Multicast pour éviter les problèmes de vMotion sous VMWare.

    Désactiver l'ipv6 complètement : décocher + 0x41ffffff dans la nouvelle DWORD 32bit "DisableComponents".

    À l'heure actuelle, sans encore avoir touché aux ports (serveurs de labo) le fonctionnement est beaucoup plus "normal".

    Je peux redémarrer mes serveurs de manière contrôlée et normale. Plus trop de soucis.

    À très bientôt et encore merci pour votre support.


    laurent ulrich UNS SCRL, MS registered partner
    mercredi 1 février 2012 13:54