none
[Résolu] Installation RDS RD Server en powershell sur server 2012 std core RRS feed

  • Question

  • Bien le bonjour,

    Alors voici mon problème, lorsque j’exécute la commande suivante en powershell sur un server 2012 standard installé en version Core uniquement:

    add-windowsfeature -name RDS-RD-Server -includeallsubfeature 

    J'ai une erreur m'indiquant que les fichiers pour l'install ne sont pas présents sur le serveur et qu'il faut que j'utilise l'argument "-source" pour spécifier l'endroit de mes sources d'install (car pas dispo par défaut ni sur le net apparemment), ce que je fais avec cette commande par la suite :

    add-windowsfeature -name RDS-RD-Server -includeallsubfeature -source D:\sources\sxs (ou D: correspond à la lettre de mon lecteur DVD)

    Mais l'install ne donne rien et j'obtiens alors le même message d'erreur qui stipule que les sources d'install ne peuvent être trouvées...

    HELP!!!

    Christouffe


    • Modifié _Christof_ mercredi 24 octobre 2012 13:18
    mercredi 24 octobre 2012 07:32

Réponses

Toutes les réponses

  • Bonjour,

    utilise cette commande : 

    Install-WindowsFeature –Name <feature_name> -ComputerName <computer_name> -Restart

    et si tu as une erreur qui te demande d'utiliser l'argument "Source" utilise la commande ci-dessous avec le DVD d'installation de windows server 2012(X: représente le lecteur DVD):

    Install-WindowsFeature –Name <feature_name> -Source X:\source\install.wim

    Cordialement,


    Cordialement, Oussema FEKIH Note : Si ma réponse vous a été utile, ou apporté une résolution; merci de Voter ou de la marquer comme Utile. Best Regards, Oussema FEKIH If my reply has helped you or made a resolution, thank you to vote it as helpful or mark it as answer.




    mercredi 24 octobre 2012 08:41
  • Merci mais déjà essayer, voici l'erreur obtenue...

    mercredi 24 octobre 2012 09:36
  • Bonjour,

    essaye cette commande :

    Install-WindowsFeature -Name RDS-RD-Server -source:wim:d:\sources\install.wim:2

    je te recommande aussi cet article qui parle de la résolution de la même erreur : http://p0w3rsh3ll.wordpress.com/2012/10/10/switch-from-windows-2012-core-to-gui-mode-hands-on/ 

    Cordialement,


    Cordialement, Oussema FEKIH Note : Si ma réponse vous a été utile, ou apporté une résolution; merci de Voter ou de la marquer comme Utile. Best Regards, Oussema FEKIH If my reply has helped you or made a resolution, thank you to vote it as helpful or mark it as answer.

    • Proposé comme réponse Oussema Fekih mercredi 24 octobre 2012 10:05
    • Marqué comme réponse _Christof_ mercredi 24 octobre 2012 13:18
    mercredi 24 octobre 2012 10:05
  • Bon visiblement ça ne marchais pas, j'ai tout simplement réinstaller complètement ma VM et j'ai ajouté les rôles en PS avant de la rentrer dans le domaine et maintenant tout est OK.

    Merci quand même pour vos réponses :)

    Christouffe

    mercredi 24 octobre 2012 13:18