none
Paramétrage de l'écran du ctrl+alt+supp (suppression de l'arrêt et du redémarrage de la machine) RRS feed

  • Discussion générale

  • bonjour,

    Nous souhaiterions supprimer la possibilité qu'un utilisateur puisse éteindre ou redemander une machine sur un Windows 10 a partir de l'ecran qui est appelé avec la sequence ctrl+alt+supp en cachant les option d'extinction :

    Sur un Windows 7, 8 et 8.1, la clé suivante permet de le faire :

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoClose"=dword:0000001

    celle ci ne fonctionne pas sur windows 10 !

    si quelqu'un connais la solution ...

    merci pour votre aide.



    • Modifié lutes vendredi 13 novembre 2015 15:39
    • Type modifié Emile Supiot lundi 16 novembre 2015 11:21 pas de solution définitive
    vendredi 13 novembre 2015 11:22

Toutes les réponses

  • Empêcher un utilisateur d'éteindre une machine est quelque peu utopique dans la mesure ou ce dernier a n accès physique à la machine. Quoi du plus simple que d'appuyer sur le bouton On/Off ou de simplement retirer le câble d'alimentation...

    Néanmoins si tel est la demande, le plus simple est d'appliquer ce changement via une stratégie de groupe (GPO) à condition d'être membre d'un domaine. Sinon "gpedit.msc" fera très bien l'affaire.

    Maintenant je m'interroge sur cette valeur "NoClose" qui finalement n'empêche pas l'utilisateur de faire un shutdown ou un restart mais cache simplement ces options.... La question devrait alors à priori être "Comment cacher les options d'extinction et de redémarrage d'une machine sous Windows 10"


    vendredi 13 novembre 2015 11:58
  • Pour pouvoir débrancher ou appuyer sur le bouton, il fauterais qu'ils puissent accéder a la machine ;)

    Via les gpo, la stratégie est : supprimer et empêcher l'accès aux commandes .... dans utilisateur\modèles d'admin.\menu redémarrer (mais elle ne change que la clé précédente).

    Effectivement, j'aurais pu dire : "Comment cacher les options d'extinction..."

    et sinon une solution ?

    vendredi 13 novembre 2015 12:17
  • Quel est exactement le setup ?

    J'imagine qu'il s'agit d'une borne tactile ne laissant pas d'accès directe au clavier ou à tout autre périphérique externe le tout dans un environnement "limité" ce pourquoi, dans un tel cadre, cacher une fonctionnalité est une "mesure de sécurité" suffisante.

    La première chose que je ferais et, c'est déjà la moitié du travail, serait de modifier QUI peut effectivement effectuer un Shutdown en modifiant la liste par default présente ici : Computer\Windows Settings\Security Settings\Local Policies\User Right Assignement\Shut down the system

    Je n'ai actuellement pas de machine Windows 10 à disposition mais d'ici quelques heures je pourrai peut-être solutionner l'autre moitié du problème ;-)

    Bien à vous

    vendredi 13 novembre 2015 12:48
  • Bonjour,

    Pour désactiver les options de redémarrage, d'arrêt et d'hibernation, il faut configurer cette GPO:

    User Configuration \ Administrative Templates \ Start Menu and Taskbar et sélectionne "Remove and prevent access to the Shut Down, Restart, Sleep, and Hibernate commands"


    signatureforums

    vendredi 13 novembre 2015 12:51
    Modérateur
  • merci, mais comme je le dit plus haut cette GPO ne fonctionne pas pour l'écran de ctrl+alt+sup ! (sur windows 10)


    LUTES - UPMC



    • Modifié lutes vendredi 13 novembre 2015 13:02
    vendredi 13 novembre 2015 13:01
  • C'est quoi le setup ?

    Merci, pour la solution avec la gestion des droits cela aurais put être une solution, mais nous disposons d'une application sur la session qui doit pouvoirs éteindre/redémarrer la machine et qui tourne en tant qu'utilisateur.

    merci pour votre implication.


    LUTES - UPMC

    vendredi 13 novembre 2015 13:10
  • Bonjour,

    La GPO pour le menu démarrer et celle ci sont celles qui correspondent le mieux;

    User Configuration > Administrative Templates > System > Ctrl+Alt+Del Options

    À part cela, l'autre options que je vois serait de désactiver aussi le gestionnaire des tâches.


    signatureforums

    vendredi 13 novembre 2015 13:17
    Modérateur
  • merci,

    Il est vrais qu'il aurait été logique que l'option de masquage de l'arrêt/redémarrage de la machine via l'écran de ctrl+alt+supp soit a cet endroit, mais malheureusement les seules option sont :

    Désactiver la modification du mot de passe
    Désactiver le verrouillage de l’ordinateur
    Supprimer le Gestionnaire des tâches
    Supprimer la fermeture de session

    Même suppression du gestionnaire de tache n'empêche pas l'utilisateur d'arrêter/redemarer la machine via cette écran !


    LUTES - UPMC

    vendredi 13 novembre 2015 13:49
  • Bonjours,

    Est-ce que cette option peut aider ?

    Local Computer Policy, Computer Configuration, Windows Settings, Security Settings, Local Policies, Security Options | Allow system to be shutdown without having to logon


    Regards, Philippe

    Don't forget to mark as answer or vote as helpful to help identify good information. ( linkedin endorsement never hurt too :o) )

    Answer an interesting question ? Create a wiki article about it!

    vendredi 13 novembre 2015 14:04
  • bonjour et merci,

    Cette GPO permet de le faire pour le "logon screen" je veux faire la même chose pour le "ctrl+alt+del screen"

    cordialement


    LUTES - UPMC

    vendredi 13 novembre 2015 14:17
  • Avec ce qui est mentionné, regarde ce qui te correspond le mieux. Tu n'as pas vraiment autre possibilité.

    Que fais tu si ta machine à un probleme ? tu fais un force shutdown?


    signatureforums

    vendredi 13 novembre 2015 15:00
    Modérateur
  • Avec ce qui est mentionné, regarde ce qui te correspond le mieux. Tu n'as pas vraiment autre possibilité.

    Que fais tu si ta machine à un probleme ? tu fais un force shutdown?


    signatureforums

    Nous les gérons a distance via une appli installé dessus (c'est pour cela que nous ne pouvons utiliser les droits sur l'arrêt de la machine).

    c'est dommage que cette clé qui fonctionnais sur 7, 8 et 8.1 ne marche pas avec 10 !

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoClose"=dword:0000001

    merci quand même.

    LUTES - UPMC



    • Modifié lutes vendredi 13 novembre 2015 15:39
    vendredi 13 novembre 2015 15:34
  • Merci d'avoir rajouté l'image pour plus de précision. Auparavant c'etait cette clé

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
    shutdownwithoutlogon à la valeur 0


    signatureforums

    vendredi 13 novembre 2015 15:51
    Modérateur
  • Merci d'avoir rajouté l'image pour plus de précision. Auparavant c'etait cette clé

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
    shutdownwithoutlogon à la valeur 0


    signatureforums

    non, cette clé ne touche que le logon screen et pas le ctrl+alt+del screen (et elle fonctionne toujours sur windows 10 celle-ci)

    LUTES - UPMC


    • Modifié lutes vendredi 13 novembre 2015 16:00
    vendredi 13 novembre 2015 15:58
  • Oui, effectivement.

    signatureforums

    vendredi 13 novembre 2015 16:17
    Modérateur
  • Au final, il n'y a pas la possibilité de masquer se bouton (pour l'instant), il semblerais que le développeur ai oublié la vérification de ce paramètre avant d'afficher le bouton !

    En attendant (peut être) un correctif, nous restons donc sur Windows 8.1 :-(

    Merci a tous pour votre aide.


    LUTES - UPMC

    jeudi 19 novembre 2015 12:03