locked
Logoff Script GPO RRS feed

  • Question

  • Bonjour à tous,


    J'ai rencontré un petit soucis auquel je souhaiterais trouver une explication plausible.
    J'ai fait un script qui permettait de copier des fichiers qui se trouve en local sur un serveur distant et ce, à l'aide de robocopy. Ex. : copie de c:\tmp -> \\serveur\bck_tmp

    Voici les resultats de mes tests:

    Exécution à partir de la session du user: OK - copie parfaite
    Exécution à partir des GPO pour le logoff: NOK - rien ne se passe

    Par contre, si je fais la copie de c:\tmp vers c:\tmp2 cela fonctionne à partir des GPO.

    Je n'arrive pas à comprendre la raison pour laquelle on ne peut faire de copie à partir du poste pendant le logoff alors qu'il est possible de faire une synchro offline au logoff.

    Merci de votre aide... Smile


    K.


    Ps.: si je ne suis pas assez clair, n'hésitez pas à me poser des questions.. Smile
    mercredi 20 août 2008 08:15

Réponses

  • Bonjour,

    J'ai trouvé une solution intermédiaire qui est de faire la sauvegarde lors du logon script... Ce qui ne me plait guère mais bon.. je ferais avec.

    par contre, j'ai appliqué la commande net config work. J'ai redirigé l'output de la commande vers un fichier texte

    voici ce que j'ai:



    Code Snippet
    Computer name \\%COMPUTERNAME%
    Full Computer name %COMPUTERNAME%.%DOMAINNAME%
    User name %USERNAME%

    Workstation active on
    NetbiosSmb (000000000000)
    NetBT_Tcpip_{53297CE9-F593-48FF-8AC2-FEBF7F783807} (001CC01CC063)

    Software version Windows 2002

    Workstation domain %DOMAINNAME%
    Workstation Domain DNS Name %DOMAINNAME%
    Logon domain %DOMAINNAME%

    COM Open Timeout (sec) 0
    COM Send Count (byte) 16
    COM Send Timeout (msec) 250
    The command completed successfully.

    Je n'arrive pas à "comprendre" ce résultat... Comment dois-je l'interpréter?
    Merci d'avance
    mardi 26 août 2008 11:01

Toutes les réponses

  • Bonjour K,

     

    la GPO de script est associée à l'utilisateur ou l'ordinateur?

     

    Il est probable que le script ne s'exécute qu'avec les droits de l'ordinateur, c'est à dire du compte système.

    Or, ce compte n'a pas les droits d'utiliser les partages réseaux.

     

    Utilise la commande "net config work" dans le script pour vérifier le compte actif et/ou l'accès au réseau.

     

    A+

    mercredi 20 août 2008 11:31
  • Bonjour,

    Merci pour la réponse.
    La GPO était associée à l'utilisateur (User Configuration -> Windows Settings -> Scripts (Logon / Logoff) -> Logoff)
    Donc, à priori, le script s'exécutait avec les droits du user.

    J'ai l'impression qu'il y a une différence entre l'état "connecté avec un user" et l'état "en cours de fermeture de session"

    Khalydros

    mercredi 20 août 2008 14:08
  • Bonjour,

    J'ai trouvé une solution intermédiaire qui est de faire la sauvegarde lors du logon script... Ce qui ne me plait guère mais bon.. je ferais avec.

    par contre, j'ai appliqué la commande net config work. J'ai redirigé l'output de la commande vers un fichier texte

    voici ce que j'ai:



    Code Snippet
    Computer name \\%COMPUTERNAME%
    Full Computer name %COMPUTERNAME%.%DOMAINNAME%
    User name %USERNAME%

    Workstation active on
    NetbiosSmb (000000000000)
    NetBT_Tcpip_{53297CE9-F593-48FF-8AC2-FEBF7F783807} (001CC01CC063)

    Software version Windows 2002

    Workstation domain %DOMAINNAME%
    Workstation Domain DNS Name %DOMAINNAME%
    Logon domain %DOMAINNAME%

    COM Open Timeout (sec) 0
    COM Send Count (byte) 16
    COM Send Timeout (msec) 250
    The command completed successfully.

    Je n'arrive pas à "comprendre" ce résultat... Comment dois-je l'interpréter?
    Merci d'avance
    mardi 26 août 2008 11:01
  • Bonsoir,

     

    c'est intéressant !

     

    Cela veut dire que le système utilise les variables qui ne sont pas ou plus accessibles à ce niveau.

     

    Lance la commande dans une fenêtre de commandes DOS pour comparer...

     

    A bientôt

    mardi 26 août 2008 18:24
  • bonjour,

    j'ai exactement le meme résultat...
    mercredi 27 août 2008 10:09
  • là, n'est pas normal!

     

    Il devrait y avoir des valeurs à la place des variables.

     

    A+

    mercredi 27 août 2008 21:15