none
Exchange 2010 - Problèmes de connexion RRS feed

  • Discussion générale

  • Bonjour,

    Nous rencontrons actuellement des problèmes sur notre infrastructure Exchange 2010 (CAS/HUB). Pendant 2 ans nous n'avons pas rencontré de problème, mais depuis quelques temps nous avons des déconnexions/reconnexions des clients et voir des clients qui n'arrivent pas a se connecter au serveur Exchange. En désactivant/activant la carte réseau cela règle les problèmes de connexion.

    Un autre problème vient de se produire, impossible de faire un ping sur l'adresse IP virtuelle du serveur (CAS) sur un poste, nous avons supprimés les arp avec la commande arp -d sur le serveur et la connexion est revenue.

    Exchange 2010 : Version 14.3 (Build 123.4)

    Je suis actuellement à la recherche de piste ou de solutions donc je suis preneur de toute suggestions.

    Cordialement,

    mardi 16 juin 2015 12:58

Toutes les réponses

  • Bonjour,

    Utilisez-vous la Connexion de Pont de Microsoft pour agréger 2 cartes par exemple ? Car cela peut poser des problèmes jusqu'en Windows Server 2008.

    Sinon, qu'entendez-vous par "IP virtuelle" concernant le CAS ?


    Cordialement,

    Sylvain (MCP, MCTS Windows Server 2008 R2 Server Virtualization)

    Blog : http://sylvaincoudeville.fr


    mardi 16 juin 2015 15:55
  • Bonjour,

    Nous n'avons pas d'agrégation sur les serveurs, nous avons juste un NLB entre les serveurs CAS qui donne une IP Virtuelle. Sinon nous sommes sur du Windows 2008 R2 Datacenter.

    Cordialement,

    mercredi 17 juin 2015 13:05
  • nous avons juste un NLB entre les serveurs CAS

    Il faut vérifier que vous n'ayez pas fait de changement au niveau des switchs, parefeu physique ou logiciel concernant les adresses MAC.


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    jeudi 18 juin 2015 08:09
    Modérateur
  • Bonjour, Xavier-MSS,

    Le problème persiste-t-il ?
    Je vous remercie par avance de votre retour.

    Cordialement,
    Téodora

    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    mardi 30 juin 2015 00:20
  • Bonjour,

    Désolé du retour tardif, nous n'avons pas fait de changement niveau MAC. Serait-il possible que le problème vienne de la partie VMware avec les MAC virtuelle ? Mais comme nous n'avons pas eu de problème pendant plus de 2 ans je doute que cela vienne de ça.

    Oui le problème persiste, demain je fais un upgrade mémoire sur les serveurs. Après si le problème persiste, je pensais passer en mode Outlook anywhere (RPC via https). Mais nous avons eu une amélioration lors de la mise à jour des Exchange.

    Mais je sens bien un problème ARP, mais je n'arrive pas à déterminer d'ou ! (Firewall netasq, Esx, Machine virtuelle)

    Tous les utilisateurs utilisent le client outlook en mode non cache et plusieurs BAL (entre 5-15 BAL par client) Nous sommes environ une 50ène de personnes.

    mardi 30 juin 2015 14:43
  • Bonjour,

    Pour faire avancer le diagnostic, votre Firewall Netasq n'est pour rien dans le problème. En effet, il n'intervient que pour les connexions distantes, pas les connexions locales (sauf si votre Exchange se trouve dans une DMZ).

    Il faudrait, lorsque le problème survient sur un poste, faire un arp -a, et regarder ce qui sort à côté de l'IP demandée :

    • soit vous avez un 00-00-00-00-00-00 : cela signifie qu'il y a un problème avec le NLB (et il faut donc regarder les logs des serveurs concernés à ce moment là) ou un problème réseau (boucle réseau ?)
    • soit vous avez une autre adresse MAC : dans ce cas, il faut rechercher à qui elle appartient car il y a un conflit d'IP

    Cordialement,

    Sylvain (MCP, MCTS Windows Server 2008 R2 Server Virtualization)

    Blog : http://sylvaincoudeville.fr


    mercredi 1 juillet 2015 05:58
  • Si vous n'avez aucun événement particulier sur les serveurs Exchange (observateur d’événement applicatif et système), vous pouvez vérifier les chemins physiques (cables, switch, routeur). La réalisation d'une trace réseau peut aussi vous donner des pistes.

    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    mercredi 1 juillet 2015 08:10
    Modérateur
  • Bonjour,

    Je vais donner plus de renseignements sur la configuration. Les serveurs sont sur un réseaux et les clients sur un autre. Afin que les clients puissent communiquer avec les serveurs ils passent par 2 routeurs (Qui sont relié par une interco).

    Clients -> Routeur Client -> Routeur Serveur -> Serveurs

    Serveurs -> Routeur Serveur -> Routeur Client -> Clients

    J'ai désactivé le NLB et créé une interface avec l'adresse IP VIP directement sur le serveur CAS primaire. Je me retrouve donc avec 2 cartes réseaux avec le même sous réseau. Dans mon cache ARP de mon serveur je retrouve les 2 adresses IP de mes interfaces ainsi des adresses MAC identiques.

    Exemple :

    Interface : 192.168.104.225 --- 0xb
      Adresse Internet      Adresse physique      Type
      192.168.104.195         XX-XX-XX-XX-00-27     dynamique (DAG1)
      192.168.104.196         XX-XX-XX-XX-00-6e     dynamique (DAG2)
      192.168.104.247         XX-XX-XX-XX-c4-3c     dynamique (FW)
      192.168.104.254         XX-XX-XX-XX-32-12     dynamique (FW)
      192.168.104.255         ff-ff-ff-ff-ff-ff     statique
      224.0.0.252           XX-XX-XX-XX-00-fc     statique
    
    Interface : 192.168.104.235 --- 0x10
      Adresse Internet      Adresse physique      Type
      192.168.104.26          XX-XX-XX-XX-2c-06     dynamique (Serveur)
      192.168.104.31          XX-XX-XX-XX-e9-20     dynamique (Serveur)
      192.168.104.32          XX-XX-XX-XX-e9-1f     dynamique (Serveur)
      192.168.104.34          XX-XX-XX-XX-00-62     dynamique (Serveur)
      192.168.104.60          XX-XX-XX-XX-00-02     dynamique (Serveur)
      192.168.104.170         XX-XX-XX-XX-00-10     dynamique (Serveur)
      192.168.104.171         XX-XX-XX-XX-00-0f     dynamique (Serveur)
      192.168.104.173         XX-XX-XX-XX-00-77     dynamique (Serveur)
      192.168.104.195         XX-XX-XX-XX-00-27     dynamique (DAG1)
      192.168.104.196         XX-XX-XX-XX-00-6e     dynamique (DAG2)
      192.168.104.206         XX-XX-XX-XX-00-09     dynamique (Serveur)
      192.168.104.210         XX-XX-XX-XX-00-0b     dynamique (Serveur)
      192.168.104.211         XX-XX-XX-XX-a2-d2     dynamique (Serveur)
      192.168.104.230         XX-XX-XX-XX-00-0c     dynamique (Serveur)
      192.168.104.247         XX-XX-XX-XX-c4-3c     dynamique (FW)
      224.0.0.252           XX-XX-XX-XX-00-fc     statique
    

    J'espère que ces informations peuvent vous donner une idée car si je n'arrive pas à trouver une solution je vais devoir faire appel un expert réseaux / exchange =)

    Encore merci de votre aide.

    Cordialement,

    mardi 7 juillet 2015 14:35
  • Bonjour,

    Vous amenez des informations très importantes : les clients et serveur sont séparés par des routeurs.

    Du coup, il n'y a pas vraiment de problématique MAC à voir, sauf si les problèmes d'adresse MAC concernent les routeurs (côté serveur ; ou côté clients).

    Pour faire avancer le diagnostic, lorsqu'un poste a le problème :

    • faire un tracert IP-DU-CAS
    • faire un arp -a pour vérifier si l'IP du routeur emprunté par le client n'est pas en conflit

    Il faudrait aussi regarder dans les routeurs s'il n'y a pas de VIP (ou redirections de ports) qui traineraient dans la config et qui utiliseraient une des IP des CAS.


    Cordialement,

    Sylvain (MCP, MCTS Windows Server 2008 R2 Server Virtualization)

    Blog : http://sylvaincoudeville.fr


    mardi 7 juillet 2015 14:44