none
Problème d'accès a un NAS RRS feed

  • Discussion générale

  • Bonjour/bonsoir.

    J'ai un problème assez fatiguant et incompréhensible, je possède un NAS Netgear ReadyNAS-Duo, et sur le pc fixe en Windows 10 d'où je vous écris, il y a 2 semaine, j'arrivais a accéder a mon NAS, et depuis, je n'arrive plus a accéder a aucun des dossiers, quand je double clique sur un partage dans le NAS, sa met au moins 10 seconde avant de me demander un MDP (ce qui n'est pas normal) et quand je rentre les identifiants de chaque utilisateurs que j'ai créer a partir du NAS, ça ne fonctionne pas (même avec le compte admin du NAS) ça me dis "\\READYNAS-DUO\Backup n'est pas accessible." Et en dessous il y a d'écrit (plusieurs connexions à un serveur ou ressource partagé par le même utilisateurs [...] ne sont pas autorisées.) Alors que personne d'autre à le mot de passe de chaque utilisateurs créé dans le NAS. Chose étonnante, sur mon PC portable quand je double clique sur le NAS dans les réseaux, il me demande un mot de passe, alors que sur mon PC fixe, il me demande aucun mdp (il me demande un MDP mais que quand je veux accéder a un des partages, et non quand je veux accéder au serveur dans les réseaux) , et quand je rentre le mdp, je peu accéder au serveur, mais cette fois si je peut accéder au dossier. Je possède un Micro-ordinateur RaspberryPI, et avec l'OS installé dessus en linux, j'accède au serveur sans problème.

    Hier, j'étais sur internet entrain d'écouter de la musique , et j'avais entendu le son quand il y a un message d'erreur, et quand j'ai réduis le navigateur il y avait un message qui me disait que la découverte des périphériques réseaux n'était pas activé, alors que j'avais strictement rien modifié dans les options , et quand j'ai cliquer sur "OK" dans le message d'erreur, et que j'ai accéder au serveur, j'ai mis mon mdp dans le partage que je voulais accéder, et chose miracle, ça a fonctionné. Et quand j'ai redémarrer l'ordi, rien ne va plus.

    Avez-vous une solution pour régler ce problème ?

    Dans l'attente d'une réponse, je vous souhaite de bonne fête de fin d'année !


    • Modifié LA_COOOO jeudi 28 décembre 2017 17:47
    • Type modifié LA_COOOO jeudi 28 décembre 2017 19:04
    • Type modifié Teodora Sharkova mercredi 3 janvier 2018 11:58
    jeudi 28 décembre 2017 17:46

Toutes les réponses

  • Bonsoir Loïc,

    Je vous remercie pour le lien que vous m'avez envoyé, mais je n'es pas se problème, mon NAS est reconnu dans les réseaux, sauf que quand je met un nom d'utilisateur et un mdp pour accéder au dossier depuis mon ordi fixe, je n'arrive pas a y accéder, même si je met le compte admin du nas.

    Je ne me connecte pas anonymement, je me connecte avec un nom d'utilisateur et un mdp qui a était créé depuis l'espace de paramétrage du NAS.

    J'avais réussi a y accéder après un reset de la carte réseau, mais dès un reboot de l'ordi, ça ne fonctionne plus. Tout a l'heure j'ai déplacer le nas d'un endroit croyant que c'étais mon switch qui causait des problèmes, et j'ai réussi a accéder au nas, mais dès que j'ai reboot l'ordi, je n'arrivais plus à accéder a un dossier sur le NAS.

    Alors que sur mon pc portable tout fonctionne normalement. Et je n'ai pas souvenir d'avoir installé un programme sur mon ordi fixe qui aurait un Malware ou autre.

    Dite moi si je m'exprime de façon incorrect.

    • Modifié LA_COOOO jeudi 28 décembre 2017 23:58
    jeudi 28 décembre 2017 23:42
  • Bonjour Momominta,

    j'ai regardé votre lien que vous m'avez envoyé, mais si je fais ça sur mon ordi, je ne vois plus les serveurs dispo dans l'onglet réseaux, et après la réactivation du SMB1, je vois de nouveaux les serveurs dispo mais je n'ai toujours pas accès a mon NAS.

    PS: Mon NAS n'est pas en windows server, c'est un os propre a lui

    vendredi 29 décembre 2017 13:25
  • Je sais que le problème viens uniquement de mon ordi, car sur mon ordi portable tout fonctionne normalement et sur mon raspberryPI tout fonctionne aussi.

    Il y a quelque chose sur mon ordi fixe qui fait que je ne peux pas accéder a mon nas, mais quoi, je ne sais pas, je sèche complètement.

    J'ai tester le reset de la carte réseaux : ça ne donne rien , restauration du système : rien non plus. la désactivation du SMB1 et SMB2 : toujours rien.

    le serveur est pas tout neuf je vais pas vous mentir, mais ce que je comprend pas c'est que tout fonctionnait il y à 2 semaine et, dès que je le rallume samedi dernier : ça ne fonctionne plus.

    vendredi 29 décembre 2017 16:13
  • Bonjour momominta,

    pourtant tout les service SMB sont activé sur mon ordi, et sur mon NAS c'est pareil, j'ai cocher une option dans le NAS qui se nomme "CIFT" et ça utilise les protocole SMB.

    La par exemple, je viens d'allumer mon ordi, et quand je vais dans les réseaux ça me dis que la découverte du réseau est désactivé, alors que, normalement, il était activé

    samedi 30 décembre 2017 12:09
  • @LA_COOOO : vous me confirmer ce que je pensais. Votre soucis vient viens de l'établissement initiale de la relation entre le NAS et le poste Windows 10. Sur votre NAS, dans la configuration SMB, forcer l'encryption. Si vous ne trouvez pas comment faire, configurer votre client Windows 10 pour autoriser le login anonyme :

    lancer une fenêtre PowerShell en mode Administrateur puis exécuter la commande:

    Set-SmbClientConfiguration -EnableInsecureGuestLogons $True

    Retester ensuite.


    Bonjour Loïc V.

    Le login anonyme est déjà activé sur mon ordi, et sur mon NAS, je vais voir si il y a une option pour activer l'encryption.
    samedi 30 décembre 2017 12:14
  • Bonjour,

    C'est cruel, mais ça soulage de voir que d'autres sont dans la même panade au même moment. Moi aussi j'ai un problème de NAS. Incompréhensible, le NAS (Mycloud) est visible depuis tous les autres PC du réseau et pas sur le mien. J'ai eu toutes les peines du monde à rétablir dans la nuit la connexion distante sur le serveur Western Digital (je n'ose plus toucher à rien maintenant). Quant aux lecteurs que j'ai pu mapper, il ne peuvent plus être déconnectés car ils sont réputés en cours d'utilisation (alors que je n'ai rien ouvert...). J'ai à peu près essayé tout ce que vous évoquez. IP fixe sur le routeur, changement de configuration réseau par déplacement des switches et des routeurs, activation de la découverte réseau (bien sûr!), redirection de ports, appels angoissés à Western Digital qui renvoie sur Microsoft, mappage avec les outils Western Digital, réinitialisation de Windows10, réinitialisation du NAS, et j'en oublie. Environ 400 heures (à la louche). Pour finir, c'est apparemment bien de Microsoft que vient le problème. J'a vu dans un forum que sous Windows 7 le problème avait été résolu en entrant le code Outlook au lieu du code PIN (https://forum.hardware.fr/hfr/WindowsSoftware/windows-10/problemes-partage-reseau-sujet_341013_1.htm). Mais sous Windows 10 il n'est plus question de code PIN (en tout cas je ne vois pas où). Par contre lorsqu'il s'agit de créer un lecteur à partir d'un fichier du NAS, les mots de passe demandés par Windows10 sont refusés, qu'on mette celui du NAS ou celui du compte Microsoft. Quant à l'identifiant proposé par défaut, c'est "Nobody". Et le mappage est impossible après deux tentatives, on a en effet le message "plusieurs connexions à un serveur ou à une ressource partagée par le même utilisateur, en utilisant plus d'un nom utilisateur (gnagnagna)". J'ai pour ma part une version de Windows 10 upgradée de Windows 8. Je ne sais pas si ça peut avoir une incidence. En tout cas je suis convaincu que c'est un bug qui vient de Microsoft. Et je fais le voeu que ce bug soit corrigé très très vite, parce qu'il est vraiment ...fatigant.

    Bonne année

    dimanche 31 décembre 2017 11:57
  • Bonjour momominta,

    pourtant tout les service SMB sont activé sur mon ordi, et sur mon NAS c'est pareil, j'ai cocher une option dans le NAS qui se nomme "CIFT" et ça utilise les protocole SMB.

    La par exemple, je viens d'allumer mon ordi, et quand je vais dans les réseaux ça me dis que la découverte du réseau est désactivé, alors que, normalement, il était activé

    Bonjour LA_COOOO,

    J'ai jeté un coup d'oeil à la configuration de votre NAS et il est dit ceci :

    Affectez une adresse IP statique au ReadyNAS et définissez votre PC avec une adresse IP statique dans le même sous-réseau.
    Connectez le ReadyNAS et la carte réseau PC à l'aide d'un câble Ethernet droit ou croisé.
    Allumez le ReadyNAS et scannez avec RAIDar pour localiser le ReadyNAS.

    Je suppose que vous avez fait cela. N'est-ce pas?

    >>La par exemple, je viens d'allumer mon ordi, et quand je vais dans les réseaux ça me dis que la découverte du réseau est désactivé, alors que, normalement, il était active

    Avez-vous la même configuration que l'image ci-dessous?



    Momominta

    Bonsoir Momominta,

    J'ai exactement la même configuration que sur votre screenshot.

    Mon NAS à une adresse IPV4 fixe, mon ordinateurs fixe non mais la box est configuré pour que chaque appareil qui est connecté en ethernet ou en wifi obtiennent une adresse IP et ils gardent toujours la même adresse IP. (Je vais tout de même configurer mon ordi pour qu'il n'utilise pas le protocole DHCP et lui attribuer une adresse IP fixe)

    Je n'ai pas brancher le NAS et mon ordi entre eux, j'aurais du faire ça, je l'ai fais avec mon ordi portable car mon CPL ne donnait plus de réseaux et ça a fonctionné.

    J'essayerais de brancher mon NAS directement sur mon ordi

    Chose que j'ai pas précisé c'est que sur mon NAS il y a 1 partage qui est en accès public, et j'arrive a y aller dessus sans problème, il y a un problème uniquement que quand je dois entrer un identifiant et un mdp.

    Passez de bonne fête !

    LA_COOOO

    dimanche 31 décembre 2017 16:24
  • Bonsoir momominta,

    veuillez m'excuser pour ma réponse assez tardif, j'en suis vraiment désolé.

    Je lirai les liens que vous m'avez envoyé.

    J'ai allumer mon ordi tout a l'heure, et j'ai démarrer mon NAS après, et j'ai réussi a accéder a mon serveur.

    J'ai éteint mon ordinateur et mon NAS car je partais de chez moi. Quand je suis rentré chez moi j'ai allumer mon ordi en premier et mon NAS après avoir allumé mon ordi, et j'ai réussi a accéder a mon serveur, j'ai redémarrer mon ordi est résultat j'ai plus accès au serveur.

    On dirais que le problème apparaît que quand j'allume le serveur en premier. et quand je redémarre le PC alors que le serveur est ON, je vais refaire des test a démarrer l'ordi puis le NAS afin de voir si j'accède au NAS.

    Bonne soirée

    samedi 6 janvier 2018 20:51
  • Bonjour momominta,

    Je suis pas le seul a avoir ce problème, ça me rassure, j'espère que Windows va régler ce soucis le plus rapidement possible.

    Maintenant j'ai un autre problème, mais c'est hors sujet :/


    • Modifié LA_COOOO dimanche 7 janvier 2018 12:13
    dimanche 7 janvier 2018 12:07
  • Bonsoir momominta,

    J'ai trouvé comment accéder à mes partages de mon NAS, il faut que j'y accède via l'adresse IP du nas, et dès que je met mon login et mdp, je peut accéder a mes partages, mais je ne sais toujours pas pourquoi je peut accéder a mon nas avec le nom et non avec l'adresse IP, mais dès que je rentre le login et le mdp je ne peux pas accéder a mes partages du NAS.

    LA_COOOO

    dimanche 7 janvier 2018 16:44
  • Voici ce que j'ai comme type de services pour le partage de fichiers

    LA_COOOO

    dimanche 7 janvier 2018 16:49
  • Bonsoir Loïc VEIRMAN et momominta,

    C'est un serveur assez vieux, donc forcément windows a changé au niveau de la sécurité, je peux accéder a mon NAS avec l'adresse IP donc sa me dérange pas, faut juste que je créer des raccourcis pour le NAS et c'est bon.

    Mais la seule chose que je percute toujours pas c'est que ça fonctionnait sur mon ordi, et que la maintenant ça ne fonctionne plus, alors qu'avec mon pc portable qui a les dernières maj de Windows d'installé, j'ai pas ce soucis.

    Après j'ai que 17 ans, donc il y a beaucoup de choses que je connais pas que je vais apprendre au fils du temps.

    Maintenant que mon compte est vérifié et que je peu poster des captures d'écran, je vais vous montrer ou je dois rentrer mes logins sur mon PC portable et sur mon PC fixe :

    sur mon pc portable je dois rentrer le login et mdp a cette endroit :

    alors que sur mon PC fixe je dois le rentrer a cette endroit (dans le NAS):

    j'ai comparé le Get-SmbClientConfiguration et le Get-SmbServerConfiguration et les 2 PC ont la même configuration.

    LA_COOOO

    dimanche 7 janvier 2018 17:12

  • Si vous pouvez accéder au NAS à partir de l'adresse IP des deux ordinateurs alors votre problème n'en est plus vraiment un. 


    Momominta

    C'est juste que je viens de découvrir ce problème seulement maintenant, sinon je savais pas que ça fonctionnait et donc j'étais bloqué sur ce problème, mais la je viens de découvrir que ça fonctionne avec l'adresse IP.

    LA_COOOO

    dimanche 7 janvier 2018 17:55
  • Je n'ai pas de nom et mots de passe utilisateur enregistrés pour le NAS,

    Maintenant que je peux accéder a mon NAS avec mon adresse IP, je peu placer le sujet en résolu.

    Je vous remercie momominta et Loïck V d'avoir consacré du temps a mes soucis.

    LA_COOOO
    • Modifié LA_COOOO dimanche 7 janvier 2018 17:57
    dimanche 7 janvier 2018 17:57
  • J'ai que ça :

    dimanche 7 janvier 2018 18:11
  • @Momomita : je connais et ma demande n'a rien à voir avec le résultat mais avec un browsing qui ne demande pas d'authentification. Il n'y a que deux possibilités : un compte déjà authentifié (en permanent ou pour la session en cour), ou l'autorisation du compte invité.
    dimanche 7 janvier 2018 18:28
  • @momominta

    L'adresse IP fixe est déjà configuré.

    dimanche 7 janvier 2018 18:33
  • @Loïc Veirman

    LA_COOOO

    • Modifié LA_COOOO dimanche 7 janvier 2018 18:38
    dimanche 7 janvier 2018 18:36

  • @La_Coooo : tu as activé l'option "EnableInsecureGuestLogons", c'est cela qui permet le browsing sans authentification préalable. Vérifie sur le deuxième, mais je pense que l'option est à FALSE et non TRUE. Pour le modifier et avoir le même comportement : 

    Set-SmbClientConfiguration -EnableInsecureGuestLogons $True

    @Loïc

    Sur les 2 Pc "EnableInsecureGuestLogons" est a True.

    LA_COOOO

    dimanche 7 janvier 2018 18:44
  • Dans ce cas, le deuxième PC a une configuration qui interdit malgré tout les connexions anonymes. Je te recommande de toute façon de mettre les deux à False, pour des raisons de sécurité.
    J'ai tout mis a False comme vous m'avez conseillé.
    dimanche 7 janvier 2018 18:50
  • Bonsoir @Loïc et @momominta,

    vous allez pas me croire, mais j'ai quand même ce bug en me connectant avec l'adresse IP sur le NAS.

    Là, je suis perdu... j'hésite a réinstaller windows...

    LA_COOOO

    lundi 8 janvier 2018 19:25
  • Bonsoir @Loïc et @momominta,

    vous allez pas me croire, mais j'ai quand même ce bug en me connectant avec l'adresse IP sur le NAS.

    Là, je suis perdu... j'hésite a réinstaller windows...

    LA_COOOO

    Ce bug ne ce produit pas tout le temps, il se produit a certain moment... Mais bon pour éviter d'avoir encore des ennuie, je pense remettre Windows a 0.

    LA_COOOO

    lundi 8 janvier 2018 20:25
  • Bonsoir @Loïc et @momominta,

    j'ai réactiver l'EnableInsecureGuestLogons,

    Pour l'instant je n'ai plus ce problème (On dirais qu'il arrive de façon aléatoire),

    j'ai eu comme idée pour essayer d'éviter le problème :

    - Mémoriser le mdp pour accéder au NAS sur windows,

    - Allumer l'ordi après que le NAS sois allumé (pour éviter le fait que quand j'allume l'ordi il me dis "impossible de reconnecter les lecteurs réseaux", et que quand le serveur est allumé, il arrive plus a se connecter sur le NAS a cause de ce fameux bug)

    @Loïc

    L'alternative que vous avez envoyé en Lien n'est pas compatible avec mon NAS (Readynas-DUO), je n'ai pas du tout les même menu, et je tourne avec un vieux OS sur le NAS qui est plus mis a jour.

    LA_COOOO


    mardi 9 janvier 2018 22:52
  • Bonsoir @Loïc et @momominta,

    Je vous tiendrez au courant si ce bug se reproduit ou si une maj a corrigé le bug.

    Oui, un jour il faudrait que je change de NAS, quitte a faire mon propre NAS maison en installant debian ou autre chose, comme ça j'aurais accès a beaucoup plus de fonction qu'un NAS.

    LA_COOOO

    jeudi 11 janvier 2018 16:51