none
reverse proxy rds RRS feed

  • Discussion générale

  • bonjour a tous,

    ma question est la suivante.

    utilisez vous un reverse proxy pour rds et si ou le quel.

    j ai  tester nginx et apache.

    le connexion a iis pas de probleme mais pour laisser une application, c est fume, a cause de l initialisation de la session.

     erreur:

    L’utilisateur « orabache@domin » de l’ordinateur client « 192.168.2.136:46806 » a établi une connexion entrante. Il se peut que cette connexion ne soit pas encore authentifiée.

    la je vais prendre haproxy pour voir.

    merci

    bonne journée

    mardi 5 mai 2020 10:50

Toutes les réponses

  • Bonjour olivier,

    Vous passez par une gateway RDS ou directement sur du RDP ?

    Normalement en passant par une gateway, il n'y a pas de probleme.

    Romain

    mardi 5 mai 2020 14:22
  • bonjour,

    gateway rds.

    peux tu detailler pas de probleme.

    merci

    mardi 5 mai 2020 15:25
  • Bonjour,

    D'après ton message, je pense surtout que c'est un problème de configuration.

    Normalement ton utilisateur attaque la GW en 443 puis derriere celle-ci à un role "reverse proxy" en allant chercher le BaD sur le 3389.

    Je suppose que sans reverse proxy la gateway fonctionne ?

    As tu des erreurs sur Nginx ?

    Romain

    jeudi 7 mai 2020 06:48
  • bonjour romain,

    avec nginx c est pas possible car uniquement http /https.

    j ai fini de configurer sous haproxy qui a un mode tcp.

    avec nginx et apache en reverse pas d access a la passerelle rds.

    La connexion tcp vers la gateway se faisait par https et posait n probleme d authentification.

    Haproxy sans le mode tcp, au moment de lancer une applis et me redemandait de m authentifier, et générai l erreur indiquée ci-dessus (voir post).

    Après moult recherchai il s avère que seul haproxy permettait ce mode, pas apache ni nginx.

    frontend rdp# serveur rds
      bind :443  ssl crt /etc/haproxy/protect.pem
      #mode http
      mode tcp
      log global
      
      
      maxconn 1000
      #acl path_rdweb path_beg -i /RDWeb/
      #http-request redirect location /RDWeb/ if { path -i / /RDWeb }
      #http-request deny unless path_rdweb
      default_backend rdp
    
    #########################################################################
    
    frontend nas 
    
    	bind *:80 #HAproxy écoute sur le port 80
     	mode http #Activation du mode HTTP
     	option httplog #Activation des logs
    acl nas hdr_end(host) domaine1.local #Si le host termine par "domaine1.local" alors l'acl "host_web1_via_http" est vrai
    use_backend nas if nas
    
    
    
    #########################################################################
    backend rdp
      balance leastconn
    	timeout client 300s
    	capture request header Host len 32
      timeout connect 4s
      timeout server 300s
      option httpchk GET /
      cookie RDPWEB insert nocache
      default-server inter 3s    rise 2  fall 3
      server srv01 x.x.x.x:443 maxconn 1000 weight 10 ssl check cookie srv01
    
    ###################################################################
    
    backend nas
      balance leastconn
    	timeout client 300s
    	capture request header Host len 32
      timeout connect 4s
      timeout server 300s
      option httpchk GET /
        default-server inter 3s    rise 2  fall 3
      server nas x.x.x.x:8000 ###########################
    
    
    
    
    je laisse une copie du hap.conf ca peux toujours servir

    Il n est pas entièrement fait, mais fonctionnel.

    comme je découvre haproxy, il faut que je regarde ce qui est inutile dans la conf.

    a+

    par contre si tu a fait tourne nginx en rds , je suis preneur pour me couche moins c....

    jeudi 7 mai 2020 18:47