none
Can't display sharepoint page in an environment without internet connection

    Question

  • Hi All,

    My environment is running a farm consisting of 2 servers on Server 2012R2.

    These servers are clones imported from production side.

    When I try to pull up the page that the end user would see I get "Sorry, something went wrong. An unexpected error has occurred"

    The event log produces event ID 6398:

    "THe Execute method of job definition Microsoft.SharePoint.Administration.SPLicenseRenewalJobDefinition ( ID x) threw an exception. More information is included below.

    Sorry, we can't seem to connect to the SharePoint Store. Try again in a bit."

    I can't find a hit on google for the SPLicenseRenewal and "Threw an exception".

    I've disabled the customer improvement experience on the pages, and sharepoint in general and it still doesn't work.

    Any help would be greatly appreciated.

    Thanks,

    Jerry

    vendredi 18 mai 2018 15:41

Toutes les réponses

  • Try clearing SharePoint configuration cache:

    1. Stop the timer service on all SharePoint servers in the farm
    2. On each SharePoint Server, A) go to: C:\ProgramData\Microsoft\SharePoint\Config\GUID, B) keep the INI file and delete all XML files in the folder, and then C) open the INI file and change its number to "1" then save it. Once you're done, there should only be the single INI file in this folder.
    3. Start the timer service on all SharePoint servers in the farm.

    It doesn't matter what the number is in the INI file. For example, for one small farm I maintain, the single application server had one number and each web front end had the same number as the other WFE but this number was different than the application server number.

    NOTE: there may be more than one folder in C:\ProgramData\Microsoft\SharePoint\Config\. Select the most recent one.

    References

    vendredi 18 mai 2018 17:35
  • Hi,

    It looks any of your user seems to be added the apps from store. Ask them to remove Add-In from their page. Then you can restrict the "SharePoint Store or app catalog" option from your administration page.

    You can also run this PS command

    Set-SPAppStoreConfiguration -Enable $false


    Murugesa Pandian MCSA,MCSE,MCPD

    Gear up for some solid action by doing. Slide,theory and blog won't useful much. 
    After all world likes only doers not sayers/speakers .

    dimanche 20 mai 2018 05:18
  • Hi Jerry,

    Is there any update?

    If the issue exists, try to go to Central Admin->Manage Web Applications->select the web-application and click Manage Features in the ribbon.

    Activate “Apps that require accessible internet facing endpoints” feature.

    Then Start->Run->IISREST to reset iis.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    lundi 21 mai 2018 10:33
  • Hello Everyone,

    I've tried the solutions proposedby Grace Wange, Murugesa Pandian, and Stephan Bren.

    Nada.

    WEbpage just says : Sorry, something went wrong. An unexpected error has occurred.

    Upon clicking on "technical details" I just get a Correlation ID, and Date and Time. I googled correlation ID but I guess its truly unique.

    On the sharepoint server the only errors I get are Event 8198: License Activation (slui.exe) failed with the following error code:

    hr=0x80072EE7

    I'm not sure if that would cause for the sharepoint page to not display.

    I also get Error 1014,

    Acquisition of End user license failed. hr=0x80072EE7

    And error 21591,

    Event 5586 (SharePoint Foundation) of severity 'Error' occurred 15 more time(s) and was suppressed in the event log.

    I'll keep googling. I appreciate everybody's help.

    il y a 8 heure(s) et 51 minute(s)
  • Hi SilentCow,

    Firstly, you can check the detailed log information in ULS log based on the correlation id, ULS is at:

    C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\LOGS

    Here is a similar post based on your error message for your reference:

    https://social.technet.microsoft.com/Forums/lync/en-US/c017cd0b-74dc-4295-9820-7af3d004d1f4/software-protection-platform-service-error-license-activation-sluiexe-failed-with-the-following?forum=win10itprosetup

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    il y a 4 heure(s) et 5 minute(s)