none
Fenêtre d'authentification Outlook 2013 Exchange 2007 RRS feed

  • Question

  • Hello,

    j'ai parcouru beaucoup de fofos, testé plein de truc niveau sécurité IIS, paramèrtes Exchange etc je n'ai plus d'idées ce problème est devenu mon cauchemar.

    Outlook 2013, Exchange 2007 (à jour)

    En interne, quand on ouvre Outlook, il marque connecté puis après quelques secondes le prompt d'authentification s'ouvre, après ça si mets le mot de passe ça passe mais il n'enregistre pas le mot de passe, soit il faut fermer la fenêtre et cliquer sur mot de passe requis. La fenêtre revient évidemment à chaque fois que l'on ouvre Outlook.

    Comment faire pour ne plus voir ce prompt ? Une info importante, on passe par unfirewall, tant que nous ne sommes pas authentifiés sur internet, pas de prompt donc il y a surement une connexion qui passe par l'extérieur mais quoi ??

    Dites moi ce dont vous avez besoin comme info je donnerai toutes les infos possibles ou presque :)

    Merci d'avance à tous les participants

    mercredi 17 septembre 2014 10:28

Réponses

  • résultat de la commande :

    InternetURL : https://monserveur.domaine.local/OAB

    ExternalURL : https://extranet.entreprise.com/OAB

    BasicAuthentification : False

    WindowsAuthentification : TRUE

    InternalAuthentificationMethods : Windowsintegrated

    ExernalAuthentificationMethods : Windowsintegrated

    j'ai constaté une chose, en changeant le host de la façon suivante :

    IPinterneSRVEchange    extranet.entreprise.com

    Le prompt ne s'affiche plus... donc je peux le contourner pour mes utilisateurs internes par contre si un nomade se connecte sur le réseau interne il a tjs le prompt

    Est ce que le problème se pose juste pour les utilisateurs internes ou les Outlook anywhere aussi ?

    En Outlook Anywhere il y a un prompt qui s'affiche mais ça c'est normal vu qu'ils se connectent de l'extérieur (enfin je crois) par contre tout utilisateur qui essaye de se connecter en interne à le prompt plus fois qui s'affiche (maintenant 2)

    je vais vérifier  le certificat SSL


    jeudi 18 septembre 2014 10:13

Toutes les réponses

  • En général, si vous avez les emails mais qu'il demande un mdp, c'est qu'il n'arrive pas à s'authentifier de façon transparente sur un VDIR.

    tant que nous ne sommes pas authentifiés sur internet,

    Vous voulez dire que vous avez besoin de vous authentifier pour sortir sur Internet?


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    mercredi 17 septembre 2014 12:47
    Modérateur
  • On passe par un proxy effectivement, par contre Outlook 2007 pas de prompt, donc ça ne concerne qu'Outlook 2013, il doit y avoir des différences au niveau de l'authentification

    pour le proxy, tant que nous ne sommes pas connectés à Internet pas de prompt, après s'être connecté à Internet le prompt apparait

    mercredi 17 septembre 2014 12:59
  • il faudrait voir côté firewall les flux sortants provenant de vos Outlook par exemple.

    Une autre astuce serait de voir la fenêtre "Etat de la connexion" sur outlook lorsqu'il demande les credentials, une ou plusieurs entrées doivent être dans l'état "Connexion" par exemple.


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    mercredi 17 septembre 2014 13:21
    Modérateur
  • dans Etat de la connexion il y a une ligne dans l'onglet boite aux lettres locales qui dit (pendant que le prompt est affiché) :

    Carnet d'adresses en mode hors connexion en cours de connexion à Microsoft Echange

    je vais vérifier au niveau du firewall

    mercredi 17 septembre 2014 14:10
  • Salut

    Sur le 2007 les clients se connectent via rpc over HTTP sur une plage de port tcp dynamiques, qui peuvent être fixés.

    Par contre sur exch 2013 on ne passe plus que sur du 443, plus de connexion rpc comme auparavant.

    Il faud dans ce cas verifier ces deux choses:

    Receive connector au niveau exchange : authentification en basic ou en windows authentication ?

    Puis en deuxième vérifier les paramètre du virtual directory sur le IIS (authentication) mettre l'authentification en anonymous.

    a+



    mercredi 17 septembre 2014 14:24
  • C'est du Exchange 2007 avec client 2013 :)

    du coup est-ce qu'il faut tout de même vérifier ces paramètres ?


    A noter que l'on a du Outlook Anywhere configuré en authentification de base (côté client) mais ça semble standard ça, on a essayé de le passé en ntml mais les nomades ne parvenaient plus à se connecter
    • Modifié TechOAB mercredi 17 septembre 2014 14:34
    mercredi 17 septembre 2014 14:32
  • Quel est le CAS server ? 2007 ou 2013 ?

    Dans le cas des utilisateurs distants, Les requêtes 443 arrive sur le firewall ou sur le reverse proxy en Dmz puis sont balancées sur un CAS server. quel est ce serveur ? 2007 ou 2013

    Pour les utilisateurs interne s'ils sont sur le même vlan dans ce cas on ne passe plus par les éléments réseau, et il faudra vérifier la configuration du IIS et la méthode d'authentification.

    J'ai eu le meme soucis avec exch 2010 et changement du paramètre sur le iis m'a solutionné le soucis.

    a+

    Yahia 

    mercredi 17 septembre 2014 14:53
  • Oh pardon je n'ai pas vu que c'etait des clients 2013 et non exchange 2013


    mercredi 17 septembre 2014 15:02
  • Il faut vérifier les paramètres de connexion au virtual directory OAB.

    Il suffit par exemple d'afficher les paramètres via la cmdlet :

    Get-OabVirtualDirectory | fl *url,*authen*


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    mercredi 17 septembre 2014 15:16
    Modérateur
  • Est ce que le problème se pose juste pour les utilisateurs internes ou les Outlook anywhere aussi ?

    Si les deux posent problème dans ce cas il faudra vérifier si le certificat ssl sur l'exchange est encore valide ou pas ? me concernant je monte tjrs un Root CA et je supprime l'autosigné d'exchange en n'oubliant pas de mettre les San alternate name qui vont bien.

    Bon courage pour la suite

    mercredi 17 septembre 2014 15:21
  • résultat de la commande :

    InternetURL : https://monserveur.domaine.local/OAB

    ExternalURL : https://extranet.entreprise.com/OAB

    BasicAuthentification : False

    WindowsAuthentification : TRUE

    InternalAuthentificationMethods : Windowsintegrated

    ExernalAuthentificationMethods : Windowsintegrated

    j'ai constaté une chose, en changeant le host de la façon suivante :

    IPinterneSRVEchange    extranet.entreprise.com

    Le prompt ne s'affiche plus... donc je peux le contourner pour mes utilisateurs internes par contre si un nomade se connecte sur le réseau interne il a tjs le prompt

    Est ce que le problème se pose juste pour les utilisateurs internes ou les Outlook anywhere aussi ?

    En Outlook Anywhere il y a un prompt qui s'affiche mais ça c'est normal vu qu'ils se connectent de l'extérieur (enfin je crois) par contre tout utilisateur qui essaye de se connecter en interne à le prompt plus fois qui s'affiche (maintenant 2)

    je vais vérifier  le certificat SSL


    jeudi 18 septembre 2014 10:13
  • https://monserveur.domaine.local/OAB

    Vous avez ajouter cette URL au exclusion de votre proxy d'entreprise, si celui-ci est en coupure entre les clients et le serveur Exchange?


    Bruce Jourdain de Coutance - Consultant MVP Exchange http://blog.brucejdc.fr

    jeudi 18 septembre 2014 12:25
    Modérateur
  • Bonjour,

    Pouvez vous lancer le IIS sur le serveur exchange et valider ces points:

    Au niveau du default web site

    choisir le répertoire RPC

    A droite sur le panneau de configuration aller sur l'onglet authentication

    Puis s'assurer que ces deux paramètres sont sur "Enabled" Activé

    "Windows Authentication" et "Basic Authentication"

    mardi 23 septembre 2014 13:05
  • Bonjour

    generalement c'est un pb de coupure reseau ou de changement de reseau

    il faut découcher la case outlook any where si vous etes sur votre lan using http a desactiver

    generalement ça arrive plu ssur les laptop  !


    Partager c'est avancer : Votez!SVP

    mercredi 24 septembre 2014 11:26