none
Problème de lancement de workflow sharepoint 2013 suite à la modification du nom d’un fichier depuis l’explorateur Windows RRS feed

  • Discussion générale

  • Bonjour à tous,

    Je vous présente mon problème…

    J’ai créé un workflow très simple depuis SharePoint designer 2013 qui consiste à mettre le nom du fichier dans le champ de l’état du workflow. J’ai configuré ce workflow pour qu’il s’exécute à la création d’un item de liste (ce qui fonctionne parfaitement) et aussi à la modification d’un item et c’est là que j’ai un problème. Si je modifie le nom du fichier depuis l’interface web pas de problème, mon workflow s’exécute mais si je modifie le nom du fichier depuis l’explorateur Windows (via un lecteur réseau webdav) le workflow ne démarre pas…le nom du fichier est bien modifié mais le workflow ne démarre pas.

    On dirait que la modification d’un nom de fichier depuis l’explorateur Windows n’est pas considérée comme une modification de fichier par le système de Workflow…

    Dans le cas de la création de fichier la par contre aucun problème, cela fonctionne si je créer un fichier depuis l’explorateur et depuis l’interface web…

    Est-ce que vous avez des pistes concernant ce problème ?

    Merci d’avance de votre aide et bonne journée.

    Gaétan
    mercredi 23 juillet 2014 07:10

Toutes les réponses

  • Bonjour,

    Je suppose que vous utilisez des EventReceivers, si oui ils ne sont pas déclenchés lors de modifications effectuées via webdav.

    Extrait de la page Event Troubleshooting :

    ISSUE #3
    When you rename a file in a document library by using WebDAV in Explorer view, the renaming event does not raise the ItemUpdating(SPItemEventProperties) and ItemUpdated(SPItemEventProperties) events, unless you also change the file extension when renaming the file.
    Resolution: None.


    My technical blog on SharePoint || My contributions on the TechNet Gallery

    mercredi 23 juillet 2014 07:43
    Modérateur
  • Bonjour et merci pour votre réponse,

    ce dont vous me parlez semble bien en rapport avec ma problématique et je vais creuser plus précisément le paramétrage des EventReceivers. j'ai juste peur que cela ce gère au niveau de Visual Studio et je n'ai jamais mis les mains dedans...

    pour le moment je travail uniquement a partir de SharePoint Designer 2013 et de l'administration centrale de SharePoint 2013. 

    je creuse la question sur internet et reviens sur le forum pour apporter le fruit de mes recherches.

    encore merci et bonne journée.

    gaétan

    mercredi 23 juillet 2014 08:11